[SOLVED] KDE reverse/natural scrolling not working

kde

#1

Hi, Reverse scrolling is not working on mouse but works when set up on touchpad, it’s like recent kde settings version don’t pass it through cause it worked like 2 months earlier…
I DO like this feature and find it superior, more Natural… and would like to still use it like I was in kde4. Should I file the bug report to KDE? Could someone just check If it works on other machines to be sure I’m not isolated please?


#2

you are very helpful guys. so difficult to go to settings if you are kde user and tick reverse scrolling? gonna have to move over to arch to use their forum or what?


#3

Manjaro uses libinput wich isnt supported by the KDE. so to get this you have 2 options:


#4

Thanks for reply! Option 2 worked but had to install xf86-input-synaptics otherwise touchpad was not recognised.
xf86-input-libinput phases out xf86-input-libinput apparently and this solution might not last for long (eg on Kwayland). Works so far in Kwin. Thanks again Tids!


#5

I just edited the file /usr/share/X11/xorg.conf.d/40-libinput.conf and added the Option “NaturalScrolling” “true” entry in the first section:

Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "NaturalScrolling" "true"
EndSection

I worked fine and I didn’t have to uninstall anything.


#6

Uninstalling xf86-input-libinput suggested me to uninstall dependent files like xorg or nvidia drivers, so i just installed xf86-input-synaptics and rebooted. Now all options in settings are available, scrolling works perfectly.
40-libinput.conf editing didn’t help.


#7

Nowadays libinput is supported by Plasma so it can be set normally from system settings. I use it and natural scrolling like other basic options work as intended.

Additionally, there is an AUR package called libinput-gestures that adds more gestures. This isn’t possible on synaptics driver.


#8

xf86-input-libinput is not supported by Plasma or Qt. Also on wayland (where libinput is suported) there is no option to enable natural scrolling in the systemsettings of 5.9.5. If it works for you on X, you’re using the other input driver.


#9

Can’t be. Manjaro comes with libinput by default. No synaptics drivers on board. Additionally, libinput-gestures package is working well for me, so all points to the libinput working. I do have natural scrolling and I can set it from plasma system settings.

I remember a year ago, situation was different. Back then synaptic driver was as default and libinput had to be installed manually. When I switched, all plasma settings became grayed out. This is not true since over half year or more.


#10

Wait … i’m talking about the situation for mices. Are you talking about touchpads? :joy:


#11

Uh, sure… I was talking about pads all the time :hushed: Didn’t read carefully… Sorry.
The whole point of natural scrolling is that pad would feel like a touch area on a device like a phone or a tablet. On a mouse, scroll should be just the way it was since the beginning. The idea reversed scrolling on a mouse is so weird I assumed you must be talking about pad.

EDIT: I checked mouse and the option of natural scrolling really doesn’t do anything.


#12

It is. for the last 10 years I’m using natural scrolling on my mices and its so much better to scroll on every device the same way :smiley:

But who cares about it anyways :wink: