[Solved] KDE Plasma 5.10.2 crash every 10 minutes

kde
plasma
#1

Hi, since updating KDE Plasma 5.10.1 to KDE Plasma 5.10.2.I have big problems I have already tried to remove the non-native plasmoid and downgrade to KDE Plasma 5.10.1 but nothing makes it, plasmashell only crashes. At first it crashed if we played a little too much with the parameters then every hour and then after 10 minutes or as soon as I click on an object of the dashboard. After having turned it into a terminal, here is what results :WARNING: Cannot find style "org.kde.desktop" - fallback: "/usr/lib/qt/qml/QtQuick/Controls/Styles/Desktop fish: 'plasmashell' terminated by signal SIGSEGV (Erreur de frontière d'adresse)

Here’s the result of coredumpctl gdb :

PID: 5992 (plasmashell)
       UID: 1000 (astumed)
       GID: 1000 (astumed)
    Signal: 11 (SEGV)
 Timestamp: Thu 2017-06-22 13:01:27 CEST (5min ago)
 Command Line: plasmashell
Executable: /usr/bin/plasmashell
 Control Group: /user.slice/user-1000.slice/session-c2.scope
      Unit: session-c2.scope
     Slice: user-1000.slice
   Session: c2
 Owner UID: 1000 (astumed)
   Boot ID: 39cbd4bf5b7d422db6fd1cf74845e4a1
Machine ID: 9c5e73d145bc45749a3150aba0dde844
  Hostname: astumed-pc
   Storage: /var/lib/systemd/coredump/core.plasmashell.1000.39cbd4bf5b7d422db6fd1cf74845e4a1.5992.1498129287000000000000.lz4
   Message: Process 5992 (plasmashell) of user 1000 dumped core.
                   Stack trace of thread 5992:
            #0  0x00007f3b01268fe7 n/a (n/a)

bt
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/plasmashell...(no debugging symbols found)...done.
BFD: Warning: /var/tmp/coredump-Gg5O7h is truncated: expected core file size >= 2638778368, found: 2147483648.
[New LWP 5992]
[New LWP 6010]
[New LWP 5995]
[New LWP 5997]
[New LWP 5994]
[New LWP 5993]
   [New LWP 5999]
   [New LWP 6001]
   [New LWP 6002]
   [New LWP 5996]
   Cannot access memory at address 0x7f3b06b8d0c8
Cannot access memory at address 0x7f3b06b8d0c0
Failed to read a valid object file image from memory.
Core was generated by plasmashell.
Program terminated with signal SIGSEGV, Segmentation fault.
 0  0x00007f3b01268fe7 in ?? ()
 [Current thread is 1 (LWP 5992)]
(gdb) bt
0  0x00007f3b01268fe7 in ?? ()
   Backtrace stopped: Cannot access memory at address 0x7ffcf806ca40

So I hope someone can help, btw inxi -F results

System:    Host: astumed-pc Kernel: 4.11.5-2-ck-core2 x86_64 (64 bit) Desktop: KDE Plasma 5.10.2
       Distro: Manjaro Linux
Machine:   Device: desktop System: Dell product: OptiPlex 755
       Mobo: Dell model: 0PU052 BIOS: Dell v: A11 date: 08/04/2008
CPU:       Dual core Intel Core2 Duo E6750 (-MCP-) cache: 4096 KB
       clock speeds: max: 2667 MHz 1: 2000 MHz 2: 2000 MHz
Graphics:  Card: Intel 82Q35 Express Integrated Graphics Controller
       Display Server: x11 (X.Org 1.19.3) driver: intel Resolution: 1440x900@74.98hz
       GLX Renderer: Mesa DRI Intel Q35 GLX Version: 1.4
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel
       Sound: Advanced Linux Sound Architecture v: k4.11.5-2-ck-core2
Network:   Card-1: Intel 82566DM-2 Gigabit Network Connection driver: e1000e
       IF: enp0s25 state: down mac: 00:21:70:49:49:3f
       Card-2: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] driver: pcnet32
       IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 00:15:77:ad:25:8e
Drives:    HDD Total Size: 160.0GB (25.3% used)
       ID-1: /dev/sda model: WDC_WD1600AAJS size: 160.0GB
Partition: ID-1: / size: 74G used: 26G (35%) fs: btrfs dev: /dev/sda1
       ID-2: /home size: 74G used: 11G (15%) fs: btrfs dev: /dev/sda2
       ID-3: swap-1 size: 2.10GB used: 0.07GB (3%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A
       Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 225 Uptime: 1:27 Memory: 893.9/1957.4MB Client: Shell (fish) inxi: 2.3.20
1 Like

#2

Could be a config issue, some other users have reported various Plasma issues since migrating to 5.10. Your stability issues seem more serious, but could be a similar root cause.

Have a look at this thread and the solution, which was to rename KDE config files, logout and login to re-generate them.

It may be a bit hit and miss and some persistence / patience will be required. I don’t know exactly what you downgraded, but I’d recommend upgrading again to 5.10.2 and backing up your config before you begin.

You could rename everything, or approach this in a more fine grained manner, but as long as you have the files backed up you can revert if you wish.

Just be warned that you’ll probably lose some of your settings during this process, but they are easy to repeat once your system is stable.

0 Likes

#3

I just had a very similar experience.

I was playing around with my Plasma config in System Settings when Plasma crashed. Straight after it became very unstable, layout was completely screwed up and compositor wouldn’t work. Reboot did not remedy.

Remembered the thread I referenced above, renamed the following files and rebooted.

plasma-org.kde.plasma.desktop-appletsrc.bak
plasmarc.bak
plasmashellrc.bak

After reboot they were auto-generated again, without the errors causing the instability.

I had to manually re-enable the compositor in System Settings, and I had to setup my desktop and panels again, but everything is now back to normal.

Handy tip for any KDE users to remember.

2 Likes

Plasma crashes
Plasmashell fails to start
Plasma panel widgets won't show up after switching virtual desktop
#4

Thanks but where are the files you mentionned above ? In the .config or a root directory I don’t know the existence…
Thanks in advance

1 Like

Plasmashell unable to start anymore
#5

Those files @sueridgepipe mentioned are in .config folder of your user.

1 Like

#6

Thanks for your fast response

1 Like

#7

/home/[username]/.config directory.

Obviously the .bak file exensions I appended during the rename of these files.

1 Like

#8

To regenerate plasma config.

cd ~/.config
for j in plasma*; do mv -- "$j" "${j%}.bak"; done

To rebuild cache

mv ~/.config/Trolltech.conf ~/.config/Trolltech.conf.bak
mv ~/.cache/ ~/cache.bak
mkdir ~/.cache
kbuildsycoca5 --noincremental && kbuildsycoca4 --noincremental

Later if required u can delete .bak files and directories.

0 Likes