[Solved] It takes too long to open or save files in XFCE


#1

I will try to describe my situation. Last year I changed my default desktop from Cinnamon to XFCE and was very happy with the change.

But lately I noticed that in some applications, for example GIMP to activate the option to open a file takes more than 20 seconds to appear. The second time I do it does not take so long, but if I close the application and do the same, again it takes time to open the dialog box.

I suppose it’s conflict between XFCE and what’s left of Cinnamon, but I’m not sure.

Any suggestions will be appreciated.


#2

I ran GIMP from a terminal and I get this message, I think it can give me a clue.

gimp: gimp_wire_read(): error
Error creating proxy: Error al llamar StartSereviceByName para org.gtk.vfs.UDisks2VolumeMonitor: Se alcanzó el        tiempo de expiración (g-io-error-quark, 24)

#3

I found the problem. It was not really a problem on my computer.

A server has passed away and I had 3 folders declared in the fstab file that automatically mounted those folders in my home directory.

Once I commented the lines that connect to the fallen server and rebooted the computer everything has returned to normal.

This is one of the problems that you find solution right after posting in the forums. :neutral_face: