[SOLVED] Intel PRO/Wireless 4965 Microcode SW error occuring roughly every minute


#1

Hello, I’m asking for help due to an issue I observed on a fresh install of Manjaro KDE stable 18.0.2 (4.19.23-1-MANJARO #1 SMP PREEMPT Fri Feb 15 21:27:33 UTC 2019). OS has been installed on an old machine of my mom’s that’s been running Vista -> W7 -> W10 for over 15 years w/out issues until its HDD died this year (ok, it also run Debian Lenny and Xubuntu Karmic Koala for some time). Since at work I’m using RHEL and SLES and at home I’m a native Debian user (since Rex), I’ve managed to showcase quite a few distros and DEs until my mom found “the best for her”… Thus switching the machine to Manjaro KDE along with a new SSD drive.

And here starts one problem - every minute or so (roughly 50-58s) the laptop “slows” down / has a minute freeze. At the same time system journals get errors related to wifi adapter kernel module/driver such as this:

lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: Loaded firmware version: 228.61.2.24
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: Start IWL Error Log Dump:
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: Status: 0x000212E4, count: 5
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: Desc                                  Time       data1      data2      line
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: NMI_INTERRUPT_WDG            (0x0004) 0743933232 0x00000002 0x03630000 208
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: pc      blink1  blink2  ilink1  ilink2  hcmd
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: 0x0046C 0x0B996 0x004C2 0x006DE 0x0B7F6 0x4B70048
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0: FH register values:
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_RSCSR_CHNL0_STTS_WPTR_REG: 0X127dc000
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:      FH49_RSCSR_CHNL0_RBDCB_BASE_REG: 0X0127dbf0
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:                FH49_RSCSR_CHNL0_WPTR: 0X000000f8
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_MEM_RCSR_CHNL0_CONFIG_REG: 0X80809000
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:        FH49_MEM_RSSR_SHARED_CTRL_REG: 0X0000003c
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:          FH49_MEM_RSSR_RX_STATUS_REG: 0X03630000
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:   FH49_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:              FH49_TSSR_TX_STATUS_REG: 0X07ff0002
lut 20 17:42:09 MarKDE kernel: iwl4965 0000:0c:00.0:               FH49_TSSR_TX_ERROR_REG: 0X00000000
lut 20 17:42:09 MarKDE kernel: ieee80211 phy0: Hardware restart was requested

Also in some cases packets get dropped and connections restarted upon that error when using the WiFi interface (which I found running tcpdumps). Could you help with fixing the issue? Having this fixed would be required for the new user to truly appreciate the linux ecosystem and DE.

These are the IF cards’ details:

$ lspci | grep -i net
04:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
$ hwinfo --netcard --wlan | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
  Model: "Intel PRO/Wireless 4965 AG or AGN"
  Driver: "iwl4965"
  Device File: wlp12s0
  Link detected: yes
    Driver Status: iwl4965 is active
    Driver Activation Cmd: "modprobe iwl4965"
  Model: "Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express"
  Driver: "tg3"
  Device File: enp4s0
  Link detected: yes
    Driver Status: tg3 is active
    Driver Activation Cmd: "modprobe tg3"
$ dmesg | grep -i "iwl4965" | grep -w 59
[   59.333744] iwl4965: Intel(R) Wireless WiFi 4965 driver for Linux, in-tree:d
[   59.333746] iwl4965: Copyright(c) 2003-2011 Intel Corporation
[   59.333822] iwl4965 0000:0c:00.0: can't disable ASPM; OS doesn't have ASPM control
[   59.334040] iwl4965 0000:0c:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[   59.377322] iwl4965 0000:0c:00.0: device EEPROM VER=0x36, CALIB=0x5
[   59.377337] iwl4965 0000:0c:00.0: Tunable channels: 13 802.11bg, 19 802.11a channels
[   59.384608] iwl4965 0000:0c:00.0: loaded firmware version 228.61.2.24
[   59.397893] iwl4965 0000:0c:00.0 wlp12s0: renamed from wlan0
[   59.709702] iwl4965 0000:0c:00.0: Can't stop Rx DMA.
$ modinfo iwl4965
filename:       /lib/modules/4.19.23-1-MANJARO/kernel/drivers/net/wireless/intel/iwlegacy/iwl4965.ko.xz
firmware:       iwlwifi-4965-2.ucode
alias:          iwl4965
license:        GPL
author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:d
description:    Intel(R) Wireless WiFi 4965 driver for Linux
srcversion:     A8ABAA6772656B93232A2EF
alias:          pci:v00008086d00004230sv*sd*bc*sc*i*
alias:          pci:v00008086d00004229sv*sd*bc*sc*i*
depends:        iwlegacy,mac80211,cfg80211
retpoline:      Y
intree:         Y
name:           iwl4965
vermagic:       4.19.23-1-MANJARO SMP preempt mod_unload modversions 
sig_id:         PKCS#7
signer:         Build time autogenerated kernel key
sig_key:        3C:7E:50:26:0D:7A:D2:11:CD:84:7A:C3:9B:34:9D:0F:79:35:7A:6D
sig_hashalgo:   sha512
signature:      5C:CB:B5:E1:32:73:F4:7D:50:D8:D6:B3:67:C2:51:93:D7:CE:1A:AE:
                0D:99:8F:04:5C:D0:E5:68:32:7E:62:C4:5E:2A:20:D9:27:FC:3A:E4:
                54:3E:6C:D4:53:63:A7:B2:29:E1:64:1D:A8:80:A7:2D:A7:6B:0F:FF:
                5C:55:8E:64:F8:F0:BB:90:A3:2E:16:85:21:7E:92:20:71:48:5A:20:
                D0:51:65:C2:3D:03:11:BF:33:FD:4E:49:48:AF:86:FD:46:23:6A:A8:
                11:28:50:08:55:59:D8:98:47:1C:AB:F1:80:4B:40:DA:66:04:78:ED:
                0B:62:00:A4:94:87:94:08:10:8D:5B:42:E7:83:2F:07:DA:8D:AA:FE:
                BF:5C:8E:73:CC:A4:B6:7B:75:E5:92:95:B6:79:55:00:18:EB:C5:DE:
                CA:CC:85:C1:F2:B5:DE:01:9D:C9:38:96:BE:AA:2E:34:10:BA:EE:0D:
                65:6B:AF:DD:86:F3:44:C4:16:F5:19:8A:DB:FF:AF:F0:CD:E3:75:05:
                23:A6:55:E3:AC:41:31:A9:E1:EA:20:B1:B5:E6:C9:46:98:E6:28:6B:
                9D:81:6C:58:56:E9:4D:FC:69:D0:65:F8:8E:DD:A7:4B:5A:B1:3C:9A:
                76:4C:7E:5B:7C:F3:EC:8C:46:CD:2F:81:F1:B3:E3:32:DD:1B:75:5B:
                2D:8A:B1:11:F5:8B:A9:86:29:11:66:C4:55:1B:82:17:83:3D:A5:56:
                CB:F2:97:1C:7D:FA:7C:9D:94:08:C2:07:94:99:BF:22:6A:5A:CD:B4:
                91:1B:F7:C0:20:4C:DB:23:8E:FB:90:3C:ED:D6:5E:BC:C0:93:A8:3B:
                9A:A0:F6:C1:EA:E8:38:94:56:38:45:33:75:BA:36:8F:BD:A2:F0:1A:
                76:48:42:48:C3:B4:E6:65:B6:DF:74:00:C8:6E:E3:C1:91:90:3E:29:
                AE:D2:73:3A:A1:FE:EC:38:B4:C8:8A:31:BE:41:5E:6E:D5:66:B5:F4:
                BC:2A:C0:CE:24:C6:62:EE:D3:29:14:6C:8A:A6:F2:F3:C0:06:91:A1:
                7E:89:6F:B7:38:10:BB:E1:4C:2F:64:6A:78:AB:95:BA:3A:1D:74:7E:
                ED:B2:79:4B:7F:42:25:72:6D:26:EF:21:C6:AB:B2:56:71:49:90:E6:
                4A:26:1A:B1:85:EF:BB:1D:A5:A2:77:A1:64:65:11:BA:3F:25:E1:0D:
                42:BA:0E:97:E6:1E:A9:1F:81:49:A7:F8:BA:CB:64:DE:EC:C6:AD:0A:
                DD:E3:72:FE:03:8F:67:2A:D1:19:D4:A6:67:D4:DA:B2:08:91:CF:3B:
                11:B7:2E:70:25:82:18:3B:33:79:84:8E
parm:           debug:debug output mask (uint)
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           queues_num:number of hw queues. (int)
parm:           11n_disable:disable 11n functionality (int)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0 [disabled]) (int)
parm:           fw_restart:restart firmware in case of error (int)

Any ideas on how to fix this?


#2

I’d try the simplest things first. Install at least two other kernels to test. Install kernels through Manjaro settings manager and always keep at least 2 kernels installed at all times.

You could also try this simple test to see if the tg3 driver is causing problems.

sudo modprobe -r tg3

You could also check if powersaving is causing issues by entering.

sudo systemctl stop tlp

You can easily revert those changes with a reboot.

Those are probably not the most likely causes, but it’s a process of elimination when troubleshooting.

The next step would be to test different iwlwifi driver options.


#3

Having the ETH unloaded does not fix the issue - the errors are still there:

lut 20 19:26:09 MarKDE NetworkManager[325]: <info>  [1550687169.6001] device (enp4s0): state change: activated -> unmanaged (reason 'removed', sys-iface-state: 'removed')
(...)
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: Loaded firmware version: 228.61.2.24
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: Start IWL Error Log Dump:
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: Status: 0x000212E4, count: 5
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: Desc                                  Time       data1      data2      line
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: NMI_INTERRUPT_WDG            (0x0004) 2807801145 0x00000002 0x03630000 208
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: pc      blink1  blink2  ilink1  ilink2  hcmd
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: 0x0046C 0x0B996 0x004C2 0x006DE 0x0B7F6 0x284001C
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: FH register values:
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_RSCSR_CHNL0_STTS_WPTR_REG: 0X127dc000
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:      FH49_RSCSR_CHNL0_RBDCB_BASE_REG: 0X0127dbf0
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:                FH49_RSCSR_CHNL0_WPTR: 0X00000048
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_MEM_RCSR_CHNL0_CONFIG_REG: 0X80809000
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:        FH49_MEM_RSSR_SHARED_CTRL_REG: 0X0000003c
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:          FH49_MEM_RSSR_RX_STATUS_REG: 0X03630000
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:   FH49_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:              FH49_TSSR_TX_STATUS_REG: 0X07ff0002
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0:               FH49_TSSR_TX_ERROR_REG: 0X00000000
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: Queue 4 stuck for 7927 ms.
lut 20 19:28:08 MarKDE kernel: iwl4965 0000:0c:00.0: On demand firmware reload
lut 20 19:28:08 MarKDE kernel: ieee80211 phy0: Hardware restart was requested

so it’s not solely there…

Stopping the tlp:

lut 20 19:29:23 MarKDE systemd[1]: Stopping TLP system startup/shutdown...
lut 20 19:29:23 MarKDE tlp[2542]: Applying power save settings...done.
lut 20 19:29:23 MarKDE systemd[1]: tlp.service: Succeeded.
lut 20 19:29:23 MarKDE systemd[1]: Stopped TLP system startup/shutdown.

and together with ETH unloaded no issue takes place for a longer stretch of time - basically we’re going from every minute to approximately every 10mins.

However even with tcp still off as soon as ETH module is reloaded I’m back to square one with the revert back to 1min intervals:

lut 20 19:35:24 MarKDE nm-dispatcher[2709]: req:1 'up' [enp4s0]: completed: no scripts
(...)
lut 20 19:35:24 MarKDE NetworkManager[325]: <info>  [1550687724.1494] policy: set 'Połączenie przewodowe 1' (enp4s0) as default for IPv4 routing and DNS
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: Loaded firmware version: 228.61.2.24
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: Start IWL Error Log Dump:
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: Status: 0x000212E4, count: 5
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: Desc                                  Time       data1      data2      line
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: NMI_INTERRUPT_WDG            (0x0004) 3251910498 0x00000002 0x03630000 208
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: pc      blink1  blink2  ilink1  ilink2  hcmd
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: 0x0046C 0x02F3E 0x004C2 0x006DE 0x02FCE 0x4FC0048
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: FH register values:
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_RSCSR_CHNL0_STTS_WPTR_REG: 0X127dc000
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:      FH49_RSCSR_CHNL0_RBDCB_BASE_REG: 0X0127dbf0
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:                FH49_RSCSR_CHNL0_WPTR: 0X000000b8
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_MEM_RCSR_CHNL0_CONFIG_REG: 0X80809000
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:        FH49_MEM_RSSR_SHARED_CTRL_REG: 0X0000003c
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:          FH49_MEM_RSSR_RX_STATUS_REG: 0X03630000
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:   FH49_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:              FH49_TSSR_TX_STATUS_REG: 0X07ff0003
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0:               FH49_TSSR_TX_ERROR_REG: 0X00000000
lut 20 19:35:37 MarKDE kernel: iwl4965 0000:0c:00.0: Can't stop Rx DMA.
lut 20 19:35:37 MarKDE kernel: ieee80211 phy0: Hardware restart was requested

So neither just TLP=off nor just unloaded ETH module works, only both seem to remediate the issue… Though both things done fixes this. Still, tlp is a good thing to have in case of laptops AFAIK (battery life etc.) so this might not be the best solution…

PS.
I’ve removed log entries in the middle as there’s a lot of garbage generated by kwin (i.e. qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow) and qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable)).


#4

Do you use your Ethernet connection. The tg3 driver has been known to cause conflicts with other drivers. Can you shut down your ETH connection in bios.

I would also suggest you try this:

sudo iw dev wlp12s0 set power_save off 

#5

Just FYI - I’ve tested with all the kernels currently shown in the Manjaro kernel tool (and in case of those other distros, using many of those down to 3.08 or something like that) and none fixed the issue (I believe those old Ubuntu and Fedora releases worked on something like 2.10)…


#6

If these are not already present try adding these lines to:

/etc/NetworkManager/NetworkManager.conf

Add:

[device]
wifi.scan-rand-mac-address=no

Also, if the laptop has separate switch to disable Bluetooth, test with it off.

Otherwise you could try the command:

sudo rfkill block bluetooth

#7

Unfortunately ETH disabling is not a good or accetable option - though the laptop is used in various rooms on a daily basis thus wifi is used, when it’s being used for work related stuff or for some media or backup related aspects the ETH is the way to go and so is the work place arranged/prepared - we’ve got a lot of neighbouring wifi networks around (checking now it’s around 20 nets both on 5GHz and 2.4GHz spectrums besides our 3 separate subnets) and ETH is far more stable…
I’ll check this power_save switch now. And I’ve added the NM config line as it was not there.


#8

The iw power_save switch tested - still issue persists, though with power_save off it seems like the interval between errors has been extended to about 6 minutes:

lut 20 21:00:53 MarKDE kernel: iwl4965 0000:0c:00.0: On demand firmware reload
lut 20 21:00:53 MarKDE kernel: ieee80211 phy0: Hardware restart was requested
(...)
lut 20 21:06:56 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
lut 20 21:06:56 MarKDE kernel: iwl4965 0000:0c:00.0: Loaded firmware version: 228.61.2.24

Bluetooth disabled and the tests were repeated to no avail.

EDIT:
Yep, the issue persists… and it seems the interval now just varies:

lut 20 21:10:56 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
(...)
lut 20 21:13:41 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
(...)
lut 20 21:13:50 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
(...)
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: Microcode SW error detected.  Restarting 0x82000000.
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: Loaded firmware version: 228.61.2.24
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: Start IWL Error Log Dump:
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: Status: 0x000212E4, count: 5
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: Desc                                  Time       data1      data2      line
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: NMI_INTERRUPT_WDG            (0x0004) 0943344953 0x00000002 0x03630000 208
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: pc      blink1  blink2  ilink1  ilink2  hcmd
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: 0x0046C 0x0B996 0x004C2 0x006DE 0x0B7F6 0x48A0048
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: FH register values:
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_RSCSR_CHNL0_STTS_WPTR_REG: 0X1150bb00
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:      FH49_RSCSR_CHNL0_RBDCB_BASE_REG: 0X01150ba0
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:                FH49_RSCSR_CHNL0_WPTR: 0X000000e0
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:       FH49_MEM_RCSR_CHNL0_CONFIG_REG: 0X80809000
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:        FH49_MEM_RSSR_SHARED_CTRL_REG: 0X0000003c
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:          FH49_MEM_RSSR_RX_STATUS_REG: 0X03630000
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:   FH49_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:              FH49_TSSR_TX_STATUS_REG: 0X07ff0002
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0:               FH49_TSSR_TX_ERROR_REG: 0X00000000
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: Queue 4 stuck for 8194 ms.
lut 20 21:20:14 MarKDE kernel: iwl4965 0000:0c:00.0: On demand firmware reload
lut 20 21:20:14 MarKDE kernel: ieee80211 phy0: Hardware restart was requested

#9

Well a little bit of progress anyways. As this is a very old adapter I’m not too familiar with it. I think it might respond positively to disabling software encryption. To test this create:

/etc/modprobe.d/iwl4965.conf

Add this line:

options iwl4965 swcrypto=1

You could also test other options. I’m not sure how many of the iwlwifi options work on your driver, but you could test them out. Simply substitute your driver for iwlwifi in the options.

Read the parts pertaining to Wi-Fi on that thread.


#10

I’ll check those options tomorrow as I really need to go leave the laptop in the hands of its owner :wink:


#11

Hello,
I’ve checked all the options - none fixed the issue permanently - some combinations just extended the period to under an hour (which is better than what we started with).
However, I’ve dug through kernel.org and alsa bugzillas and mailing list archives to find a solution to my other issue reported here (sound/system stuttering/freezing). There I’ve found this similar issue that stems from when “tickless” and dyn-ticks kernel designs took hold of kernel environment. To fix that one needed to eitherrestrict CPU cstates to the max value of 2 (reduces the errors but not fixes it) or 1 (reduces completely but no suspend/sleep on the table and cpu both gets hotter and battery life degrades), alternatively - and this is the option I’ve chosen - you can fix the stutter by disabling MSI. Having done that, not only does the audio output work well, the system does not freeze and no power state restrictions are enforced, I only forgo the functionality of memory interupts… and the i4965 wifi error is not appearing for the moment. FYI, AFAIK this kernel parameter might mean there can be some issues with nvidia’s drivers but I have not experienced one yet…
So thanks tbg for your support. It seems the issue was not in the wifi driver per se but rather in the kernel and how it operated on my C2Duo setup that just was amplified and shown through both alsa oversized data errors and this.