[SOLVED] Installing Epson printer: unable to access localhost:631

Yesterday, I installed my Epson printer using the CUPS web interface (localhost:631), using the Manage Printing GUI in Manjaro-xfce. I have done this before and it usually works without any problem.

Yesterday’s installation went smoothly, but it wouldn’t print any of my LibreOffice documents. So, in an attempt to fix this, I deleted the printer and tried to reinstall it. However, there seems to be a problem in connecting to localhost:631, as this notification shows:
unabletoconnect

I should add that my internet connection and Firefox browser are fine as, apart from localhost:631, I’m not experiencing any problems browsing the internet.

Many thanks in advance for your help …

I experience the same, cannot connect to localhost atm.

That is the local web service of CUPS, what is the output of:

sudo systemctl status org.cups.cupsd.service


Mine is working and is

note -> Active: active (running)

$ sudo systemctl status org.cups.cupsd.service
[sudo] password di fabio: 
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2018-03-17 11:02:34 CET; 1h 1min ago
     Docs: man:cupsd(8)
 Main PID: 571 (cupsd)
   Status: "Scheduler is running..."
    Tasks: 1 (limit: 4915)
   Memory: 10.1M
   CGroup: /system.slice/org.cups.cupsd.service
           └─571 /usr/bin/cupsd -l

mar 17 11:02:34 fabio-asus systemd[1]: Starting CUPS Scheduler...
mar 17 11:02:34 fabio-asus systemd[1]: Started CUPS Scheduler.

Thanks Lolix - the output doesn’t look very good …

[mike@G750 ~]$ sudo systemctl status org.cups.cupsd.service
[sudo] password for mike: 
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; ven>
   Active: inactive (dead)
     Docs: man:cupsd(8)
lines 1-4/4 (END)

Other systemctl options are start; for current session, and enable; for persistent restarting

sudo systemctl enable org.cups.cupsd.service

sudo systemctl start org.cups.cupsd.service

and again

sudo systemctl status org.cups.cupsd.service

for checking how is going

2 Likes

Thanks Lolix - following your advice I was able to make contact with localhost:631, output from terminal looking good:

[mike@G750 ~]$ sudo systemctl status org.cups.cupsd.service
[sudo] password for mike: 
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; ven>
   Active: active (running) since Sat 2018-03-17 14:26:21 GMT; 3min 52s ago
     Docs: man:cupsd(8)
 Main PID: 690 (cupsd)
   Status: "Scheduler is running..."
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/org.cups.cupsd.service
           └─690 /usr/bin/cupsd -l

Mar 17 14:26:21 G750 systemd[1]: Starting CUPS Scheduler...
Mar 17 14:26:21 G750 systemd[1]: Started CUPS Scheduler.
lines 1-12/12 (END)

The Epson R285 printer was then installed successfully, but is still not printing any jobs, these just queuing up, showing as “Withheld” under CUPS managing jobs tab:

Can’t help further

Thanks anyway Lolix.

I have now used command-line to try and print a file on my desktop, named “jobs.png”, but without success. This is what I got:

[mike@G750 ~]$ cd /home/mike/Desktop/
[mike@G750 Desktop]$ lp jobs.png
lp: Error - no default destination available.

I then did the following to check printer status:

[mike@G750 Desktop]$ lpstat -p -d
printer EPSON_Stylus_Photo_R285 is idle.  enabled since Sat 17 Mar 2018 17:05:05 GMT
no system default destination

What is “no system default destination”?
How to fix this?

I’ve fixed the problem.
I chose the wrong option in printer setup in CUPS - I chose 9-pin printer setup which was incorrect. Ignoring this option the second time round and choosing the printer model (Epson Photo R285) from the choices list got the printer setup correctly, as it’s now printing my documents (as it should do).

Lolix’s response in reply #5 is the correct one to reconnect with localhost:631, together with correcting my error that I mentioned in #8 to enable the printer to work properly (& see added message below)

Added on 18March2018: Ah - I forget to mention that I hadn’t installed gutenprint ! - This explains why the installed printer wouldn’t work and there was a “no system default destination” in the terminal output in reply #8 above - silly me !!! Anyway, suffice to say that everything is working now as it should.

1 Like

Edit added to #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by