<SOLVED> Installation Issue

I recently purchased a NVMe M.2 SSD. I have installed it and have been able to partition it with Windows on one half. The Windows install has been completed (although very trying).

Now I am attempting to install Manjaro XFCE on the other half of the M.2 SSD but there is a catch. I want the SSD to be my Boot/EFI plus my Root. I would like my 1 TB HDD to be my Home. I have attempted to install twice now and each time I have gotten an error. The most current one is:

Installation Failed
Boost.Python error in job "unpackfs".
<class 'AttributeError'>

Traceback:
File "/usr/lib/calamares/modules/unpackfs/main.py", line 340, in run return unpackop.run()

File "/usr/lib/calamares/modules/unpackfs/main.py", line 224, in run error_msg = self.unpack_image(entry, imgmountdir)

File "/usr/lib/calamares/modules/unpackfs/main.py", line 270, in unpack_image return file_copy(imgmountdir, entry.destination, progress_cb)

File "/usr/lib/calamares/m,odules/unpackfs/main.py", line 152, in file_copy utils.warn("rsync failed with error code{}.".format(process.returnecode))

On the boot/efi I did place the boot and esp flags. Am I missing something? On the root the standard flag is selected. Home I used the same flag as root.

Any help would be greatly appreciated. Thanks.

UPDATE:
The User Guide on the desktop of the live installation is a ton of help. I had to use the manual installation method. I had my /boot/efi partition behind the root partition so that was my issues. I used edit partition table for the pre-made partition with Windows 10. From there I built the /boot/efi, /swap, / file paths.

Then I selected my second drive with the dropdown up top. I hit the create a custom partition for my 1TB HDD and listed it as /home.

Note: for home and / I did not select any flags and it worked well.

with USB install manjaro
open a terminal and returns

fdisk -l
inxi -Fxxxz

Thanks for your assistance. Since the install I do not get a GRUB menu when I boot so that is my next issue to work on after I update the system.

if you dont use USB install , Grub can be show on Boot with Esc on Start , it is hidden

I attempted hitting Esc at boot to the same results of no Grub.

with USB install manjaro
open a terminal and returns

fdisk -l
inxi -Fxxxz
lsblk -f
[manjaro@manjaro ~]$ sudo fdisk -l
Disk /dev/nvme0n1: 953.9 GiB, 1024209543168 bytes, 2000409264 sectors
Disk model: Sabrent                                 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6AFCC69D-C392-4C1D-B08D-0F6382EEC636

Device              Start        End   Sectors   Size Type
/dev/nvme0n1p1       2048    1085439   1083392   529M Windows recovery environme
/dev/nvme0n1p2    1085440    1288191    202752    99M EFI System
/dev/nvme0n1p3    1288192    1320959     32768    16M Microsoft reserved
/dev/nvme0n1p4    1320960 1000865791 999544832 476.6G Microsoft basic data
/dev/nvme0n1p5 1000865792 2000406527 999540736 476.6G Linux filesystem


Disk /dev/loop0: 76.6 MiB, 80293888 bytes, 156824 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 274.6 MiB, 287899648 bytes, 562304 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 1 GiB, 1123639296 bytes, 2194608 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 475.5 MiB, 498569216 bytes, 973768 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
Disk model: ST3000NM0033-9ZM
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 45736856-0D8E-42A9-8C33-4AA56C8DD8BF

Device     Start        End    Sectors  Size Type
/dev/sda1   2048 5860532223 5860530176  2.7T Microsoft basic data


Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10EZEX-08W
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 01842156-CC87-496E-AD88-6FF9FDE1C982

Device     Start        End    Sectors   Size Type
/dev/sdb1   2048 1953520031 1953517984 931.5G Linux filesystem


Disk /dev/sdc: 7.5 GiB, 8027897856 bytes, 15679488 sectors
Disk model: USB DISK        
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdc1  *         64 4007655 4007592  1.9G  0 Empty
/dev/sdc2       4007656 4015847    8192    4M ef EFI (FAT-12/16/32)type or paste code here
[manjaro@manjaro ~]$ inxi -Fxxxz
System:
  Host: manjaro Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.3 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF X470-PLUS GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 4805 date: 06/04/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen 
  rev: 1 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 76683 
  Speed: 3404 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 
  1: 3389 2: 3358 3: 2638 4: 1266 5: 1359 6: 2795 7: 1869 8: 1274 9: 3394 
  10: 2042 11: 1357 12: 2789 
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Micro-Star MSI 
  driver: nvidia v: 418.43 bus ID: 0a:00.0 chip ID: 10de:1c81 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~60Hz, 1366x768~60Hz 
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
  direct render: Yes 
Audio:
  Device-1: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 0a:00.1 chip ID: 10de:0fb9 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0c:00.3 chip ID: 1022:1457 
  Device-3: C-Media Audio Adapter (Unitek Y-247A) type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2:2 chip ID: 0d8c:0014 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 4.58 TiB used: 430.9 MiB (0.0%) 
  ID-1: /dev/nvme0n1 model: Sabrent size: 953.87 GiB speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: ECFM12.2 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST3000NM0033-9ZM178 size: 2.73 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-3: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: 1A02 scheme: GPT 
  ID-4: /dev/sdc type: USB model: SMI USB DISK size: 7.48 GiB 
  serial: <filter> rev: 1100 scheme: MBR 
Partition:
  ID-1: / size: 11.73 GiB used: 430.9 MiB (3.6%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 27.2 C mobo: N/A gpu: nvidia temp: 31 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 35% 
Info:
  Processes: 281 Uptime: 4m Memory: 15.64 GiB used: 1.14 GiB (7.3%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: xfce4-terminal inxi: 3.0.32 
[manjaro@manjaro ~]$ lsblk -f
NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
     squash                                                  0   100% /run/miso/
loop1
     squash                                                  0   100% /run/miso/
loop2
     squash                                                  0   100% /run/miso/
loop3
     squash                                                  0   100% /run/miso/
sda                                                                   
└─sda1
     ntfs   NinjaExtra
                  042A8CE32A8CD2DA                                    
sdb                                                                   
└─sdb1
     ext4         2145e09a-47e7-43a0-a1dc-9cd4571b22dc                
sdc  iso966 M1804 2019-03-12-09-01-11-00                              
├─sdc1
│    iso966 M1804 2019-03-12-09-01-11-00                     0   100% /run/miso/
└─sdc2
     vfat   MISO_EFI
                  BB93-7505                                           
nvme0n1
│                                                                     
├─nvme0n1p1
│    ntfs   Recovery
│                 50FEC5C7FEC5A616                                    
├─nvme0n1p2
│    vfat         2EC7-398F                                           
├─nvme0n1p3
│                                                                     
├─nvme0n1p4
│    ntfs         B04CC9A64CC96824                                    
└─nvme0n1p5
     ext4         4c3de896-0b88-4503-a134-e554bfedd143 

so try

manjaro-chroot -a ( select 1 if one line )
grub-install /dev/nvme0n1
exit ( leave chroot )

reboot