[Solved] Installation fails for grub (cinnamon 17.0.4 & 17.0.5


#1

Only been able to get 17.0.5 cinnamon to install in virtual box using calamares 3.1.4-9 (-13 failed), all other attempts whether in VB or natively on system (amd fx6300 & amd r9 290x) when it tries to setup grub.
I’ve tried chroot to install grub but was unsuccessful following a {solved} thread here for a 16.x install.

Once the installer starts setting up hardware neither the network or any drives work on live-USB so only able take photo of debug as unable to save the output anywhere.

I heard install problems had been resolved with 17.0.4, so what’s going on?
Anyone help, I wanna give manjaro a go, it looks great, thanks in advance.

E2A: Apologies for posting in Manjaro editions. Was using phone, saw ‘installation’ and started posting. Please feel free to move this to appropriate section.


#2

I see it’s the old bootloader error.

You made certain you defined /boot/efi with a small (500’ish MB) partition in partitioning?


#3

These most recent attempts have been the simplest ‘erase entire disk’ having had all previous attempts fail as well when defining partitions manually.


#4

I also see lots of input/output read errors.

Maybe the harddrive is failing?


#5

As I mentioned (with significant uncertainty), I’m unable to access any drive outside of the Live-USB, whether SSD (install target), HDD or another USB (where I could save the debug output for easier viewing here) once the installer has run through ‘hardware setup’, where the network disconnects then reconnects (even though it’s then unaccessable). That might be the cause of the I/O errors and therefore the grub failure as that follows the hardware setup.

Edit: specified when drives become inaccessable.


#6

Attempted install with primary xfce, different failure point but again, unable to access network or drives after calamares ‘configures hardware’.

Probably gonna give up with manjaro now, far too many installation failures. Apparently it’s just not for my system.
:frowning:


#7

plz return before installing
inxi -Fxxx

have you check bios before launch USB install ?


#8

FWIW got installed using Manjaro Architect. Hopefully I can work out the weird kinks I’ve hit with initial setup of software/settings/etc.

P.S. Bios (should) be fine Stephane, other Distros (inc Arch based) were fine, so ¯_(ツ)_/¯


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.