[Solved] How to "reroute" sound to usb audio device?

Since my jacks doesn’t work, I bough USB Sound Adapter that is said to be linux compatible. After plugin it in it didn’t work. So i started to dig in.

I changed laptop. The same. I changed to ubuntu based system, the same. So I went back to manjaro and looked if it sees it.

lsusb sees it as:

Bus 001 Device 006: ID 0d8c:0014 C-Media Electronics, Inc.

alsamixer sees it as USB Audio Device

I do see it also under the same name in KDE Settings. But even when I set it from Inbuild Sound Device (loose translation) to USB Audio Device, I still get sound from laptop speakers. Interesting is, when I click in tests, speakers connected through this device do work. There is a test sound and audio left/right. But normal system sounds are still running through laptop speakers.

I found that it might be because of order of modules so I followed the advice on this site:

http://sudomod.com/forum/viewtopic.php?t=144

After reboot I finally see:

 0 snd_usb_audio
 1 snd_hda_intel

So order seems to be fixed but still no luck, system sounds and music (from spotify or everything else) plays on laptop, while test sounds work on speakers that I attached through device.

My /etc/modprobe.d/alsa-base.conf looks like that:

options snd_usb_audio index=0
options snd_hda_intel index=1
options snd slots=snd-usb-audio,snd_hda_intel

The device works, still I have no idea how to “reroute” sound through this USB adapter. I am clearly missing something and that is why I ask for help. I am newbie at alsa, pulseaudio etc.
Thanks! :slight_smile:

OK, found solution on #alsa IRC channel.

We figured out that alsa isn’t using my device, despite all settings so I installed pavucontrol and on one of the tabs I found it, switched to USB Audio Device and now it works! I have sound and plugging and unplugging also switches automatically so it’s just as I wanted.

Despite all the KDE settings, this one was so obscure and none present in system GUI so pavucontroll was a must it seems.

Additionally, I need to set every working sound program (spotify, firefox) to my USB Sound Device for this to work. When I don’t do that, sound is from laptop speakers.

It’s possible that creating the file is not necessary, only setting in pavucontrol since alsa is not respecting set order anyway.

Pavucontrol is can be a ‘must have’ in some cases.

I’ve used it to control latency for a remote BT speaker in Plasma, and used it with Paprefs together to set defaults, latency, and configure virtual streams in GNOME/GTK DEs.

You should be able to defer/promote devices in System Settings>Multimedia>Audio and Video. I say ‘should’ because I have no idea what is going to show with re-route.

Regards

I did it in menu settings and… no effect. Only setting each program to this specific audio device on pavucontrol worked. It looked as if, all sound sources on my computer were using default audio, despite general system setting. Of course setting to different one (so no usb audio device or default system) was resulting in no sound, so kde settings somehow has issue only with this one.

I installed pavucontrol-qt and it looks as a native plasma settings so at the beginning I was confused as how it differs from default plasma sound center, but eventually I found settings there that are not present on KDE by default.

1 Like

Glad you got it sorted. :smiley: Pavucontrol-qt is a nice tool.

Regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.