[SOLVED] HL-2140 (USB) stopped working after 2018-08-18 updates

cups

#1

After the update this past weekend my desktop printers all stopped working. I have two network printers and one usb printer. All are Brother printers. After many gyrations I got the two network printers (not sure what did the trick). However, the usb printer does not work anymore (HL-2140). It has worked great for years. Also, I plugged its usb cable into a Linux laptop (Mint 17) and it was instantly recognized and auto-installed AND printed perfectly.

The usb printer shows up in lsusb:

# lsusb
...
Bus 002 Device 005: ID 04f9:0033 Brother Industries, Ltd 
...

lpinfo doesn’t see the usb printer:

$ sudo lpinfo -v
[sudo] password for ecomer: 
network http
network ipps
network beh
network https
file cups-pdf:/
network ipp
network socket
direct hp
network lpd
network smb
direct hpfax
network dnssd://Brother%20HL-L2380DW%20series._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-30055c97a9c0
network dnssd://Brother%20MFC-J430W._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-0080927a0c0f
network lpd://HL-L2380DW2B0C3/BINARY_P1
network lpd://MFC-jF30W/BINARY_P1
network ipp://HL-L2380DW2B0C3.local:631/ipp/print
network ipp://BRN0080927A0C0F.local:631/ipp/port1

I have re-installed “brother-hl2140 2.0.2_1-4” to no avail.

Any ideas?


#2

I have a similar model HL 2030 and it works. I use just the PPD file to set up the printer.


#3

The PPD is present “/etc/cups/ppd/Brother-HL-2140.ppd”. Nothing changed except the Manjaro update last weekend. All printers died after post update reboot. The USB printer remains dead.


#4

cups-filters got updated

                        cups-filters             1.20.4-1             1.20.4-2

Try to downgrade to the previous version.


#5

I downgraded to 1.20.4-1, restarted CUPS but the printer is still doesn’t show up in lpinfo -v
I initially did not try rebooting the machine, as I felt that restarting CUPS was enough, but with no success, I rebooted the machine. No change - usb printer is not recognized enen though it is present in lsusb.


#6

That’s a pretty large nothing. :wink:


#7

Agreed - the update was large. I meant that nothing else changed with printer, PC, cables, etc. Only the update.


#8

I would try to downgrade other related packages from that update. Check in /var/log/pacman.log what got updated.


#9

These are the only items in the Aug 18 update that contained “cups” or “printer” in the name:
[2018-08-18 13:02] [ALPM] upgraded cups-filters (1.20.4-1 -> 1.20.4-2)
[2018-08-18 13:03] [ALPM] upgraded python-pycups (1.9.73-3 -> 1.9.73-4)
[2018-08-18 13:03] [ALPM] upgraded system-config-printer (1.5.11-2 -> 1.5.11-3)

Of course, the kernel was also upgraded to linux414-4.14.65-1-x86_64


#10

I know about these, but the whole list would be better.


#11

This link has ALL of Aug 18’s entries in pacman.log:
https://pastebin.com/4xS94TMn


#12

I would try to downgrade this

[2018-08-18 13:02] [ALPM] upgraded ghostscript (9.23-1 -> 9.23-2)

#13

Only that - everything else at Aug 18 versions?


#14

Only or in addition to cups-filters. It’s a combinatoric problem.:dizzy_face:


#15

/var/cache/pacman/pkg/ghostscript-9.23-1-x86_64.pkg.tar.xz is there but NOT ghostscript-9.23-2-x86_64.pkg.tar.xz


#16

ls /var/cache/pacman/pkg/ | grep ghostscript
to be sure.


#17

Not there. I fetched ghostscript 9.23-2 from https://archive.archlinux.org/packages and downgraded to ghostscript-9.23-2-x86_64.pkg.tar.xz. No joy.

As another effort, since the Aug 18 upgrade did system-config-printer (1.5.11-2 -> 1.5.11-3), I downgraded to system-config-printer-1.5.11-2-x86_64.pkg.tar.xz. That didn’t go so well - it broke system-config-printer with “ModuleNotFoundError: No module named ‘cupshelpers’”. I went back to system-config-printer 1.5.11-3.


#18

system-config-printer is just a GUI for CUPS.
No joy means you have rebooted?

But this is an upgrade then. Anyway check both versions 9.23-1 and 9.23-2.


#19

system-config-printer is back to current version. ghostscript and cups-filter remain at previous version. I have rebooted. No Joy means that the usb printer is still not recognized by lpinfo -v although it is present in lsusb, and, of course that I cannot get the printer working again, the way that it did prior to the Aug 18 upgrade.


#20

I misspoke - ghostscript was updated on Aug 18 from (9.23-1 -> 9.23-2). I downgraded to earlier 9.23-1, where it still is, with no improvement. cups-filters was downgraded back to 1.20.4-1 and it remains there, also with no change for the better.