[solved] Hexchat spellcheck

hexchat spellcheck isn’t working when i look into preferences spell check is checked and dictionary in use is en_US but when I spell something incorrectly nothing happens

If you have the hunspell-en-US package installed, make sure you restart the client so is starts using it. Then make sure to enable spelling under Settings ‣ Preferences ‣ Interface ‣ Input box.
Alternatively you can use LANG=en_US hexchat to launch it, or add that to the Exec= line in the desktop file.

Thanks installing hunspell-en_US did the trick