[SOLVED] HDMI audio does not return after resume from standby

deepin

#1

Tried restarting pulseaudio per some Arch forum thread - only thing that works so far is to not suspend, just do full shutdown at night. Never had this issue with Ubuntu gnome or kde…


#2

Does it do the same thing if you use hibernate?


#3

This issue often occurs with network drivers at suspend. The way I have been working around this problem with people experiencing these suspend issues is by unloading the modules before suspending. A systemd service file needs to be written to automatically unload the driver before suspending, then reload it at resume.

Perhaps a service could accomplish the same fix for audio components. Let me know if you’d like me to post info on writing a service file.


#4

I do not see a hibernate option, only shutdown, reboot, suspend, lock, logout.

edit: possibly related - I don’t think a swap partition was setup on install…


#5

You can always make use of a swapfile instead of swap partition, especially on SSD.


#6

is that needed with 8GB of RAM?


#7

Is needed if you want to use hibernate :slight_smile:
Also it depends how you set in BIOS (if you have those options): ACPI S1 (Power on Suspend) or ACPI S3 (Suspend to RAM).


#8

Just brought PC back from suspend - then turned on HDMI monitor - sound working. So it may have to do with order of power, or it may have been fixed in the most recent round of kernel updates. Either way, problem solved.