[SOLVED] Having problems to install NVIDIA Drivers

I am trying to install my drivers the way I always did, but at this point it is no longer working. I am sure my GPU supports this driver.

$ sudo mhwd -i pci video-nvidia-390xx
> Installing video-nvidia-390xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-390xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Sincronizando a base de dados de pacotes...
 core está atualizado
 extra está atualizado
 community está atualizado
 multilib está atualizado
resolvendo dependências...
atenção: não é possível resolver "nvidia-390xx-utils=390.116", uma dependência de "linux51-nvidia-390xx"
:: O seguinte pacote não pode ser atualizado devido a dependências não resolvidas:
      linux51-nvidia-390xx

:: Deseja ignorar o pacote acima para esta atualização? [s/N] erro: falha ao preparar a transação (não foi possível satisfazer as dependências)

:: não foi possível satisfazer a dependência "nvidia-390xx-utils=390.116" necessária por linux51-nvidia-390xx
Error: pacman failed!

$ inxi -Fxzc0
System:    Host: denielt-pc Kernel: 5.1.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: Gnome 3.32.2 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: PCWARE model: IPMH81G1 serial: <filter> BIOS: American Megatrends 
           v: F5 DB date: 03/20/2014 
CPU:       Topology: Dual Core model: Intel Pentium G3250 bits: 64 type: MCP arch: Haswell rev: 3 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12777 
           Speed: 867 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: NVIDIA GF119 [GeForce GT 610] vendor: ZOTAC driver: nouveau v: kernel 
           bus ID: 01:00.0 
           Display: x11 server: X.org 1.20.5 driver: nouveau resolution: <xdpyinfo missing> 
           OpenGL: renderer: NVD9 v: 4.3 Mesa 19.1.4 direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Realtek 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Device-2: NVIDIA GF119 HDMI Audio vendor: ZOTAC driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 
           Sound Server: ALSA v: k5.1.21-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           v: 8.047.02-NAPI port: d000 bus ID: 03:00.0 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 473.22 GiB used: 6.39 GiB (1.4%) 
           ID-1: /dev/sda vendor: Toshiba model: DT01ACA050 size: 465.76 GiB 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 7.45 GiB 
Partition: ID-1: / size: 406.95 GiB used: 6.39 GiB (1.6%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 29 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 180 Uptime: 25m Memory: 3.80 GiB used: 1.43 GiB (37.7%) Init: systemd 
           Compilers: gcc: N/A Shell: bash v: 5.0.7 inxi: 3.0.35 

kernel 5.1 is EOL, so change kernels

also make sure you are up to date and mirrors are synced

also -- you could just use the auto-install option .. 390 is as low as nvidia goes .. who knows, maybe you can use a newer version.

3 Likes

I upgrade to linux kernel 5.2 and it solved my problem, thanks for your help and thanks for your suggestion too, but my GPU doesn't support drivers forward 390.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark