[Solved] Grub loader failed to install efi

Good and you're welcome.

That we need your output of

sudo blkid
cat /etc/fstab
grep CMDLINE /etc/default/grub
grep keymap /etc/mkinitcpio.conf
/dev/sda1: LABEL="threeterabyte" UUID="d7d418ac-04c8-438d-8bbb-fae812d032ff" TYPE="ext4" PARTUUID="e72ac8be-3852-4263-bd1e-396b047ab257"
/dev/sdc1: LABEL="BigOneT" UUID="52e2f09a-560e-4d0a-97db-cca80831542b" TYPE="ext4" PARTUUID="e183436e-79b4-4240-b645-444e1b161c21"
/dev/sdb1: UUID="B6FC-EBA3" TYPE="vfat" PARTUUID="d1e47169-20fa-409e-8262-f6cc29ba96ff"
/dev/sdb2: UUID="8549f59b-032c-4388-bb97-2f6aecb8ab26" TYPE="ext4" PARTUUID="335ec498-9f31-438d-8386-21a335e24132"
/dev/sdb3: UUID="32ef6fdc-bbe4-4540-a31b-c2c68a69299c" TYPE="swap" PARTUUID="b11d4dd1-c6bc-4f09-a6ce-ab848def1446"
[douglas@Frog-pc ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=B6FC-EBA3                            /boot/efi      vfat    umask=0077 0 2
UUID=8549f59b-032c-4388-bb97-2f6aecb8ab26 /              ext4    defaults,noatime,discard 0 1
UUID=32ef6fdc-bbe4-4540-a31b-c2c68a69299c swap           swap    defaults,noatime,discard 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

UUID=52e2f09a-560e-4d0a-97db-cca80831542b /media/OneT    ext4    defaults,relatime,discard 0 2
UUID=d7d418ac-04c8-438d-8bbb-fae812d032ff /media/ThreeT  ext4    defaults,relatime,discard 0 2
[douglas@Frog-pc ~]$ 
[douglas@Frog-pc ~]$ grep CMDLINE /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
GRUB_CMDLINE_LINUX=""
[douglas@Frog-pc ~]$ 
[douglas@Frog-pc ~]$ grep keymap /etc/mkinitcpio.conf
HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems"

In /etc/default/grub, to this line, add..

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"

to

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet resume=UUID=32ef6fdc-bbe4-4540-a31b-c2c68a69299c"

Then do

sudo update-grub

I note your swap is in sdb3. I assume it is in an internal drive.
If that is a partition in an external drive and you sometimes remove this drive, let us know.

You have a typo in that help. Might want to fix it for future users.

sdb is my internal root and ssd drive. Are there any settings i should be using, for example in fstab for an ssd drive or just leave it the way it is?

Thanks again!

Instead of using discard for SSD partitions you could use FSTRIM which is the recommended procedure to trim the SSD's. Simply remove discard from all lines (except for swap) and enter in a terminal:

sudo systemctl enable fstrim.timer

After a reboot this will enable the timer causing once a week to trim the mounted SSD partitions.

The swap partition won't be trimmed by this, you either can leave the discard here, ignore the trimming for the swap or trim it manually from time to time.

Remove discard even for the two hdd or only the ssd?

What I mentioned only corresponds to SSD's, as far as I understand it, a HDD doesn't understand a TRIM instruction and will normally ignore it.

Forum kindly sponsored by