[Solved](GPU) Geforce 210 Screen Tearing

Hello all,

I have a pretty old GPU, and I am wondering if there is a way to remove screen tearing. So far I have tried to use two tutorials to solve them, but none of them have worked.

Youtube (Got stuck on nvidia-settings)
Screenshot on why:

Manjaro Wiki

I just want to consult you guys before I try more settings.

Add this to the Section "Device" right under BoardName

    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"

Add to /etc/profile.d/kwin.sh this lines

export KWIN_TRIPLE_BUFFER=1
export __GL_MaxFramesAllowed=1

In that Nvidia X config set the resolution from Auto to the native one and the same for the refresh rate. When you save to X make sure you keep the last 3 Sections and only add your custom one. Then modify where the resolution is set in the config to be:
1920x1080_60 +0+0 {ForceCompositionPipeline=On}

Always keep the original config just in case.

2 Likes

Thanks for your fast response. Can you go into more detail please? I tried following your instructions, but I somehow managed to stop KDE plasma from booting :P. I’ll try to fix it in the meanwhile

Edit: Got Plasma running again. For some reason kwin.sh doesn't exist in my machine. Should I just create a file and add those two commands? Where do I put the "1920x1080_60 +0+0 {ForceCompositionPipeline=On}"? Screenshot on where I put it (guessing this was why it crashed):
image
And I add

Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"

to /etc/X11/mhwd.d/nvidia.conf and /etc/X11/xorg.conf.d/95-mhwd.conf?

I think my GPU is too old? Just tried the legacy solutions on this site, and it didn't work... Oh well. Guess I'll live with it, unless you can find a solution I can't. Thanks for your help though.

95-mhwd.conf is a symlink to nvidia.conf
The lines you mentioned you add them

From your screenshot is to where the red line is

image

Yes, you create it if is not present :slight_smile:

Tried your suggestions... sadly they did not work. Here is a screenshot of a screen tearing test on YouTube


Edit: Here's a video of screen tearing as well:

1 Like

Did you try using Compton?

2 Likes

Oh, no it didn't even appear in my searches to be honest. Should I follow this guide, even though I am using KDE? It seems like a old program so it might work with my gpu.

Your biggest problem is memory back in the day 512mb was really just adequate for a GPU today 2gb is just about the same if possible do a upgrade you can get a gt710 for $40 and it runs on the latest drivers.

I had tearing with Intel (I have Intel and Nvidia). After installing compton and using just default config I fixed the tearing.

I am not sure if it will help on KDE (it helped on xfce and i3). I guess KDE has its own compositor.

Just an opinion to check the compositor not only nvidia settings.

That's a good idea, but I was planning to save up to buy a new computer altogether (This computer is about 10 years old :P). Just want to use Manjaro on what I have right now, and hopefully do a huge upgrade soon.

Alrighty, thanks for your input. I'll see what I can do on KDE, or if need be, I'll just switch to XFCE for the time being.

I would recommend you Xfce then, it very lightweight and with small effort it could look really good (although without some animation and fancy styles).

Well many users have old gear 10 year old is not old, a SDD, a bit of ram, a modern GPU that does the rendering, it will outperform most modern laptops as they are throttled down and a lot of desktops.

True, but I rather just upgrade the whole thing to be honest.

1 Like

Compton worked! Thanks so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.