[SOLVED] GNOME/GTK Color won't change

Hello, first time using Manjaro and Arch in general, absolutely loving it on my Surface Pro 4.

I've been trying out a lot of themes lately to find something that works great on touchscreens. I installed the Zorin Theme from the AUR (https://aur.archlinux.org/packages/zorin-desktop-themes) as it's pretty great for touch, but it appears that my UI is now stuck on the blue color that was used by the blue variant. Here's what I mean:

Look at the Apperance button's color on the left:

As you can see, it's stuck on that blue no matter the theme I use.

I've already tried:

  1. Changing the theme
  2. Uninstalling the Zorin themes
  3. Reinstalling the Zorin themes and using one of the other colors (e.g. Red)
  4. Resetting GNOME Tweaks entirely.

Nothing has made a difference. Any ideas?

Thanks in advance!

Another image with the Adwaita theme as I can only use 1 image per post as a new user:

Never mind, figured out a way to change it! The Layouts app has an option for Application Highlight Color which seems to stick even after changing the theme.

While this lets me change the color, it still doesn't let me reset it to its original automatic value. I've already tried chaging gtk-color-palette using dconf Editor or resetting it, nothing changed. Any other ideas?

The what now? :thinking:

gnome-layout-switcher by Chryssostomus. Even uninstalling the app doesn't seem to make a difference... I guess I'll go ask in the respected thread to see if anyone there has any ideas.

Alright, I figured it out! Deleting ~/.config/gtk-3.0/gtk.css resets all the colors to whatever the theme is using. Not sure if this is a bug with gnome-layout-switcher or something intentional. Either way, thread Solved.

Forum kindly sponsored by