(solved) Gnome file manager does not alphabetize correctly. Really. Also can I make the list view items closer together?

I have a partition where I store folders for work. Within each folder are many subfolders that can easily be alphabetized. This is the first time I have ever seen this: Gnome file manager will not alphabetize correctly. I can sort by name all I want and it sitll has entries that are in the wrong place. I can use a LiveCD or USB of other distros, look at the same filder and its subjfolders ARE in correct alphabetical order.
Any ideas ?
Secondly. The folder has 150 subfolders in it. For my work purposes it is good to see as many of them at one time in the list or details views as possible. I have never seen a file manager that is “double-spaced” in effect, before. Between each folder is an empty space the same height as the folder’s line entry. So, I have half as many folders in view as any other OS that I have seen.
Is Gnome or at least its file manager kind of janky ?

One thing I can think of is the difference in capitals as starting character or the sort option in preferences: sort folders first.

They are all folders being sorted, but you were right about the caps, but that still leaves me in the lurch. I need it to be capitalization agnostic for alphabetizing. I do not have the time to capitalize every folder as I do not create them I only have to deal with them.
Again, I have never ever seen a file manager or computer treat a folder beginning with a lower case letter in the name as if it was a non-character or any different than a capitalized folder name.
can this be fixed in a setting somewhere or is it a Gnome “feature” ?

On unix systems a directory is a file (everything is a file) and it gets treated as file so it sort it as a file. Since the caps are treated as different they are sorted as such. I’m using gnome files and in the gnome terminal using zsh this behavior is the same, it is (for me) the expected behavior. I’m not aware of a option to change this with a setting in the files filemanager. It would probably need some coding to make happen.

There are some solutions:

  • Automation: Have a script run through the directories and change the capitals, not sure if this is possible in your case. Nice example of this option

  • Change the tool: Use a different filemanager, I just installed pcmanfm it and it does not seem to care about capitals. so folder a is above folder C, and folder d is below folder C. (I presume this is the behavior you need) The ranger terminal file manager (excellent workflow with ranger btw) does not care about capitals by default.

  • Change the environment: Use a different OS/Desktop/filesystem.

This appears to be specific to whatever filemanager Gnome is using. I use Dolphin in KDE and it doesn’t seem to care about upper case/lower case.

I ended up reinstalling the Cinnamon version. File manager acts as I want it to.