[Solved] Firefox doesn't open when I click on it


It has been a few weeks since I used Manjaro and I launch Firefox, but realize that my version is outdated. Well, I decide to (only) update Firefox for quick browsing, but after the update is done, I realize that Firefox doesn’t launch.

What should I do?

Update the entire system every time.

Partial updates, like you did, is not supported.

I guess the new Firefox depends on versions of dependencies, which is outdated in your case.

Sorry for ninja’ing this, @Aragorn. :stuck_out_tongue:


Welcome to the forum! :slight_smile:

This is known as a partial upgrade scenario, and this is not supported. The newer Firefox was linked against newer shared libraries than you have on your system, and that’s why it doesn’t start.

You should fully update your system instead. :arrow_down:

sudo pacman -Syyu

This solved my problem, thank you for your answer

Edit: just to be clear for future beginners seeing this post, If It wasn’t obvious: you should type the command in a terminal:

sudo pacman -Syyu

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.