(solved) "failed to start load Kernel modules” after OS Upgrade

#21

please find the result

[subin@subin-pc ~]$ /etc/modules-load.d/*.conf
bash: /etc/modules-load.d/modules.conf: Permission denied
[subin@subin-pc ~]$

[subin@subin-pc ~]$ grep vfs_monitor /etc/mod*/*.conf
[subin@subin-pc ~]$
[subin@subin-pc ~]$
[subin@subin-pc ~]$

#22

hey PCI bus error problem solved what about “Failed to start load kernel modules”

#23

dkms install deepin-anything/0.0.3 -k 4.20.0-1-MANJARO
was installed but now way.

#24

That’s a win!

Check this

systemctl status systemd-modules-load

and again…

If you don’t understand something, ask again.

1 Like
#25

Try this.

sudo dkms install deepin-anything/0.0.3

And then reboot.
And let me know if the error goes away.

1 Like
#26

Hey

Please see the results

[subin@subin-pc ~]$ systemctl status systemd-modules-load
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; >
Active: failed (Result: exit-code) since Fri 2019-02-15 23:02:09 IST; 5min ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 578 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, stat>
Main PID: 578 (code=exited, status=1/FAILURE)

Feb 15 23:02:09 subin-pc systemd[1]: Starting Load Kernel Modules…
Feb 15 23:02:09 subin-pc systemd-modules-load[578]: Failed to find module 'vfs_mo>
Feb 15 23:02:09 subin-pc systemd[1]: systemd-modules-load.service: Main process e>
Feb 15 23:02:09 subin-pc systemd[1]: systemd-modules-load.service: Failed with re>
Feb 15 23:02:09 subin-pc systemd[1]: Failed to start Load Kernel Modules.

#27

hey its installed

#28

Check which package has this

pacman -Ql | grep "vfs-monitor"
pacman -Fl | grep "vfs-monitor"
1 Like
#29

pipes and grep … like seriously the best things since bread and toasters.

2 Likes
#30

heyyyy buddy

How to check this

in terminal???

pacman -Ql | grep “vfs-monitor”
pacman -Fl | grep “vfs-monitor”

#31

That’s not what i asked you to do.
Can’t help you like this.

Run this in terminal & reboot.

#32

heyyy

some error occurred,

please find the result

[subin@subin-pc ~]$ sudo dkms install deepin-anything/0.0.3
[sudo] password for subin:
Error! echo
Your kernel headers for kernel 4.20.7-1-MANJARO cannot be found at
/usr/lib/modules/4.20.7-1-MANJARO/build or /usr/lib/modules/4.20.7-1-MANJARO/source.
[subin@subin-pc ~]$

#33

hey

how to check this

pacman -Ql | grep "vfs-monitor"
pacman -Fl | grep "vfs-monitor"
#34
~ >>> man pacman                                                                                                                 [1]
~ >>> pacman -h                                                                                                                     
Verwendung:  pacman <Operation> [...]
Operationen:
    pacman {-h --help}
    pacman {-V --version}
    pacman {-D --database} <Optionen> <Paket(e)>
    pacman {-F --files}    [Optionen] [Paket(e)]
    pacman {-Q --query}    [Optionen] [Paket(e)]
    pacman {-R --remove}   [Optionen] <Paket(e)>
    pacman {-S --sync}     [Optionen] [Paket(e)]
    pacman {-T --deptest}  [Optionen] [Paket(e)]
    pacman {-U --upgrade}  [Optionen] <Datei(en)>

#35

how to run this

pacman -Ql | grep “vfs-monitor”

#36

You probably don’t need it. Follow the suggestions from people who know about Deepin, if this is your DE.

If you don’t know how to run this command, please don’t try to do it blindly. It’s not harmful now, but if you do it as a habit, you may create unsolvable problems to your installation.

#37

You use a terminal.

Be aware that Linux isn’t an operating system for those who can’t use a computer.

1 Like
#38

hiii

i don’t try that commands. i am following only your and @thesneakyotter instructions. just dropped how to check the commands posted by you.

i have posted all the results of your instructions, except the below

pacman -Ql | grep “vfs-monitor”
pacman -Fl | grep “vfs-monitor”

the reason is i don’t know how to check this :disappointed_relieved:

#39

They are both commands you run in a terminal, in exactly the same way as you have run every other command so far.

Which bit are you having difficulty with?

#40

I think this should fix your problems.

First install linux-headers:

sudo pacman -S linux420-headers

And then run this:

sudo dkms install deepin-anything/0.0.3

Reboot.

Cheers.