(solved) "failed to start load Kernel modules” after OS Upgrade

#1

Heyy All

Recently i have upgraded my OS from manjaro deepin 17.1.12 to Manjaro deepin 18.02, after the upgrade, everytime boot up an error showing that is " Failed to start load Kernal Modules". but the system is startup normally. is it a serious problem ??? how can i solve this problem, the second problem is i cant find the LAN option after upgrade. if i try to start with old Kernal the LAN option is working. how to solve this problem. for your reference i have posted the result of the following commands

1, sudo systemctl status systemd-modules-load.service

2, sudo journalctl -u systemd-modules-load.service

3, sudo /usr/lib/systemd/systemd-modules-load

Results

1
[subin@subin-pc ~]$ sudo systemctl status systemd-modules-load.service
[sudo] password for subin:
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; >
Active: failed (Result: exit-code) since Wed 2019-02-06 22:43:36 IST; 2min 43s>
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 536 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, stat>
Main PID: 536 (code=exited, status=1/FAILURE)

Feb 06 22:43:36 subin-pc systemd[1]: Starting Load Kernel Modules…
Feb 06 22:43:36 subin-pc systemd-modules-load[536]: Failed to find module 'vfs_mo>
Feb 06 22:43:36 subin-pc systemd[1]: systemd-modules-load.service: Main process e>
Feb 06 22:43:36 subin-pc systemd[1]: systemd-modules-load.service: Failed with re>
Feb 06 22:43:36 subin-pc systemd[1]: Failed to start Load Kernel Modules.
lines 1-13/13 (END)…skipping…
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2019-02-06 22:43:36 IST; 2min 43s ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 536 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 536 (code=exited, status=1/FAILURE)

Feb 06 22:43:36 subin-pc systemd[1]: Starting Load Kernel Modules…
Feb 06 22:43:36 subin-pc systemd-modules-load[536]: Failed to find module ‘vfs_monitor’
Feb 06 22:43:36 subin-pc systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Feb 06 22:43:36 subin-pc systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.
Feb 06 22:43:36 subin-pc systemd[1]: Failed to start Load Kernel Modules.

2,

[subin@subin-pc ~]$ sudo journalctl -u systemd-modules-load.service
[sudo] password for subin:
– Logs begin at Sun 2019-02-03 17:46:30 IST, end at Wed 2019-02-06 22:49:05 IST. –
Feb 03 17:46:31 subin-pc systemd-modules-load[208]: Inserted module ‘vfs_monitor’
Feb 03 17:46:31 subin-pc systemd-modules-load[208]: Inserted module ‘crypto_user’
Feb 03 17:46:31 subin-pc systemd-modules-load[208]: Inserted module ‘sg’
Feb 03 17:46:31 subin-pc systemd[1]: Started Load Kernel Modules.
– Reboot –
Feb 03 17:50:39 subin-pc systemd-modules-load[198]: Inserted module ‘vfs_monitor’
Feb 03 17:50:39 subin-pc systemd-modules-load[198]: Inserted module ‘crypto_user’
Feb 03 17:50:39 subin-pc systemd-modules-load[198]: Inserted module ‘sg’
Feb 03 17:50:39 subin-pc systemd[1]: Started Load Kernel Modules.
– Reboot –
Feb 03 17:56:44 subin-pc systemd-modules-load[207]: Inserted module ‘vfs_monitor’
Feb 03 17:56:44 subin-pc systemd-modules-load[207]: Inserted module ‘crypto_user’
Feb 03 17:56:45 subin-pc systemd-modules-load[207]: Inserted module ‘sg’
Feb 03 17:56:45 subin-pc systemd[1]: Started Load Kernel Modules.
Feb 03 18:00:36 subin-pc systemd[1]: Stopped Load Kernel Modules.
– Reboot –
Feb 03 18:00:58 subin-pc systemd-modules-load[203]: Inserted module ‘vfs_monitor’
Feb 03 18:00:58 subin-pc systemd-modules-load[203]: Inserted module ‘crypto_user’
Feb 03 18:00:58 subin-pc systemd[1]: Started Load Kernel Modules.
Feb 03 18:19:46 subin-pc systemd[1]: Stopped Load Kernel Modules.
– Reboot –
Feb 03 18:20:07 subin-pc systemd-modules-load[203]: Inserted module ‘vfs_monitor’
Feb 03 18:20:07 subin-pc systemd[1]: Started Load Kernel Modules.
Feb 03 19:39:27 subin-pc systemd[1]: Stopped Load Kernel Modules.
– Reboot –
Feb 03 19:39:51 subin-pc systemd-modules-load[279]: Failed to find module ‘vfs_monitor’
Feb 03 19:39:51 subin-pc systemd-modules-load[279]: Inserted module ‘crypto_user’
Feb 03 19:39:51 subin-pc systemd-modules-load[279]: Inserted module ‘sg’
Feb 03 19:39:51 subin-pc systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Feb 03 19:39:51 subin-pc systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.
Feb 03 19:39:51 subin-pc systemd[1]: Failed to start Load Kernel Modules.
Feb 03 19:39:57 subin-pc systemd[1]: Starting Load Kernel Modules…
Feb 03 19:39:57 subin-pc systemd-modules-load[461]: Failed to find module ‘vfs_monitor’
Feb 03 19:39:57 subin-pc systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Feb 03 19:39:57 subin-pc systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.
Feb 03 19:39:57 subin-pc systemd[1]: Failed to start Load Kernel Modules.
lines 1-37

~

3,

Failed to find module “vfs_monitor”

#2

Well, many things changed since 17.1.12 … You should have take a look at the *.pacnew files too.
To be honest, that was a bad move. Too much time since you did not update, and maybe because of the huge number of packages, probably some bad mirror, now you have a partial update.
If you have access to TTY, try a new update.
See here how to boot directly to TTY

1 Like
#3

Only you may know what program looks for this.
Maybe look in

/etc/modules-load.d/*.conf

or run

grep vfs_monitor /etc/mod*/*.conf
1 Like
#4

I soled it by installing deepin-anything via dkms.

dkms install deepin-anything/0.0.3 -k 4.20.0-1-MANJARO

For some reason it fails to install when the kernel is changed.

#5

hey buddy

i have replaced “quiet splash pci=nomsi” and post “3”.After the grub update system rebooted. but i can’t start up the system due to Pci bus error, the display is flashing and un stopable. please provide a solution to access the grub menu without startup.

#6

There a reason ? (deepin-anything is in the repos and part of the deepin group)

#7

i cannot startup my system due to pci bus error firstly i need a solution for that after i will try the rest.
Thanks

#8

Can you boot to tyy by using 3 as grub boot option ?

#9

i have replaced “quiet splash pci=nomsi” and post “3”.After the grub update system rebooted. but i can’t start up the system due to Pci bus error

#10

That doesnt make sense to me… please try explaining it differently.

#11

@https://forum.manjaro.org/u/bogdancovaciu
he told to me to replace the “quiet” in grub boot menu and post “3” i have replaced it to “3” and post the command sudo update-grub this is done and post the next command “reboot” but the system is not rebooting due to PCI BUS Error.

#12

how about …
sudo pacman-mirrors -f
sudo pacman -Syyuu
mkinitcpio -P

systemctl reboot
[if you get an error … please copy it here]

#13

buddy

i cannot startup my system due to pci buss error

this is a sample picture of that

#14

See? How did I know you werent starting … you kept saying you could not reboot … I thought you couldnt turn off your machine :wink:

Anyways you can try a few things like
acpi=force
acpi_enforce_resources=lax
pci=noaer

Otherwise … if you cant boot … you gotta use some other live media and chroot in.

2 Likes
#15

hey where can i add this commands

acpi=force
acpi_enforce_resources=lax
pci=noaer

#16

Same place you put the 3 and nomsi
add to options after hitting ‘e’ at grub

Id probably first try replacing nomsi with pci=noaer … then maybe the 2 acpi ones together, and so on.

#17

hey i put the commands through Terminal

Open terminal

Sudo nano /etc/default/grub

then post the new line

Cntrl X

sudo update-grub

but how can i open terminal without the os startup

i am not an IT gay please provide each steps simple way

my procedue is

pressing power button > grub to display for OS Selection (Manjaro,
Advance Option for Manjaro and Windows 10) i selected Manjaro then the problem is starting (flashing the display)
so where can post the commands
acpi=force
acpi_enforce_resources=lax
pci=noaer

#18

At grub selection hit ‘e’

1 Like
#19

Read carefully what @cscs mentioned.
Instead of the above, try to replace “quiet splash pci=nomsi” with:
3 pci=nomsi acpi=force acpi_enforce_resources=lax
or
3 pci=noaer acpi_enforce_resources=lax
or combinations of those parameters …

1 Like
#20

You were told to replace only quiet, not more and only at grub boot menu, not in /etc/default/grub.

Start from the beginning and be more careful, spend some time reading, please.

1 Like