[SOLVED] Error with rtl8812au

#1

When installing kernel 4.11, it errors out on my wifi module. Anyone with same wifi module?

Error! Bad return status for module build on kernel: 4.11.0-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/make.log for more information.
1 Like
#2

I experience exactly the same problem with 4.11. That’s why I decided to stick to 4.9 LTS for the time being.
I wondered if kernel update that has just been released would change anything, but nope, I got the same error.

==> dkms install rtl8812au_rtl8821au/4.3.20.r16.d716b38 -k 4.11.1-1-MANJARO
Error! Bad return status for module build on kernel: 4.11.1-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/make.log for more information.

DKMS make.log for rtl8812au_rtl8821au-4.3.20.r16.d716b38 for kernel 4.11.1-1-MANJARO (x86_64)
pią, 19 maj 2017, 10:49:23 CEST
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.11.1-1-MANJARO/build 
M=/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build  modules
make[1]: Wejście do katalogu '/usr/lib/modules/4.11.1-1-MANJARO/build'
CC [M]  /var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/core/rtw_cmd.o
In file included from /var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/include/drv_types.h:32:0,
             from /var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/core/rtw_cmd.c:22:
/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/include/osdep_service.h: In function ‘thread_enter’:
/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/include/osdep_service.h:343:2: error: implicit declaration of function ‘allow_signal’ [-Werror=implicit-function-declaration]
allow_signal(SIGTERM);
^~~~~~~~~~~~
/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/include/osdep_service.h: In function ‘flush_signals_thread’:
/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/include/osdep_service.h:353:6: error: implicit declaration of function ‘signal_pending’ [-Werror=implicit-function-declaration]
if (signal_pending (current))
  ^~~~~~~~~~~~~~
/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/include/osdep_service.h:355:3: error: implicit declaration of function ‘flush_signals’ [-Werror=implicit-function-declaration]
flush_signals(current);
^~~~~~~~~~~~~
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:295: /var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build/core/rtw_cmd.o] Błąd 1
make[1]: *** [Makefile:1492: _module_/var/lib/dkms/rtl8812au_rtl8821au/4.3.20.r16.d716b38/build] Błąd 2
make[1]: Opuszczenie katalogu '/usr/lib/modules/4.11.1-1-MANJARO/build'
make: *** [Makefile:1670: modules] Błąd 2
1 Like
#3

Same here with a Wi-Fi dongle on 2 machines, but as said @ryanmusante it is only with Kernel 4.11, so for now I stick with 4.10 or better 4.9. LTS. The issue should resolve in the future… maybe.

#4

So, there is a new addition in “rtl8812au-v5-dkms-git”. But I don’t have any luck with that one either. So I’m staying on 4.10 until things change.

$ yaourt rtl8812au
1 aur/rtl8812au-dkms-git r47.2a9bbb7-1 (13) (0.78)
    A kernel module for Realtek 8812au network cards with dkms support
2 aur/rtl8812au-inject-dkms-git r44.2577553-1 (2) (0.98)
    A kernel module for Realtek 8812au network cards with dkms support, with 
    monitor mode and injection support
3 aur/rtl8812au-rpi-dkms-git 0.r54.21af4bf-1 (0) (0.00)
    Realtek 802.11n WLAN Adapter Linux driver for rtl8812au (patched for the 
    Raspberry Pi)
4 aur/rtl8812au-v5-dkms-git 5.1.5-2 (3) (1.90)
    rtl8812AU Chipset driver
5 aur/rtl8812au_asus-dkms 4.3.2.11100.20140411-2 (Out of Date) (10) (0.00)
    rtl8812au linux kernel driver for ASUS USB-AC56 Wireless Dual-Band USB 
    Adapter
6 aur/rtl8812au_rtl8821au-dkms-git 4.3.20.r8.9fea6c0-2 [installed: 4.3.20.r16.d716b38-1] (26) (0.42)
#5

I got a similar problem with rtl8192au and 8192cu and the patch has been applied at both the source used for dkms. Anyway, you can verify directly: the correction to apply, for both the driver, is the same. The file to patch is osdep_service.h and add the lines:

#ifndef __OSDEP_SERVICE_H_
#define __OSDEP_SERVICE_H_

#include <linux/version.h>
#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
#include <linux/sched/signal.h>
#endif

The lines to add are the last 3, more or less starting from line 23 of the original source code.

2 Likes
#6

@fdc1b

Thanks for the heads up!

closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.