[SOLVED] Error in KDE System Settings.

Welp, after I updated, I didn't notice right away but I have an issue with systemsettings5 in KDE Plasma on Frank. I'm getting massive errors.
When I open System Settings I can go to any category except Application Style-> GNOME/GTK Application style. When I click it it hangs for about 40 -50 seconds then crashes with this error.
When I open system settings, I get this error.

I've tried reinstalling glibc, but no luck. I wanted to post this before I did anything drastic (Downgrade glibc sounds like a bad move).
Current theme is Arc Dark. I tried other themes but it exhibits the same behavior.


Update

  • I've done all the tips & tricks on the archwiki
  • I've done the tips in the thread @saedlar93 with Petsams advice.
  • Tried kernels 419,52,53,414. Just for fun. :crazy_face:
  • Restore from backup. Updating brings the problem back.
  • sudo pacman -S plasma kf5 qt5 No joy.

And now I'll give @xircon's idea a try.
Wooho! Are we having fun yet?


???

1 Like

Thanks for the reply. :grin:
I read that. I have tried Petsams suggestions with no change.

Also, that person seems to have hacked at thier configs for having GTK themes in root some something. I haven't done that so at least that's a good thing.

Try (I haven't read petsams's post):

sudo pacman -S plasma kf5 qt5

Can I use a very, very rude word?

NSFW

BACKUP?

:rofl:

Also worth a pop:

cd /home/<your-username>/.config
mkdir plasma-old
mv *rc plasma-old/
1 Like

I do. And I did go back. However when I update it problem comes back.
Eh, forgot to add that to the list of tried stuff.

Summary

At least I know why the lights blink on my computer. :stuck_out_tongue:

1 Like

But you don't know why my lights blink, do you? :smiley:

1 Like

I'm sure the NSA does. :stuck_out_tongue:

Using your command. /sigh Bloody Discover-snap errored. I hate that program. I really do.

https://www.nationalsheep.org.uk/
:sheep: :sheep: :sheep: :sheep: :sheep: :sheep: :sheep: :sheep: :sheep: :sheep:
I asked them they said "Baaaah"

1 Like

Still crashes.

NEXT!

Does the install work or does that crash, if so:

sudo pacman -S plasma kf5 qt5  --overwrite="*"

Oh, I just left discover-snap out and it was fine.
:wink:

1 Like

Try a new user, rest plasma to defaults as I stated above or place a bucket over your head and rock gently.

Running out of ideas and there is very little info on the net.

1 Like

Oh, forgot about a new user. Good thinking. :wink:
I'll get stuck into that after my coffee. :coffee: All out of buckets though.

Tell me about it.

New Profile has zero problems. So I guess it's a theme somewhere or setting?

I wonder if taking the Trolltech settings from the new user and replacing mine would work?
Meh, about to find out. :rofl:

Are spotty fourteen year olds (with a bad attitude) allowed caffeinated drinks?

Did you try to reset your plasma as I stated above?

1 Like

Yep. I've done it several times. Several ways. At this point it's getting to where it's easier to reinstall.

HEY! Not 14! Sheesh.

1 Like

Just harking back to an older thread :smiley:

1 Like

You could stay with the new user and copy your stuff across, then delete the broken user.

1 Like

Weighing my options at the moment.

  • Reinstall
  • Use the new user
  • Go back to Windows since i never had these problems there!!!!!!
  • Go on as if nothing is wrong. Who cares about GTK settings anyhow? It's all skinned properly. I only noticed the crashing when I want to change the cursor for Firefox.
  • All of the above (Not the Windows one)

I blame KDE.