[SOLVED] Disable PC Speaker when Backspace is pressed on Log In

Hi, as I’m sure many users know, on some computers Manjaro XFCE produces a loud beep sound when user clicks on Log Out. I was able to disable this by following this Arch Wiki entry:

https://wiki.archlinux.org/index.php/PC_speaker#Disable_PC_Speaker

However, no tutorial I could duck out has provided me with the solution on how to disable the PC Speaker in the Log In screen, when Backspace is pressed when there are no more characters left to delete.

To clarify, how this often happens is when I’m logging in, I type my password incorrectly by accident, so I hold Backspace to delete the whole string. But if I hold Backspace too long, the loud beep sound from PC Speaker occurs.

Was anyone able to find solution to this?

EDIT: The solution was in the Arch Wiki all along. For everyone stumbling upon this topic, run in terminal:

sudo rmmod pcspkr
sudo nano /etc/modprobe.d/nobeep.conf

Paste these two lines in the newly created file:

# Do not load the 'pcspkr' module on boot.
blacklist pcspkr

Press Ctrr+X to exit, type Y to save changes and press Enter

5 Likes

What method have you used to disable the PC speaker? It seems that blacklisting should prevent beeps even during login. Or you can try kernel parameter as pointed out in the Archwiki article.

1 Like

Try this

xset -b

Then open your .xprofile file

sudo mousepad ~/.xprofile

add this line to your .xprofile

xset -b

https://forum.manjaro.org/t/how-disable-bios-beep-like-sound-in-some-applications/17094/5

sudo rmmod pcspkr
sudo echo "blacklist pcspkr" > /etc/modprobe.d/nobeep.conf
1 Like

This did it. I didn’t realize I need to first create the nobeep.conf file, my bad for not reading the Arch wiki entry more carefully. I edited the OP for anyone who stumbles upon this topic.

1 Like

glad it worked out.

you dont, that command creates it for you and puts “blacklist pcspkr” in it.

For me, it returned “Permission denied”. It seems you need to login as root, instead of using sudo, which I also did not know:
https://askubuntu.com/questions/230476/how-to-solve-permission-denied-when-using-sudo-with-redirection-in-bash

Forum kindly sponsored by