[SOLVED] Deepin Dock gone after updates


#1

Scrolled through latest journalctl - these ‘errors’ were there, some listed dozens of times. The one that specifically mentions the dock seems relevant, not sure about the others…

kernel: e1000e 0000:00:1f.6: The NVM Checksum Is Not Valid

daemon/launcher[1116]: manager.go:343: queryPkgName failed: Manager.desktopPkgMap is nil

daemon/watchdog[715]: manager.go:89: Launch 'dde-dock' failed: org.freedesktop.DBus.Error.ServiceUnknown:The name com.deepin.dde.Dock was not provided by any .service files

systemd[663]: Failed to start BAMF Application Matcher Framework.

Obviously I can use the Win/Start key to access apps. However I noticed another issue, not sure if it is related. Went into control panel, tried to change my user account avatar. When opening an avatar folder, none of the images showed. Everything looks fine if I access the file manager directly.


#2

For this you will have to reset the NVM … afaik you can make use of the ethtool

For the rest … hm … try to upgrade the stardde package by using the one from testing branch

sudo pacman -U http://mirror.ragenetwork.de/manjaro/testing/community/x86_64/startdde-3.4.0-1-x86_64.pkg.tar.xz

#3

I get ‘package missing required signature’ - is there a way to bypass that?


#4

hmmm … it shouldn’t do that
probably from terminal:
sudo pacman-key --init


#5

Download the signature file as well:
http://mirror.ragenetwork.de/manjaro/testing/community/x86_64/startdde-3.4.0-1-x86_64.pkg.tar.xz.sig


#6

got past the signature issue - testing version matched existing version, so just reinstalled - when running startdde I still get dde-dock failed errors


#7

That’s bad … try from terminal to to kill it first with pkill dde-dock and then quickly relaunch it with dde-dock and post the error you get in that instance.


#8

command not found

so I went into the Add/Remove Software app - installed Deepin Dock (wasn’t installed!?) - ran startdde - all good! That was a strange one…


#9

Well, i will mark your last comment as solution, so nobody will get confused. I would cross install packages from a different branch as last resort, only in special conditions.
Maybe we can notify @oberon - if there might be something that triggered the uninstall of Deepin Dock package during the last update, maybe he can investigate it :slight_smile:
Glad you sorted it out!