(SOLVED) Click on external device icon opens qmplay2 instead of Files

Hello to the Community,

I am using the Gnome version of Manjaro since only yesterday and I have also installed qmplay2 media player from AUR via the package manager. Whenever I click on a disk icon on Dash or on the Desktop in order to browse its contents, qmplay2 starts instead of Files. I get the same strange behaviour also when I click on Home, Documents, etc shortcuts of Arc Menu. When I click the disk icons inside Files (I mean after I have manually started Files) I can access the content as usually.
Thanks in advance.

Hi!
You need to check what applications opens what, check in settings/applications or something like that, I don’t use gnome.
Also if you do right click on icons and choose open with, you can change the app that it will be opened with

Please check the file ~/.config/mimeapps.list.

Remove any unwanted associations.

1 Like

This specific file contains no information relevant to qmplay2.
Thanks anyway

Settings β€”> Applications β€”> QMplay2 β€”> Other Files contained a relevant entry which I don’ t remember exactly because it disappeared after I have unset it. This did the trick.
Thanks very much!!!