[Solved] Canon PIXMA TS705 Drivers

Dear All,
I bought for my daughter a.m. printer and want install the drivers on notebook with latest manjaro-kde.

The manufacturer offer rpm, deb and ‘source-file’ Canon-PIXMA-TS705_Drivers an there are cnijfilter2 and cnijfilter3 in the version ‘5.80-3’.
I tried to compile the “source-file” but fails.

  • In the AUR are three packages cnijfilter2-bin 5.10-2, cnijfilter2 6.00-1 and cnijfilter2-common 4.10-3
    Note: On my home-net ‘Brother_HL-3152CDW’ can I already print but this notebook reside at another home in which will move as soon the “Canon” drivers are on it.

1. Can I install one of the drivers from AUR and which one is the right one?
2. If not, should I convert the rpm or deb to arch-architecture.
3. If I’m forced to use ‘source-file’ could someone tell me how to compile and install successfully?

Thanks in advance and best regards.

if it is a network printer this could help:

The drivers available in AUR are - as far as I could see - for different models.

Short of creating or adapting a PKGBUILD for installing this specific driver
I’d use debtap to convert the Debian package to arch.
Seems to work - with a little effort:

The package is a compressed archive
unpack that:
tar xzf cnijfilter2-5.80-1-deb.tar.gz
inside the directory which gets created, there is a “packages” directory
inside that there are two versions, presumably for 32 bit vs 64 bit machines
cnijfilter2_5.80-1_amd64.deb and cnijfilter2_5.80-1_i386.deb

Now you can run debtap on that cnijfilter2_5.80-1_amd64.deb
… after you installed it from AUR and have run
sudo debtap -u to initialize it

The resultant package can then be installed via
sudo pacman -U cnijfilter2-5.80-1-x86_64.pkg.tar.zst

I hope it works!

it seems the automatically generated dependencies are not correct
It want’s to install
aarch64-linux-gnu-binutils-2.35.1-1 aarch64-linux-gnu-gcc-10.2.0-1 aarch64-linux-gnu-glibc-2.32-1 aarch64-linux-gnu-linux-api-headers-5.8-1
which seems wrong
… perhaps you can force install it without those? don’t know

re your third question:
that source archive looks too complicated for me - it looks like it is set to be used to build either the debian package or the rpm package
I don’t know how to use that to build the package on Manjaro or Arch without modifications.

1 Like

Thanks a lot for your answer Nachlese at first.

By building the packages from ‘source-file’ occur the same error (dependencies), these dependencies (gcc = c++ = compiler) are for ARM-processors (64-bit) and niter for desktop 32-bit nor desktop 64-bit.
ARM-CPU’s are RISK-CPU’s (restricted-instructions…) and used on smart-phones or raspy-similar (one-small-board-computers). That’s worse for Canon.

Seeing this Canon-Video I fear that this printer is only for android and iphone.

This printer is niter supported by Guteprint nor by Foomatic.

That’s mean (most probably) I should try to install the deb on Ubuntu/Kubuntu but… how can I take the driver from buntu and transfer to Manjaro?

Thanks for the link with IPP but… should not be anyway installed a driver?

They say no - if that printer is one that supports that method.
I just read it and thought it could be useful info. That’s all I know.
I never had a network printer.
Why not try? - it seems to be the easiest method.

If it doesn’t work:
Why not try what I suggested - use debtap to convert the debian package you can download from the same website you got the source package from?
I have the package here, extracted it, used debtap to create the Arch/Manjaro package - and could even install it.
I just cannot test whether it works.
sudo pacman -Udd cnijfilter2-5.80-1-x86_64.pkg.tar.zst
should install it without the (wrong) dependencies.

Of course you can use your filemanager to do the extracting if you are not comfortable on the command line.
But for the debtap program there is no way around that.
… all the commands are here - just a copy+paste job :wink:

That link to the printers website … you linked to the german website.
Sprichst Du deutsch? Deine Info sieht danach aus. Ist vielleicht einfacher.

Thanks Nachlese.

I installed debtap, on Manjaro initialize with sudo debtap -U on arch initialize with sudo debtap -u and it’s works

It just created a folder with subfolders with a couple of files but nothing else, following these instructions the package is quickly done by using debtap -q <package-name> and this works fine.

Please to all people want use -q, use small q not the capital letter Q, after some edits…

so the complete procedure is:

Canon PIXMA TS705 Drivers

Step 1. Download Canon PIXMA TS705 Drivers, choose (debian Packagearchive).

Step 2. Unpack the archive with File-manager or Code:

tar xzf cnijfilter2-5.80-1-deb.tar.gz

Step 3. Inside unpacked archive/folder we find the package of interest, this is:


Step 4. Install ‘debtap’ and other necessary packages with Code:

sudo pacman -S --needed bash base-devel git wget binutils pkgfile fakeroot \
debtap system-config-printer cups-pk-helper cups-pdf

don’t worry about \ (back-slash) in Linux, it just mean ‘continue command or list in next line!’.

Step 5. Initialize ‘debtap’ with Code:

sudo debtap -u

Step 6. Convert deb-package to zst-package with Code:

debtap -q cnijfilter2_5.80-1_amd64.deb

Step 7. Install new converted zst-package with Code:

  1. Recommended is the installation without ‘ARM-RISK 32-bit’ dependencies with Code:

sudo pacman -Udd cnijfilter2-5.80-1-x86_64.pkg.tar.zst

  1. Installation with ‘ARM-RISK 32-bit’ dependencies with Code:

sudo pacman -U cnijfilter2-5.80-1-x86_64.pkg.tar.zst

Remove drivers or any other package (Arch-Linux &/ Manjaro)

sudo pacman -Rns cnijfilter2-5.80-1-x86_64.pkg.tar.zst

Thanks again to Nachlese to helping me!

  • [x] Done! & Enjoy!

P.S.: If someone want download the ‘*.md’ file, you can fin it here on GitHub.

The installation seems to have went ok.
installing it with
sudo pacman -Udd cnijfilter2-5.80-1-x86_64.pkg.tar.zst
would have skipped the installation of the wrong dependencies …

Now it only needs to actually work. :wink:

I think, the arm-cpu dependencies will be used for network-printing and I suppose this printer has a small risk-cpu on board as well as the fritz.box (or any other modem) and many other connected device (smart-phones, tabletts, etc…)

As soon my daughter come with this printer I will test it.

Can you tell me how to remove such manually installed packages? Maybe I want tray without dependencies.

That should be:
sudo pacman -Rns $packagename
There is no difference between “manually” installed or otherwise.

:joy: A big update coming yesterday that want install cnijfilter2 6.00-1.
This one I could install also before converting the deb-package and install canon 5.8.
My question now is: How/where can I see if 6.00 support TS705 ot TS700-Series?

Sorry, but I have no idea what you are asking.
What we have done here was a crude hack to make the printer work.
You could try whether cnijfilter2 6.00-1 now also does the job.
I don’t know.

Manjaro want upgrade from driver ver. 5.8 to ver. 6.0 and I don’t know if the ver. 6.0 (from AUR) support the printer.

If the ver. 6.0 from AUR support the printer, everything is perfect, if not, I have to point it in the /etc/pacman.conf to not be updated anymore.


I searched in the AUR for cnijfilter2 6.00-1 and downloaded the source-code.
Knowing/remembering that most important file for printer are ppd-files… I found ppd-folder for both versions and found:

~/Downloads/Canon/PIXMA TS705/cnijfilter2-source-5.80-1/ppd/canonts700.ppd
~/Downloads/Canon/PIXMA TS705/cnijfilter2-source-6.00-1/ppd/canonts700.ppd

These Files are exact the same, hence… I installed the version 6.0 from AUR an will test if owrking

cnijfilter2 6.00-1 in the AUR is not new - last updated July 23 2000
It’s not the correct driver.
Trying to install it will fail anyway - I just tried.

None of the drivers available in the AUR where the correct drivers for your printer.

That’s why we hacked our own using the file from Canon and then converting it with debtap.

cnijfilter2 5.80
was the result - which you installed

Now we seem to have a naming conflict - since we didn’t bother to adapt the automatic process as long as it resulted in a package that gave you an installable driver.

The version cnijfilter2 5.80 is not from AUR - it’s the one you hacked together.
It can’t be updated via AUR

I’d advise to not update it.
In the future, when it fails, you’ll have to do the manual process all over again.
Till then, don’t touch it.


Last Updated: 	2020-07-23 13:30

The system suggest to upgrade but fails, but if uninstalled… is possible to install directly ver 6.00-1

I’m little bit confused now, anyway, if you are right and I have to hold ver. 5.80 than I have to edit /etc/pacman.conf and insert

IgnorePkg   = cnijfilter2

NoUpgrade   = cnijfilter2

It’s right?

That is probably correct - I have never had the need to do this so I never tested.
But it seems correct.

If they now have a new version available and you want to have it,
you’d need to get it and repeat the whole manual process to build a package with debtap, then install it.

No they (Canon) haven’t new vers. 6.00. Vers. 5.80 is from Canon and vers. 6.00 is the source from AUR.

If I well understood, you mean I should relay on Canon version, correct?


Thanks a lot to you for clear, simple and honest answer.

It continues :wink:
and sorry for the ensuing confusion … as I’ll now say pretty much the opposite of what I said so far today :man_shrugging:

I just had a look into the source code downloaded for the AUR package cnijfilter2 6.00-1

I looked into the ppd directory, there is a file called NEWS

this lists all the printers this should work with.

The upshot of this is:
Yes, the AUR package cnijfilter2 6.00-1 should be the correct one - and it builds and install just fine.

I don’t know anymore why we/I ruled it out previously - and went the more complicated route.

I’d try building and installing it and see if the printer works.
If it does - it makes maintaining things much easier.

I just built and installed it successfully, so it shouldn’t be a problem for you either.

Finally the solution of the topic is:

sudo pacman -S cnijfilter2

… that easy, yes? :wink:
Not even the AUR involved.
oh well - good for you! :+1: