[SOLVED] Cannot create new container!!!

Hi guys,

I'm running Arch but I figured since you guys have a GmbH you could solve my problem. I'm trying to set up a new chroot with DEVTOOLS, but I get alot of errors:

Running aur-x86_64-build
==> Creating chroot for [aur] (x86_64)...
==> Creating install root at /var/lib/archbuild/aur-x86_64/root
==> Installing packages to /var/lib/archbuild/aur-x86_64/root
:: Synchronizing package databases...
downloading core.db...
downloading extra.db...
downloading community.db...
downloading multilib.db...
:: There are 26 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file  7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff  14) gzip  15) libtool  16) m4  17) make  18) pacman  19) patch  20) pkgconf  21) sed  22) sudo  23) systemd  24) texinfo  25) util-linux  26) which

Enter a selection (default=all): 
resolving dependencies...
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "libncursesw.so=6-64", a dependency of "readline"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "gawk"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "gawk"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "gmp"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "libncursesw.so=6-64", a dependency of "readline"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "sh", a dependency of "gmp"
warning: cannot resolve "gmp>=5.0", a dependency of "mpfr"
warning: cannot resolve "mpfr", a dependency of "gawk"
warning: cannot resolve "awk", a dependency of "autoconf"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "m4"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "libncursesw.so=6-64", a dependency of "readline"
warning: cannot resolve "readline>=7.0", a dependency of "bash"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "bash"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "bash"
warning: cannot resolve "bash", a dependency of "m4"
warning: cannot resolve "m4", a dependency of "autoconf"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "diffutils"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc>=2.27", a dependency of "gcc-libs"
warning: cannot resolve "gcc-libs", a dependency of "ncurses"
warning: cannot resolve "ncurses", a dependency of "readline"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
warning: cannot resolve "glibc", a dependency of "ncurses"
warning: ignoring package linux-api-headers-5.1-1
warning: cannot resolve "linux-api-headers>=4.10", a dependency of "glibc"
...

The log goes on like this for a while but after waiting for 30 minutes the forum just told me I can only have 98000 characters. So sorry guys so it's impossible for me to post the whole thing.

I'm willing to pay a lot of arch coins for this!!!

Moved to newbie corner.
Please edit your post, use </> to propper format the text.
If you look for GmbH then this forum is the wrong place :smiley:

4 Likes

Thread moved to #other-os.


Sorry Bro. :hugs:

4 Likes

Well played guys. :slight_smile:

You mean it was a test? :face_with_raised_eyebrow:

2 Likes

This was the Arch Linux TU Alad Wenter "messing around".

[13:48:33] <dvzrv> alad: I'm sorry you're having trouble with one of our products. would you like to contact our premium customer services? https://manjaro.org/support/firststeps/
[13:48:33] <phrik> Title: Manjaro - First Steps (at manjaro.org)
[13:48:38] <dvzrv> oh wait
[13:48:47] <alad> RIP in pieces
[13:50:18] <alad> dvzrv: oh, I shall ask on teh forum
[13:50:32] <dvzrv> hehe
[13:50:45] <alad> "Hi I'm running arch, devtools don't work. I saw you guys have a GmbH so I figured you could solve my problem"
[13:50:46] <dvzrv> alad: not sure, I use devtools pretty vanilla for building
[13:50:56] <dvzrv> alad: sounds like a plan
[13:51:02] <alad> alright!
[13:51:09] <dvzrv> "I'm willign to spent some big arch coins on this!!!"
[13:51:15] <alad> !!
[13:51:16] <phrik> POPOZÃO!
[13:52:34] <alad> dvzrv: > What branch of Manjaro do you use > Other OS
[13:52:36] <alad> perfect
[13:55:57] <dvzrv> haha
[13:56:11] <dvzrv> curious to see what comes out
[13:56:47] <alad> dvzrv: pasting the 10k lines of devtools output to their form crawls it to a halt
[13:59:11] <alad> this might take a while...
[13:59:17] <alad> > Body is limited to 98000 characters; you entered 1692821.
[13:59:19] <alad> :D
[14:01:56] <alad> dvzrv: https://forum.manjaro.org/t/not-solved-cannot-create-new-container/105371
[14:01:57] <phrik> Title: [NOT SOLVED] Cannot create new container!!! - Technical Issues and Assistance - Manjaro Linux Forum (at forum.manjaro.org)
[14:07:32] <alad> ready to spend those big archcoins!!!
[14:09:14] <Foxboron> ...
[14:09:31] <alad> :D
[14:09:41] <Foxboron> jonathon: I apologize for alads behaviour.
[14:10:06] <alad> I apologize for all the 9001 manjaro users who misused our bbs for their issues
[14:10:41] <Foxboron> alad: You as an Arch team member don't have to act like a clueless Manjaro user.
[14:10:48] <alad> aww :(
[14:10:55] <Foxboron> Come on.
[14:11:17] <alad> but if archlinux-premium cannot solve my issue, who can?!
[14:11:22] <alad> ok ok
[14:11:25] <alad> I'll remove it later :P
[14:12:10] <alad> heh it was moved to newbie corner
[14:12:19] <Foxboron> Rightfully so.
[14:12:40] <alad> Foxboron: I'm not offended considering every support request I've done on the arch forums was in the newbie corner
[14:12:45] <alad> :D
[14:35:36] <alad> jonathon: pretty good https://forum.manjaro.org/t/about-the-other-os-category/33571
[14:35:37] <phrik> Title: About the Other OS category - Other OS - Manjaro Linux Forum (at forum.manjaro.org)
[14:36:23] <alad> +1 internet point for you
[14:37:18] <alad> anyway sorry for the offtopic stint/acting like a douche. still'd appreciate some feedback on the orginal issue :)
1 Like

I suspect your configured pacman.conf has linux-api-headers in the IgnorePkg variable.

Forum kindly sponsored by Bytemark