[Solved] Can not mount partition to manjaro-chroot from live-usb

Hi! Due to my Notebook having a power outage during an update, I was getting:

error: file /boot/vmlinuz-5.4-x86_64 not found
error: you need to load the kernel first.

After investigating I figured to look into ls and ls /boot yields:

efi/ grub/ memtest86+/ linux419-x86_64.kver intel-ucode.img linux54-x86_64.kver

No idea what these .kver files are all about, but the both my 5.4 and 4.19 kernel links aren’t here as expected.
After some more investigation I decided to go with a live USB and manjaro-chroot to fix the issue. Since I’ve got encryption for all partitions except the UEFI Fat32 partitions (one for Windows, one Grub/Manjaro) I ran into some more issues that I’d appreciate help with. I went as follows:

  1. Enable UEFI only boot and disabled csm in my bios
  2. Live boot of Manjaro via UEFI boot loader
  3. Via sudo gparted “open encryption” on my Manjaro / partition /dev/nvme0n1p6
  4. sudo mount -t ext4 /dev/nvme0n1p6 /mnt which is where I am stuck:

mount: /mnt: /dev/nvme0n1p6 already mounted or mount point busy.

My investigation on this issue yielded multiple suggestions, I unsuccessfully tried the following and more for the last couple of hours:

  • Booting live-usb via UEFI only (I didn’t do this at first) but it didn’t solve the issue.
  • Trying to mount via Gparted (doesn’t work, option to mount there is disabled/grayed out)
  • lsof | grep nvme0n1p6 shows nothing. so it seems the mount point is in fact not busy.
  • sudo umount /dev/nvme* lists me all the partitoins and says neither of them is currently mounted.

Any idea how I can get the partition mounted to get into manjaro-chroot? Thank you, any help is appreciated!

Here’s some more relevant info:

$ sudo manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
==> ERROR: You can't mount 0!


$ lsblk -f 
NAME                FSTYPE      FSVER            LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0               squashfs    4.0                                                                           0   100% /run/miso/sfs/livefs
loop1               squashfs    4.0                                                                           0   100% /run/miso/sfs/mhwdfs
loop2               squashfs    4.0                                                                           0   100% /run/miso/sfs/desktopfs
loop3               squashfs    4.0                                                                           0   100% /run/miso/sfs/rootfs
sda                 iso9660     Joliet Extension MANJARO_XFCEM_202 2020-12-03-12-24-42-00                     0   100% /run/miso/bootmnt
├─sda1              iso9660     Joliet Extension MANJARO_XFCEM_202 2020-12-03-12-24-42-00                              
└─sda2              vfat        FAT12            MISO_EFI          83D8-49E4                                           
├─nvme0n1p1         vfat        FAT32            SYSTEM            CC3B-A8C8                                           
├─nvme0n1p3         ntfs                         Windows           DC9E40739E4047EA                                    
├─nvme0n1p4         vfat        FAT32                              FBD1-A561                                           
├─nvme0n1p5         crypto_LUKS 1                                  b6d6e87f-cb0d-40f9-965c-7b2527f8dd99                
├─nvme0n1p6         crypto_LUKS 1                                  22b307b9-3559-4496-b6f5-bdf2050e8c58                
│ └─nvme0n1p6_crypt ext4        1.0                                b328a288-78d7-4f9f-a717-653a61aae6a7                
├─nvme0n1p7         crypto_LUKS 1                                  a4e15206-0f62-4fc0-a329-1af923499443                
└─nvme0n1p9         ntfs                         WinRE_DRV         46A4414CA4414023      

nvme0n1p6 is the only partition I decrypted via Gparted since that should be my Manjaro’s / which I’d like to mount to use with manjaro-chroot. I successfully mounted and unmounted nvme0n1p4 which is the UEFI Fat32 partition, but that doesn’t help.

1 Like

If you start from scratch on the live-usb:

cryptsetup luksOpen /dev/nvme0n1p6  nvme0n1p6_crypt 
mount /dev/mapper/nvme0n1p6_crypt  /mnt
mount /dev/nvme0n1p4  /mnt/boot/efi
manjaro-chroot /mnt

when you’re finished, unmount in this order:

umount /mnt/boot/efi
umount /mnt

Thank you so much flipper, /dev/mapper is exactly the missing part here that I wasn’t aware of :sweat_smile:, also thanks for mount /dev/nvme0n1p4 /mnt/boot/efi, I am finally able to manjaro-chroot.

I am trying pacman -Sy linux54 now and naturally get

error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck

as my machine got a power outage during an update.

Going with pacman -Qkk I get lots of warnings.

What would be the recommended course of action in this case? Simply go ahead and delete db.lck and run pacman -S?

yes, it’s safe to remove the lock file if no other update/install instance is running

Great progress, I re-installed my kernels and am finally able to progress in the booting of my original Manjaro installation. But now I am getting

[FAILED] Failed to start light display manager.

I guess the failed update damaged more stuff, but I also ran pacman -Syyu already. Perhaps related to the latest Nvidia issues? Probably not though. Will investigate later, got to head out for now.

Here is a nice read for you: 👩‍🏫[HowTo] Boot without a password for encrypted root partition
You don’t need to use the passwordless boot functionality described in there, but it will explain some info for you in future :wink:

Yes, probably a videodriver issue.
Give the output of:

inxi -G
mhwd -li -d
$ inxi -G
$ mhwd -li -d
NAME:        video-linux
VERSION:     2018.05.04
INFO:        Standard open source drivers.
DEPENDS:     -
CASSIDS:     0300 0380 0302
VENDORIDS:   1002 8086 10de

I am actually no longer getting [FAILED] Failed to start light display manager. But booting simply gets stuck. Doing it without the quiet grub option, the last thing I see is [ OK ] Started hostname Service. Using the TTY, sudo journalctl reveals a couple of things:

kernel: proc: Bad value for 'hidepid'
bumblebeed[977]: Module 'nvidia' is not found.
bumblebeed.service: Failed with result 'exit-code'

And then

systemd-coredump[1707]: Process 1704 (lightdm-gtk-gre) of user 620 dumped core.
                        Stack trace of thread 1704:
                        #0  0x00007f733c1a1693 memset (ld-linux-x86-64.so.2 + 0x22693)
                        #1 ...
systemd[1]: lightdm.service: Failed with result 'exit-code'.

After that we get a systemd[1]: lightdm.service: Scheduled restart job, restart counter is at ... multiple times with the above lightdm stack trace inbetween each try.

Sorry for any typos, I typed this manually from some pics I took with the phone. I could upload them but not sure there’s anything else interesting.

Trying sudo lightdm –-test-mode --debug next I guess. Not sure it’s related to Nvidia, I think I’ve actually been using my integrated Intel graphics card before, dedicated graphics is Nvidia Quadro P2000 Max-Q.

looks like no nvidia driver is installed, you’re running on a laptop?

Doesn’t inxi -G give any output? Maybe you’ll have to install inxi, otherwise we’ll never know which driver you’ll need.

Also, fixing the graphic part, is not my best, but I try :slight_smile:

Yes, weirdly inxi -G gives no output at all. pacman -Sy inxi complained about existing files, they don’t belong to any installed package acording to pacman -Qo inxi though, so I deleted and installed inxi again from within the live-usb’s chroot.

Now inxi -G gives

Graphics:  Device-1: Intel driver: i915 v: kernel 
           Device-2: NVIDIA GP107GLM [Quadro P2000 Mobile] driver: nouveau v: kernel 
           Display: x11 server X.org 1.20.10 driver: intel  
           Message: Advanced graphics data unavailable for root. 

If I do the same using the live-usb (I chose the open source drivers option), the last two lines change:

           Display: x11 server: X.Org 1.20.10 driver: intel,nouveau unloaded: modesetting s-res: 1920x1080 
           OpenGL: renderer: Mesa Intel UHD Graphics P630 (CFL GT2) v: 4.6 Mesa 20.2.3 

Not sure whether bumblebee came with Manjaro, perhaps I installed it at some point. Doesn’t seem to be part of the live-usb, although it apparently has both drivers (intel,nouveau) but probably doesn’t support Nvidia optimius (graphics hot-swapping) by default but rather via some command I assume. I guess I chose the proprietary (non-ope source) graphic drivers when installing Manjaro which might be powered by bumblebee.

lightdm –-test-mode --debug wasn’t helpful at all, it just gets me stuck in the loader.

mhwd -l gives me

> 0000:01:00.0 (0300:10de:1cba) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2020.11.30               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
          video-nvidia            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:3e94) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2020.11.30               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

I tried sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee and it failed, pacman indicating that it already exists in my filesystem just like it did with inxi.

I also noticed that I can’t run e.g. vim, nothing happens, like with inxi before I deleted files and reinstalled it… I suspect that some packages are still in some kind of corrupted state due to the crash during the system update… Does that make any sense? If that’s right, then fixing these corruptions somehow should also fix all my boot issues.

It’s maybe not a bad idea reinstalling all packages again, you can do that with:

sudo pacman -Syu $(pacman -Qqen)

for AUR packages, I’m not sure maybe this could work

yay -Syu $(pacman -Qqem)

Do you still need to chroot into your install or can you get into terminal using ctrl+alt+F3

Also I think it would be a good idea, updating the topic title [UPDATE] to the need of installing your nvidia drivers

Yes, I was looking into that but I get tons of

<package-name>: <file> exists in filesystem

It seems adding --overwrite "*" did the trick now. Not sure about AUR, but I don’t think I’ve got any essential packages there.

So, now mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee also succeeded :grinning:

> Successfully installed video-hybrid-intel-nvidia-390xx-bumblebee

I can get into terminal since I sucessfully chrooted. But doing it from the live-usb is a bit more convenient really (wifi running, web browser to check stuff…)

Yes, I think I’ll open a new topic and mark this as solved if I still need help with graphic drivers. But I am also thinkink about just re-installing Manjaro, just not sure how complex it would be to do that within my current encryption setup and then mounting /home which I’ve got on a separate partition nvme0n1p7 :thinking:

1 Like

Opened a new topic Booting “Module ‘nvidia” is not found” and lightdm issues for the graphics card issue. I am still getting the errors after installing the driver via mhwd -i.

Thank you again for all the help so far flipper :bowing_man::bowing_man::bowing_man:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.