[SOLVED] Boot loop before GRUB

Hi everyone. I need a little help with my laptop boot loop.

I had windows 7 + Manjaro and later this month i’ve decided to go to full Manjaro.
So, I’ve formated my SSD and installed Manjaro from LiveUSB.

After i boot, my laptop goes to infinite loop before GRUB. I tried everything(format not only as MBR but even GPT), I did different partitions and installed boot loader in different places, but nothing helps.

The main problem is, that I can’t use UEFI boot. My laptop got some firmware error, that if you load UEFI it bricks. And there is no new firmware on the official site.
So, the only option for me is to use Legacy Mode.

If anyone can help, that would be great. I just don’t want to go back to Windows. :slight_smile:

SOLUTION:
On old PCs there is some bug with boot flag on bootloader.
Just set boot flag on your boot partition (example: /dev/sda)
You can use Super Grub Disk https://www.supergrubdisk.org/ to boot in system.
And inside system use GParted to set boot flag
Also, you can use terminal for this. :slight_smile:

Please provide information regarding your hardware… you can use inxi -F to generate the information.

Additionally, if you have not already, you should read the various posts and wiki articles on Grub repair/ re-installation?

I’ve digged internet and forums for 4 days and nothing helped. And reinstalled GRUB lots of time. It won’t even work if I do full SSD format and install OS in automatic mode.

Here is the text from LiveUSB.

System:
  Host: manjaro Kernel: 4.14.65-1-MANJARO x86_64 bits: 64
  Desktop: KDE Plasma 5.13.4 Distro: Manjaro Linux
Machine:
  Type: Laptop System: SAMSUNG product: 300E4C/300E5C/300E7C v: 0.1
  serial: <root required>
  Mobo: SAMSUNG model: NP300E5X-U01RU v: FAB1 serial: <root required>
  UEFI [Legacy]: Phoenix v: P04RAC date: 06/14/2012
Battery:
  ID-1: BAT1 charge: 35.0 Wh condition: 45.5/48.8 Wh (93%)
CPU:
  Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197
  2: 1198 3: 1198 4: 1199
Graphics:
  Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Card-2: NVIDIA GF108M [GeForce GT 620M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.1 driver: intel,nouveau
  unloaded: modesetting resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.1.6
Audio:
  Card-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.14.65-1-MANJARO
Network:
  Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
  IF: wlp2s0 state: down mac: 1e:b1:28:28:c0:b9
  Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: down mac: e8:03:9a:e4:06:be
  Card-3: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
Drives:
  Local Storage: total: 236.62 GiB used: 2.01 GiB (0.8%)
  ID-1: /dev/sda vendor: Crucial model: CT250MX200SSD1 size: 232.89 GiB
  ID-2: /dev/sdb type: USB model: General USB Flash Disk size: 3.73 GiB
Partition:
  ID-1: / size: 11.59 GiB used: 88.6 MiB (0.7%) fs: overlay dev: ERR-102
Sensors:
  System Temperatures: cpu: 53.0 C mobo: 29.8 C gpu: nouveau temp: 41 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 178 Uptime: 1m Memory: 15.45 GiB used: 626.8 MiB (4.0%)
  Shell: bash inxi: 3.0.20 

Did you make changes in your BIOS to indicate you wish the machine to use Legacy boot not UEFI? Did you point the bios to all the boot locations?

Yes, of course. UEFI is disabled and boot locations are working as they should. There is no problem with Win7 installation. And there was no problems when I installed Manjaro as a second dualboot.

Reset bios to default setting

I tried this many times. But to be sure I did it right now. And it’s not helping.

I also disabled FastBoot, to be sure. But no. I also changed all values in BIOS, except UEFI, trying to find something. But nothing helped.

I think there is something with the installer. On my main PC i’ve installed Manjaro without any problems using UEFI. But, same image is giving me troubles on my laptop using Legacy Mode.

Try this
Sudo bash
Modprobe nvram
dd if=/dev/zero of=/dev/nvram

So i did it from LiveUSB. And here is the log:

[manjaro manjaro]# dd if=/dev/zero if=/dev/nvram
v����� �0+1 records in
0+1 records out
114 bytes copied, 0.000454443 s, 251 kB/s

So did bios got reset
While installing simply choose erase entire disk
And install manjaro and try KDE and xfce isos

I did full reinstall. 5-7 times. And it’s not helping. I will try to install xfce and write here.

Can u send image of what happens

It’s just keeps rebooting before GRUB loading.

Secureboot is off ???

I don’t think my laptop got Secureboot. There is nothing in BIOS.

Bios image if possible

All tabs in Bios. Sorry for the external link, there is some limits for new users. :slight_smile:

Ok. So i’ve installed New Manjaro 18 with XFCE and it is not working. The result is the same.

Right now i see only one option to install Win7 and install Linux as second OS. It will enable GRUB to load itself…:frowning:

You should try with a newer ISO.

On your current situation, you could try to boot to your installation, using Live media and the manual method, explained in this tutorial, to see if you can get to your grub menu. If it succeeds, login and run a full update, while after the update, make sure you remove quiet from /etc/default/grub, and run again update-grub

1 Like

This tutorial doesn’t help at all. All those commands are not working for me. But thanks to last comment i am able to get to my system by using https://www.supergrubdisk.org/

It boots when i choose manually to boot.
And my bootloader is in “/boot”. Maybe I should move it to /dev/sda? I think that’s the problem.
When i installed OS, i chose /dev/sda. But it installed in “/boot”.

Forum kindly sponsored by