[SOLVED] Bluetooth permanent deaktivieren


#1

Ich will Bluetooth permanent deaktivieren/löschen. Ich musste bei der Suche schmunzeln, da offensichtlich einige Probleme haben Bluetooth zum laufen zu bringen und ich das Teil gerne löschen will weil es permanent (perfekt) funktioniert. Nach jedem Start von Manjaro muss ich Bluetooth (in der Leiste) mit der rechten Maustaste deaktivieren.

Im BIOS (sofern das noch so heisst) habe ich bereits gesucht, doch keine für mich erkennbare Einstellung gefunden. Ich habe auch versucht in Pamac die Bluetooth-Komponenten zu löschen …was keine gute Idee war! :no_mouth: danach hatte ich keinen Internet-Zugang mehr. Nun, was darf/soll/kann ich ausschalten/löschen, damit einzig Bluetooth deaktiviert/gelöscht ist?

Mein Gerät ist ein “HP Notebook x2 - 10-p037nz”.


#2

Wenn du Bluetooth nur temporär ausschalten willst, damit du ggf. Bluetooth wieder einfach an schalten kannst und du Blueman benutzt, sieh dir dieses Link an

https://wiki.archlinux.org/index.php/Blueman#Disable_auto_power-on

Wenn du Bluetooth Software löschen willst kannst du z.B. diese Pakete löschen.

blueman bluez bluez-utils pulseaudio-bluetooth

Entferne auf keinen Fall bluez-libs wenn du den NM verwendest. Aber ich denke das hast du schon selbst bemerkt.

Das Entfernen von Bluetooth Software deaktiviert natürlich kein Bluetooth. Die Hardware Unterstützung ist immer noch da, nur etwas schwieriger zu verwenden. Wenn du Bluetooth wirklich komplett ausschalten willst deaktiviere (blacklist) die Kernel Module die dein System für Bluetooth benötigt. Welche das sind ist Hardware abhängig. Wenn Bluetooth an ist einfach mal mit lsmod nach bluetooth suchen. Es könnten z.b. sein btrtl btintel btbcm bnep btusb und natürlich auch einfach nur bluetooth .


#3

In Xfce kannst du auch unter Sitzung und Startverhalten unter Automatisch gestartete Anwendungen den Haken bei “Blueman-Applet” raus machen, sofern es nur um Blueman nicht starten geht.


#4

@xabbu: Danke! …und ja, das ich bluez-libs nicht entfernen soll habe ich bemerkt. :grin: Deine angegebenen Pakete werde ich morgen löschen, wenn ich einen ausgeruhten Kopf dazu habe. Der Hinweis in Deinem Link verstehe ich nicht - was soll/kann ich da genau tun? Grundsätzlich klingt das ja auch ganz gut, dass es nicht einfach eingeschalten ist beim Start:

Disable auto power-on

Blueman automatically enables Bluetooth adapter ( `` ) when certain events (on boot, laptop lid is opened, …) occur. This can be disabled with the auto-power-on in org.blueman.plugins.powermanager :

$ gsettings set org.blueman.plugins.powermanager auto-power-on false

@firefightux: Ok, den Haken habe ich jetzt erstmal entfernt. Danke.


#5

Voraussetzung ist das du Blueman verwendest. XFCE verwendet Blueman, Gnome und KDE nicht. Bei den Comunity Editionen bin ich mir nicht sicher, das müsstest du selbst herausfinden.

Wenn Blueman im Autostart aktiviert ist und einen Bluetooth Adapter findet, wird dieser von Blueman sofort aktiviert. Das heißt nicht das der Adapter “sichtbar”/“erkennbar” ist, aber bereits bekannte Geräte können einen Verbindung aufbauen. Wenn man nur hin und wieder Bluetooth verwenden will, aber trotzdem ein Bluetooth Icon in der Benachrichtigungsfläche (Systray) haben will, dann kann man das sofortige aktivieren ausschalten. Dazu musst du einfach den Befehl ohne sudo und ohne das $ in einem Terminal ausführen.
Das ist im Prinzip das selbe als wenn du einen Rechtsklick auf das Bluetooth Symbol in der Benachrichtigungsfläche machst und dann auf “Bluetooth ausschalten” klickst. Nur automatisch bei jedem Start.


#6

@xabbu: Danke, das hat einwandfrei funktioniert. Ich lasse es erstmal so stehen. Deine weiteren tollen Informationen habe ich mir notiert und freue mich wieder etwas dazu gelernt zu haben. :vulcan_salute:


#7

you can likewise under Session and Start Behavior under Automatically propelled applications the snare at “Blueman Applet” out, on the off chance that it is just about Blueman does not begin.