[solved] awesome wm screen geometry not matching x settings

GTX 1070 out to an old samsung tv with nonfree drivers
On a fresh, updated install of manjaro with awesome wm, I had to set some overscan. After saving and setting the x config generated by nvidia-settings, the right and bottom edges of the screen are off the edge of the display, but the mouse can't be moved to there. Restarting awesome doesn't help. There's a similar issue on the arch forums with no replies.
my x config: https://pastebin.com/Xqm83YbX
Any ideas? Anything else I need to paste?

Option         "metamodes" "nvidia-auto-select +0+0 {viewportout=1822x1024+49+27}"

are you sure on these values? "viewportout=1822x1024+49+27"

xrandr --prop
hwinfo --monitor

also, verify the specs on the tv/monitor being used and get the exact size, and add it to your xorg config in the monitor section

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    DisplaySize     340 190   <<--change acordingly
    HorizSync       27.0 - 81.0
    VertRefresh     23.0 - 75.0
    Option         "DPMS"
EndSection

The viewportout values are just what nvidia-settings spat out when I set the underscan slider to 49, and from where the mouse stops at the edges it seems right

xrandr --prop gave me this https://pastebin.com/dAM9u5w6
hwinfo --monitor very quickly flashed some output on a single line which was then replaced with my terminal prompt, not sure what's up there

By exact size, do you mean the "597mm x 336mm" on line 16 of xrandr's output?

1 Like

yes, but confirm those are the actual dimensions from another source, manual possibly? a quick google on the model should probably be fine as well.

the other thing i just thought about, when i hook my laptop to my TV i end up with the screen not fit properly and i need to use the TV remote to adjust the fit. on my samsung tv, it's on the bottom of the remote labeled something like "s. size" which cycles between different modes like "16:9", "stretch". and "fit" if i remember correctly. i would try this first instead of messing with xorg configurations.

also, this is what the monitor is defined as in xrandr output

HDMI-0 connected primary 1822x1024+0+0 (normal left inverted right x axis y axis) 597mm x 336mm

but it's not a listed mode, so

 1920x1080     60.00*+  59.94    29.97    23.98    60.05    60.00 

1920x1080@60hz is whats being used for a video mode. (which is the correct value). i really think the issue is on the TV end.

i use awesome-wm also and it behaves the same as when i would use the TV with windows setups in the past. changing the "s. size" or aspect ratio on the tv is what makes it fit properly

1 Like

Alright, setting the DisplaySize properly had the interesting effect of making the whole screen scroll when the nouse reached the edge, which was fun for a few minutes.
I found the remote, and the picture settings menu had a "screen fit" option that fixed everything and made underscan unnecessary.
Thanks, this is solved now.

1 Like

glad it worked out. :+1:

Forum kindly sponsored by Bytemark