[SOLVED] Autostart not working

openbox

#1

I now have a few .desktop files copied to the following locations:

/etc/xdg/autostart
/usr/share/applications
~/.config/autostart

And yet these apps do not autostart. I can manually start them all.

What do I have to do to make sure they autostart?


#2

Are they executable? Check with ls -la if they have the “x”. If not use chmod +x *.desktop

Otherwise write an .sh File with the execution comments and put that one into the Manjaro autostart.


#3

Well I certainly thought they were all set that way. Evidently chmod doesn’t follow with copied files. Time to test another reboot.

[UPDATE: It did not fix the problem]


#4

Try an .sh-File and put that into the autostart. Write Into that File:

#!/bin/bash

./*yourdesktopfile*.desktop

#5

Can you share one of those .desktop files here?
Which desktop are you using?


#6

here’s one:

[Desktop Entry]
Name=Blueman Applet
Comment=Blueman Bluetooth Manager
Icon=blueman
Exec=blueman-applet
Terminal=false
Type=Application
Categories=

xfce desktop with openbox wm and tint2 panels


#7

I do not see a mistake in that file.

Are you sure that blueman-applet is an executable which can be executed just like that in a terminal or via Alt-F2?

You might want to try with the full path of the executable.


#8

Yes, typing blueman-applet into terminal - launches the icon in systray. After reboot, no icon, requires manual start


#9

It depends on how you start your session.
If you use Openbox Xinit (IIRC) the autostart of openbox is different. RTM about OB


#10

According to the Arch Wiki you can use the file ~/.config/openbox/autostart.

Adding in that file

blueman-applet

or (with a delay of 3s for example)

(sleep 3s && blueman-applet) &

could make it work.


#11

@petsam pointed me in the right direction - went into Preferences > Openbox > Edit autostart - I had added my network applet here manually, but evidently I also botched something. So I put lines in for bluetooth, power and the network line up next to the line with volume icon, right after starting tint2. Not only do I get all of those apps autostarting, my PIA VPN applet and the pamac applet are now also populating.

Any way, so there’s about ten different ways to autostart, but this problem appears to be resolved now.

Even though @petsam prompted me to the right fix, technically @bill_t gave a more specific answer. Unfortunately I can pick only one official solution, so I’m picking his since it is more helpful for future forum searchers. But kudos to @petsam as well.