[SOLVED] Airport Express not detected by Pulseaudio v12.0-1.1



I recently did a clean install of Manjaro Gnome v17.1.10. Now I’m trying to stream audio to my Airport Express device. Before the reinstall this worked without issues using Pulseaudio and the Pulseaudio RAOP-module.

According to the Pulseaudio release notes, the current version of the RAOP-module has been merged upstream as from Pulseaudio v11.0 (see here: https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/11.0/ und http://hfujita.github.io/pulseaudio-raop2/). I have Pulseaudio v. 12.0-1.1 installed.

In the pulseaudio prefs I have activated detection of Airtunes devices. However, the Airport Express device is not detected, and thus there is no respective sink available to play audio to.

Any ideas?

EDIT: Similar issue here: https://bbs.archlinux.org/viewtopic.php?id=230382 - the solution was to install pulseaudio-zeroconf. However, I have already installed this package and it still doesn’t work


You also have avahi enabled?

Did you reboot after installing zeroconf?


Request was also made here Airport Express wird nicht von Pulseaudio v12.0-1.1 erkannt

Suggested solution was made


Hi Strit,

yes, I did reboot after installing zeroconf.

I was looking into avahi too right now, and it looks like avahi might be the problem indeed. avahi-daemon does not seem to be running. I already have reinstalled avahi and rebooted, but still it doesn’t show up in the list of running processes in the system monitor. How can I set avahi to start up at boot?


Then take a look at the German forum


My bet would be something like:
sudo systemctl enable avahi-daemon or what ever the service is called. :slight_smile:
To start it now without reboot do:
sudo systemctl start avahi-daemon


Thanks, that did the trick!!! now working like a charm

closed #8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.