Solve my cabinet hdd light is always on

My computer’s cabinet’s (computer casing) HDD light, which should blink a red light while the HDD is in use, is now continually on since I installed Manjaro. Windows has never displayed this behaviour.

Hi @ssbin,

Since you’re posting in the KDE section, I’m presuming that’s your desktop environment, and it might because of Baloo indexing. To check, run the following:

top -b -n 1 | head -n 20

…in a terminal, and please provide the output.

Edit:

Please also run, and provide the output of:

sudo iotop -b -n 1 | head -n 20                                                                                                                                                                                                                    

If you don’t have iotop installed, it’s in the community repository, and can be installed using:

pamac install iotop

Edit #2:

Providing terminal output

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

```
pasted text
```

This will just cause it to be rendered like this:

Sed
sollicitudin dolor
eget nisl elit id
condimentum
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as descrribed above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

2 Likes
top -b -n 1 | head -n 20                                                                      INT ✘ 


top - 20:51:37 up 29 min,  3 users,  load average: 0.50, 0.59, 0.41
Tasks: 191 total,   1 running, 190 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0.0 us,  1.6 sy,  0.0 ni, 96.8 id,  1.6 wa,  0.0 hi,  0.0 si,  0.0 st
MiB Mem :  15955.0 total,  12701.7 free,   1592.7 used,   1660.6 buff/cache
MiB Swap:      0.0 total,      0.0 free,      0.0 used.  13986.7 avail Mem 

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
     41 root      20   0       0      0      0 S   6.7   0.0   0:00.06 ksoftirqd/3
    587 rock      20   0  281972  45284  38244 S   6.7   0.3   0:01.44 kglobalaccel5
   2681 rock      20   0  830676  94480  76616 S   6.7   0.6   0:00.60 konsole
      1 root      20   0  166808  12084   9068 S   0.0   0.1   0:00.74 systemd
      2 root      20   0       0      0      0 S   0.0   0.0   0:00.00 kthreadd
      3 root       0 -20       0      0      0 I   0.0   0.0   0:00.00 rcu_gp
      4 root       0 -20       0      0      0 I   0.0   0.0   0:00.00 rcu_par_gp
      5 root       0 -20       0      0      0 I   0.0   0.0   0:00.00 netns
      7 root       0 -20       0      0      0 I   0.0   0.0   0:00.00 kworker/0:0H-events_highpri
      9 root       0 -20       0      0      0 I   0.0   0.0   0:00.09 kworker/0:1H-events_highpri
     10 root       0 -20       0      0      0 I   0.0   0.0   0:00.00 mm_percpu_wq
     11 root      20   0       0      0      0 I   0.0   0.0   0:00.58 kworker/u8:1-flush-8:0
     12 root      20   0       0      0      0 S   0.0   0.0   0:00.00 rcu_tasks_kthre



sudo iotop -b -n 1 | head -n 20                                                           ✔  14s  
Total DISK READ :       0.00 B/s | Total DISK WRITE :       0.00 B/s
Actual DISK READ:       0.00 B/s | Actual DISK WRITE:       0.00 B/s
    TID  PRIO  USER     DISK READ  DISK WRITE  SWAPIN      IO    COMMAND
      1 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  init
      2 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [kthreadd]
      3 be/0 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcu_gp]
      4 be/0 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcu_par_gp]
      5 be/0 root        0.00 B/s    0.00 B/s  ?unavailable?  [netns]
      7 be/0 root        0.00 B/s    0.00 B/s  ?unavailable?  [kworker/0:0H-events_highpri]
      9 be/0 root        0.00 B/s    0.00 B/s  ?unavailable?  [kworker/0:1H-kblockd]
     10 be/0 root        0.00 B/s    0.00 B/s  ?unavailable?  [mm_percpu_wq]
     11 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [kworker/u8:1-events_unbound]
     12 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcu_tasks_kthre]
     13 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcu_tasks_rude_]
     14 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcu_tasks_trace]
     15 be/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [ksoftirqd/0]
     16 rt/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcu_preempt]
     17 rt/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcub/0]
     18 rt/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [rcuc/0]
     19 rt/4 root        0.00 B/s    0.00 B/s  ?unavailable?  [migration/0]


How to solve this ‘Baloo’?

  1. Open the Launcher.
  2. Open System Settings.
    3.1. Go to WorkspaceSearchFile Search.
    3.2. Configure as required. (Screenshot of my settings as attached below.)
    3.3. Click on the Apply button in the bottom-right corner of the window.

To re-start the index, according to the new settings:

In a terminal, rum the following:

  1. Disable Baloo
balooctl disable
  1. Clean all current content:
balooctl purge
  1. Re-enable Baloo
balooctl enable
  1. Check that everything is OK:
balooctl check

Note:

It can only be Baloo if the Baloo file indexer is installed and operational, by default this makes it KDE-only. I have no idea if it can be used about/for other D.Es. or what their indexers are even called if they have it.

I’m using kde :innocent:

1 Like