Software rendering keeps getting enabled

Alright, so i went ahead and did just that, so the only driver i have installed now is
video-hybrid-intel-nvidia-bumblebee and when i went to reboot it, it stopped at
[ OK ] Started TLP system startup/shutdown, so i went to tty2, (ctrl+alt+f2) to see what was going on, and startx throws out an error.
it wont boot into a GUI, but i still have access to the tty lines
it did the same thing when I reinstalled video-linux to put the bumblebee driver on

Okey. whats the errors?
And maybe
systemctl status lightdm

LightDM:
Active :failed (code=exited, status=1/FAILURE) failed to start light display manager,

startx command:
Server terminated with error (1)
xinit:giving up
xinit: unable to connect to the X server: Connection refused
xinit : server error

(i apologize about not having screenshots, im unable to get to the GUI if you need additional info just ask)

OK. so lightdm is failing.

Any info from trying to start it?

systemctl start lightdm
or config file
cat /etc/lightdm/lightdm.conf

..oh .. and outta left field .. this kinda reminds me of some virtualbox stuff

pacman -Qq | grep virtualbox

And lastly dmesg .. as its possible it wants a different nvidia module than mhwd assumed.

dmesg | grep -E 'nvidia|NVRM'

Trying to start lightDM seems normal, but brings me back to tty1 where you would usually see the GUI, but its still at the screen where it appears to have stopped mid boot
in the lightdm.conf file, theres A LOT of things commented out
and with virtual box, it is installed
linux419-virtualbox-host-modules
virtualbox
virtualbox-ext-oracle

no output from the dmesg command

This is a desktop system. Why setup bumblebee?

1 Like

Hey .. if they want to use PRIME they can go ahead.
If they can use neither and just kill the intel .. thats also fine.

But most likely the easiest thing for them to do is install bumblebee.

Correct me if I'm wrong .. but just saying 'F it' and trying to install a single driver on an optimus system like this is still a functionally broken system, right? Like it wont work well..

Why any fully functional setup breaks the DM right now .. I'm not sure.

I do not understand. This is technology for saving battery power on laptops. It has no benefit on a desktop.

@LinuxDaily Do you have 4 monitors connected?

I would just start over.

In tty:

Remove all video drivers

sudo mhwd -r pci video-linux
sudo mhwd -r pci video-nvidia
sudo mhwd -r pci video-nvidia-390xx
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee

Clean any leftover files (if everything uninstalled correctly none of these files should exist)

sudo rm /etc/modules-load.d/mhwd-gpu.conf
sudo rm /etc/modprobe.d/mhwd-gpu.conf
sudo rm /etc/X11/xorg.conf.d/*mhwd.conf

Then re-install Nvidia drivers

sudo mhwd -a pci nonfree 0300

Reboot and show inxi -Fxxxz again. Please just copy the text from terminal.

Also what is output of
pacman -Q bumblebee lib32-primus primus

If any are installed you should uninstall them also.

1 Like

do you know why you have bumblebee stuff installed?
like @korealinux said its only useful for laptop systems with optimus chipsets (which you dont have at least according to above inxi something output).

so ignore the recommendation to install bumblebee stuff.

I did a few things before you guys commented, i ran the pacman -Q command and none of those were installed, i remember i installed them at one point but they must have gotten uninstalled when i reinstalled video-linux to try something

heres the output from inxi -Fxxxz, i followed the steps prior, remove all grapics drivers, clean up all the files, reinstalled nonfree drivers, to answer a previous question, yes 4 monitors
System:
Host: andrew-desktop Kernel: 4.19.32-1-MANJARO x86_64 bits: 64
compiler: gcc v: 8.2.1 Desktop: Cinnamon 4.0.10 dm: LightDM 1.28.0
Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASRock model: Z170 Gaming K4/D3 serial:
UEFI [Legacy]: American Megatrends v: P1.10 date: 08/06/2015
CPU:
Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP
arch: Skylake-S rev: 3 L2 cache: 8192 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64152
Speed: 4000 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4000 2: 4000
3: 4000 4: 4001 5: 4000 6: 4000 7: 4000 8: 4000
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 418.43
bus ID: 01:00.0 chip ID: 10de:1b81
Display: x11 server: X.Org 1.20.4 driver: nvidia
resolution: 1360x768~60Hz, 1360x768~60Hz, 1360x768~60Hz, 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43
direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170
Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:10f0
Device-3: C-Media Blue Snowball type: USB
driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-14:4 chip ID: 0d8c:0005
serial:
Sound Server: ALSA v: k4.19.32-1-MANJARO
Network:
Device-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: ASRock
driver: alx v: kernel port: d000 bus ID: 06:00.0 chip ID: 1969:e0a1
IF: enp6s0 state: up speed: 100 Mbps duplex: half mac:
Drives:
Local Storage: total: 1.82 TiB used: 604.05 GiB (32.4%)
ID-1: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: CC43 scheme: MBR
ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0
size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial:
rev: 1A01 scheme: MBR
Partition:
ID-1: / size: 898.98 GiB used: 604.05 GiB (67.2%) fs: ext4 dev: /dev/sdb1
ID-2: swap-1 size: 17.18 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 55 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 35%
Info:
Processes: 239 Uptime: 2m Memory: 15.61 GiB used: 1.40 GiB (8.9%)
Init: systemd v: 241 Compilers: gcc: 8.2.1 clang: 8.0.0 Shell: zsh v: 5.7.1
running in: termite inxi: 3.0.32

Ok, you disabled the iGPU from BIOS (as others suggested), and the nvidia driver seems to load and work properly from the last inxi you provided... Is Cinnamon still on software rendering mode?
But now my question is, what mesa version you have installed on your system?
pacman -Qi mesa
probably needs "downgraded"
sudo pacman-mirrors -f5 && sudo pacman -Syyuu

1 Like

I don't think that was ever confirmed. Maybe it was enabled at some point when playing with Bumblebee.

To my understanding, I don't believe it is throwing me into software rendering mode anymore, but I am still getting the weird screen freezing thing discussed earlier, the message did not pop up when I logged out and back in like it usually did, heres the version of mesa installed:
Name : mesa
Version : 19.0.1-2

The only option in my bios menu is IGPU Multi Monitor, which I have set to disabled

1 Like

After unplugging and plugging in one of the monitors, seemed to have helped with the screen freezing thing discussed earlier, but I do believe im still running in software rendering mode due to noticeable performance issues and high CPU usage

Try turning on Nvidia Force Composition Pipeline. Some people with high CPU usage on GTX 1070 report success with this enabled.

To test from terminal

Turn on:
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

Turn off:
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0"

However, I am not sure if this is the correct syntax for a multi-monitor setup.

It can also be enabled/disabled from the start/cinnamon menu by going to NVIDIA X Server Settings -> X Server Display Configuration

Click on Advanced button
Check "Force Composition Pipeline"

You can also try "Force Full Compositon Pipeline" but some people report problems with it sometimes.

If this seems to work, enable it at boot time:
https://wiki.manjaro.org/index.php?title=Simple_fix_for_screen_tearing_-_nVidia

There are some other options you can try also (I use these as well successfully).

    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"

The Arch wiki says these options need to go in the Screen section, but it can be in Device section as well like the Manjaro Wiki says.

[Protip: A slight modification on Manjaro Wiki, instead of creating a custom file called 95-mhwd.conf and deleting 90-mhwd.conf file (this is actually a symlink to /etc/X11/mhwd.d/nvidia.conf), save your custom file as 85-mhwd.conf instead and leave 90-mhwd.conf alone. Then if you want to revert all custom changes, you can just delete 85-mhwd.conf and 90-mhwd.conf will still be there. Lower numbered files seem to have priority for xorg config files.]

P.S. - You can also try running Compton compositor with GLX backend instead of the Cinnamon windows compositor. But I do not use Cinnamon so cannot help you in detail.

P.P.S - When you play games, you want to turn in-game Vsync OFF with Force Composition Pipeline enabled.

1 Like

first of all, at least the nvidia driver is correctly loaded.

you could try for your remaining issues:
check xorg.log file, maybe you can find some helpful error message or something similar
like @korealinux said, maybe test some xorg config options (but dont use too many if possible).
available can be found in nvidia readme:
http://us.download.nvidia.com/XFree86/Linux-x86_64/418.43/README/xconfigoptions.html

(you can also click home at the bottom of the page and check other topics, e.g. regarding multi monitor setup)

changing those settings for nvidia, Force Composition Pipeline fixed the issue, the problem is resolved Thank you all that helped!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.