Software just doesn't seem to want to work in bottles

Hi,

I am running into issues with bottles.

I must have some kind of system misconfiguration because there doesn’t seem to be a lot of people complaining about the same problem.

I have bottles installed via flatpak and it runs fine. I can use it for diablo 2 for example and its okay.

However if I try and run something more modern, such as the Battle.net installer or the EA Launcher (installer) they just fail repeatedly. I am using the bottles ‘installers’ section.

I have tried many different wine versions, I have tried disabling fsync/esync, fresh bottles, restarts, windows versions, etc - however if I try to install battle.net with Lutris it works fine, leading me to believe the problem is instead with the flatpak sandboxing or bottles itself.

Suggestions greatly appreciated :smiley:

:saluting_face:

x86_64
XFCE
Kernel 6.0.6
Stable Branch

why try to solve a problem with wine or bottles
when you do not even have it with lutris?
why not use what works?

  1. Science.
  2. Sandboxing and separation.
  3. Lutris is for games specifically and bottles is for everything.
  4. Lutris is a pile and duplicates my game entries.

None of this is pertinent however.