Software download system unavailable while trying to remove Snap

Hi. I am using dual boot with Manjaro and Windows 10. Although I have used a few flavours of Linux. One of the programs I frequently use in Win 10 is Photoscape. I could not find Photoscape in the available software in Manjaro but I came across some information on the Photoscape website that I can install Photoscape in Manjaro if I first install Snap. In this effort I searched for and installed snap related system files but was still unsuccessful in installing Photoscape. I then uninstalled the snap related files but that has resulted in the removal of the software installation and update buttons in the start menu. Now I am unable to install or update my Manjaro OS. Yet, while you help me fix my system and get back the software installation buttons, I would also like to request you to hide the system related files in the application download list so that newbies like me cannot break their systems by inadvertently uninstalling critical system files. Thank you. Please help.


Photoscape is a windows only application and the snap package you would like to install, should be then a pre-configured wine environment running Photoscape.

I would suggest to install it manually:

Install wine

pamac install wine

Create a wine bottle:

mkdir ~/Photoscape
WINEPREFIX=~/Photoscape WINEARCH=win32 wineboot

Install Photoscape

WINEPREFIX=~/Photoscape WINEARCH=win32 wine PhotoScapeSetup_V3.7.exe

After following the setup, there must be a shortcut at the category wine of the startmenu.

About the “system files”:

Can you run sudo pacman -Syu or pamac upgrade in a terminal?

We should probably default to suggesting -Syyu
Because systemd timer pamac-mirrorlist.timer will run pacman-mirrors in the background.
Thus a mirror change could occur, and a db refresh could be required.
[pamac syncs db before install by default]

Dear megavolt, thank you for your prompt response to my help request. I am sorry for replying late due to the time difference and my work schedule. I already have Wine installed in my system and after the debacle of trying to install and uninstall snap related files I accidentally found Photoscape in the lost and found section of the start menu. But If I have any problem with it I will definitely follow your instructions to install it. Thank you very much for your help once again.

Yes, megavolt. I have typed “sudo pacman -Syu” in the terminal and it immediately began updating the system while I am typing these lines. Will this update process bring back the Software Add/Remove and Software Update buttons back on the start menu favourites menu again?

Sure :wink:

sudo pacman -Syu pamac-manager

Sorry, megavolt. I typed in the command and it returned an error message: “target not found: pamac-manager” and I don’t see the Software Add/Remove/Update buttons on the start menu either. Do I have to restart the system for them to appear?

Whupps sorry :slight_smile: , pamac-manger is the command to start this application. This is the package name:

If you use XFCE or GNOME and similar:

sudo pacman -Syu pamac-gtk

If you use KDE and simliar:

sudo pacman -Syu pamac-qt


Thank you megavolt. I am using KDE, hence, I typed in sudo pacman -Syu pamac-qt. The operation went smoothly and I now see two programs for installing and removing software in the >Applications>System menu: Pamac Qt and Bauh, but, unfortunately, still no Add/Remove Software buttons that were there in the start menu favourites when I installed Manjaro.

It should be there. Search for it in the start menu and put it to your favorites. I don’t use KDE, but should be the same procedure. Maybe it is somewhere in the settings?

Someone who uses KDE could help better.

Check what you have installed:

pamac search pamac | grep -i install


pacman -Ss pamac | grep -i install

Thanks for all your help. I got back the original software add/remove with the following command:
sudo pacman -Syu pamac-gtk
You had mentioned it earlier for Gnome and Xfce but it worked fine for KDE Plasma 5.

1 Like