So if one wanted to use Pipewire?

I want to install and run Pipewire as the default system on my Manjaro setup. I want to try it to see if I can get a particular windows app (that cannot automatically access the audio driver in Linux-WINE) .

It certainly does not work with PulseAudio! I have also had a look at JACK and that doesn’t seem to solve it.
The app does access the audio driver randomly after I have opened a linux app using pulse, but this is hard to replicate.

Hence the need to experiment with another system, probably will need to use jack too, although not sure at this stage.

Any help appreciated!!

Did you install pipewire-pulse and pipewire-jack? You may also need lib32-pipewire for 32-bit games. See PipeWire - ArchWiki

1 Like

Thanks Yochanan.

yeah I did try that but got knocked back because of conflicts and it would allow (even under sudo) me to remove the pulseaudio first.

Thanks for the link, I’ll check it out.

Yes, there are unresolvable dependency conflicts when attempting to replace PulseAudio with PipeWire or vice versa. You will need to remove packages ignoring dependency checks using pacman -Rdd <package> to remove the PulseAudio packages first.

1 Like

oh ok cool thanks!

oky doky, got all that working fine now. And the app auto runs the audio engine at boot up (in WINE)…onyl small issue now is latency.

It’s not bad, but I’d like to tweak it down a bit. I cannot do this in the app so is there a way to set a “system wide” latency level? say 128 buffer at 48000khz sample rate? That would give me about 3ms of latency which is fine for live keys work.


Thanks…I actually found that using pipewire-jack dropin worked quite well. I simply changed the settings in that, checked the notes and saw it altered the sample rates and buffers accordingly with no x-runs.

Just been playing with it now (as in instruments :slight_smile: ) soooo, early days, but looks like this one is solved for the moment.

Thanks again for your help Yochanan :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.