Snapper the easy way?

I’ve tested this in virtual machine and now on the my laptops, I’m looking that is working very well.

I’ve started installing yay:

sudo pacman -Syu

sudo pacman -S --needed git base-devel

git clone
cd yay
makepkg -si

sudo pacman -Syu
sudo pacman -S yay

after that I’ve installed snapper with:
yay -S snapper-support

and from pacman I’ve installed:


and update grub with:
sudo update-grub

All work very well, any suggestions are accepted.


1 Like

I guess you end up with something similar as Garuda Linux ?

I tried Garuda in a VM few weeks ago, i have to say that their btrfs config is really nice, much more better than Timeshift, which is very limited and not supported anymore.

I which Manjaro team adopt the Garuda btrfs way somehow

Yes I’ve tried also Garuda and snapper configured out of the box is very good.
I’ve tried also ArcoLinux and I think that is good also, you may choose with installation if use Timeshift or Snapper an all works good.
I don’t know why Manjaro is not adopting snapper as configuration out of the box and sincerly also documentation on this matter is very confuded.
In every case that procedure is ispired from EndevourOS and works also with Manjaro

Hi all,
sincerly I’ve seen a lot of tutorial about Manjaro with btrfs and snapper and all are confused.

Also Manjaro team has never released a tutorial on the matter and I don’t understand why…

This is another simple way that I’m testing and is going very very well

After a fresh installation of Manjaro, reboot and remove timeshift

$ sudo pamac remove timeshift
$ sudo pamac remove timeshift-autosnap

enable grub menu with
sudo nano /etc/default/grub

change in:
save and close
sudo update grub

after that install following:


create first snap with:
sudo snapper -c root create --description “initial snapshot”

sudo chmod a+rx /.snapshots
sudo chown :users /.snapshots

reboot and enjoy snapper

that’s all

Don’t use sudo with Pamac, it will prompt for authentication when needed.

No need to install yay from the AUR, it’s in the Manjaro community repo. :wink: :point_down:

Those are AUR packages and cannot be installed with Pacman.

FYI, I’ve merged your two threads. Please don’t create another thread when you already have one open about the same subject.