Snapd is not working since downgrade to systemd 239.6-2.2 advised in the security update on 2019-01-19

#21

I have just reviewed your topic at snapd forum.
This issue is not reproduced in a Manjaro VB-VM.
Something is wrong in your system, maybe on kernel. Have you tried other kernels?
If changing kernels does not help, only Manjaro devs/packagers might be able to explain or help IMHO.

1 Like

#22

Have you try installing squashfuse? package which will then let you install snaps without actually using the kernel squashfs filesystem.

0 Likes

#23

Yes, I have tried 2 kernels (both LTS).

  • Linux 4.19.16-1
  • Linux 4.14.94-1
0 Likes

#24

Yes, I have.

It’s installed on my system.

0 Likes

#25

These package versions are now out-of-date.

Can you confirm you have a fully updated system?

0 Likes

#26

These package (squashfuse) is the same like I have and my pc is udpated, Joshua look it

This guy resolve a similar issue so… maybe it can help you.

0 Likes

#27

Yes, I have. I applied the stable update released on 2019-01-23 to my system.

0 Likes

#28

I am going to review it.

0 Likes

#29

I tried to follow the steps of the snapd forum provided in the last link, with no success.

0 Likes

#30

Maybe it is the a issue with kernel and squashfs. Try the last kernel with a fresh install… After i read again your post(I didn’t read well -sry) you did all possible- so only wish you good luck man

0 Likes

#31

No problem, I truly appreciate your help with this. Hopefully with the next stable update, this can be fixed.

0 Likes

#32

Hello @jonathon!

Is there something that I could try with the kernel or Should I wait for the next stable update to see if maybe that fixes the issue with snapd?

0 Likes

#33

Hello guys @petsam @andicic89 @XtyM @jonathon!

I was able to fix the issue!!! :grinning::grinning::grin::grin::joy::joy::joy:

Below I described how I did it.

Yesterday, at the university I was checking the snaps apps with my classmates in their distros (debian, ubuntu, slackware so on and forth) and I noticed that for every snap app that they had installed on their distros, when running the command “df”, The root partition always showed several mount points like the following ones:

/dev/loop0,
/dev/loop1
/dev/loop2

I was curious about why when i ran df in my terminal i didn’t get mount points /dev/loop. So I started to research about it an I found the following post (https://bbs.archlinux.org/viewtopic.php?id=49570) in the arch linux forum in which a user was having a similar problem.

In that post, the arch user was advised to perform the comand

sudo modprobe loop

which I did, and then I ran the following command to install rambox

sudo snap install rambox

And it worked. However, I noticed that modprobe only enabled the mount loop module temporarily. So I looked for how to enable module permanently and after reading the kernel modules article in the arch wiki I run:

cd /etc/modules-load.d/
sudo nano modules.conf

I added “loop” to the modules.conf file and saved changes, then reboot, try to install the snaps again and it worked, my snaps are back!!!

imagen

I appreciate all your help an effort guys! I don’t still understand why the downgrade changed the module configuration but, anyway this is solved.

2 Likes

#34

@Joshua-17
Thx for sharing your succesful solution to all of us :slight_smile: Great work!
Don’t hesitate asking some questions :wink:

Cheers
Andi

0 Likes

#35

I don’t thing this is the real solution, or the source of the problem.
This module should have been loaded and boot-enabled in the kernel, or called(?) when needed. Check with

modinfo loop
mkinitcpio -M | grep loop
mkinitcpio -v | grep loop

Note: The last 2 commands don’t show anything for me, even if I have working snaps without any modprobe.d/*.conf file.

It would be more helpful/logical to look for signs in your journal

journalctl -k -g loop

More info here.

0 Likes

#36

Hey @petsam!

I ran all the commands

Running

modinfo loop

Showed this:

filename: /lib/modules/4.19.20-1-MANJARO/kernel/drivers/block/loop.ko.xz
alias: devname:loop-control
alias: char-major-10-237
alias: block-major-7-*
license: GPL
srcversion: 5179A034524587DA1743C36
depends:
retpoline: Y
intree: Y
name: loop
vermagic: 4.19.20-1-MANJARO SMP preempt mod_unload modversions
sig_id: PKCS#7
signer:
sig_key:
sig_hashalgo: md4
signature: 30:82:02:A5:06:09:2A:86:48:86:F7:0D:01:07:02:A0:82:02:96:30:
82:02:92:02:01:01:31:0D:30:0B:06:09:60:86:48:01:65:03:04:02:
03:30:0B:06:09:2A:86:48:86:F7:0D:01:07:01:31:82:02:6F:30:82:
02:6B:02:01:01:30:46:30:2E:31:2C:30:2A:06:03:55:04:03:0C:23:
42:75:69:6C:64:20:74:69:6D:65:20:61:75:74:6F:67:65:6E:65:72:
61:74:65:64:20:6B:65:72:6E:65:6C:20:6B:65:79:02:14:57:8D:81:
61:18:0B:06:56:79:C3:26:E4:A0:67:2D:37:5D:6A:33:B3:30:0B:06:
09:60:86:48:01:65:03:04:02:03:30:0D:06:09:2A:86:48:86:F7:0D:
01:01:01:05:00:04:82:02:00:B4:DB:E2:66:50:B8:B3:E7:8E:4E:A6:
E8:BD:A5:DC:D0:F4:4A:D5:7B:F9:51:1E:FC:66:F8:2B:29:9D:BC:C1:
47:82:39:BE:1E:72:CA:50:EC:A8:B5:D9:35:B7:7B:D8:A5:40:86:B5:
52:68:04:B2:54:3E:4D:00:74:FE:E0:A7:89:4D:D2:67:A2:BE:C0:28:
14:80:C6:61:D9:62:99:BB:96:B5:93:CD:F3:2F:02:24:50:07:26:EA:
65:FC:2B:69:55:AD:6D:AD:F7:68:F8:9A:42:A7:3C:8F:71:77:C5:75:
0F:99:48:B3:B5:91:33:66:BA:78:41:00:C2:6C:AF:AE:21:7B:AC:BC:
3A:8E:96:0B:BF:FB:91:02:9F:3A:92:FB:83:A9:D7:A4:01:16:DA:09:
48:CC:D9:CF:E5:15:23:CE:D5:5F:E0:BD:08:76:47:02:A1:9A:43:0A:
E6:3C:80:61:61:1A:9D:C8:39:11:13:91:1D:42:D7:18:65:49:D0:BE:
34:18:C7:8B:D6:28:B6:07:9A:9E:23:B6:59:7D:AD:F2:A3:A9:41:8A:
2F:99:34:BA:D9:B9:35:D7:CB:E0:B2:0E:57:56:66:FD:A5:68:45:BC:
FD:24:81:E1:37:E0:8A:CA:8C:5E:F3:37:40:92:9B:81:EB:20:E3:B6:
DA:62:89:DB:21:70:1C:05:77:58:B3:88:02:44:BE:AE:D1:00:0F:EB:
78:37:1B:E7:0A:A4:EE:D3:1B:75:DC:F7:4B:3C:73:91:86:1E:54:D3:
FB:47:49:97:93:B8:7A:AB:C3:EB:B2:BD:FA:F7:3B:62:F7:44:D7:95:
31:11:72:86:B7:57:5F:94:FA:04:E2:D2:3C:01:10:1E:EC:45:62:C4:
68:3E:83:27:33:80:E7:47:79:D1:A4:27:10:CC:F4:64:16:A4:B8:B7:
DC:16:70:5F:02:FD:F7:82:A0:35:01:3C:57:1B:D3:61:D2:C3:3E:0F:
0D:43:56:C8:C0:41:99:4A:5C:60:73:EB:C2:DE:E1:49:7A:15:00:7E:
71:A3:A5:56:66:0C:50:1F:7E:3C:E5:C7:CA:55:FF:A7:58:9C:9F:4D:
A6:6B:F5:52:88:49:9A:41:38:64:06:38:5F:5E:EB:99:5C:EB:46:C3:
F8:71:81:77:1F:1E:1F:0A:3B:59:AF:1B:80:55:76:5E:35:14:A7:1B:
D6:5D:CE:BC:F0:BA:54:49:F7:73:6F:30:ED:20:7E:09:E0:71:38:3E:
07:8D:DB:6F:5E:D8:D4:38:D7:7C:00:89:A0:FE:F6:08:0B:EF:1D:39:
76:48:4D:A4:D6:FE:F9:B8:01:3C:0F:3A:54:08:7B:92:4C:24:8D:2B:
E7
parm: max_loop:Maximum number of loop devices (int)
parm: max_part:Maximum number of partitions per loop device (int)

When I ran the last two commands, they didn’t show anything for me too.

This is what happened:

Running

journalctl -k -g loop

Shows the module loaded:

– Logs begin at Wed 2018-05-30 17:43:38 CST, end at Sun 2019-02-10 20:54:03 CS>
feb 10 20:50:10 MJ-LINUX kernel: Calibrating delay loop (skipped), value calcul>
feb 10 20:50:21 MJ-LINUX kernel: loop: module loaded

0 Likes

closed #37

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes