Snap-store seg fault

hi, i recently install snapd and also snap-store, sadly apon launching snap-store i get a segfault, please see below:

[ibanez@sunshine ~]$ snap-store
09:55:43:0978 Gtk Failed to load module “canberra-gtk-module”
09:55:44:0136 Gs enabled plugins: odrs, rewrite-resource, snap, icons, key-colors, key-colors-metadata
09:55:44:0136 Gs disabled plugins: appstream, desktop-categories, desktop-menu-path, dpkg, dummy, fedora-langpacks, fedora-pkgdb-collections, fwupd, generic-updates, hardcoded-blacklist, hardcoded-popular, modalias, os-release, packagekit, packagekit-history, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, provenance, provenance-license, repos, systemd-updates
09:55:44:0229 Gs /etc/PackageKit/Vendor.conf file not found
09:55:44:0424 Pango pango_font_get_hb_font: assertion ‘PANGO_IS_FONT (font)’ failed
Segmentation fault (core dumped)

any help would be appreciated, thanks in advance :slight_smile:

2 Likes

Hello,

Why not using pamac-snap-plugin with Pamac ?

If you followed this


still snap-store is not a package that Manjaro provides, but is actually a snap package …
3 Likes

I am using it but there are quite a few snaps that arnt available on pamac, this is the only reason.

Getting the same exact error. Don’t know why. Tried reinstalling snapd multiple times, following all the instructions at the “How to install Snap Store on Arch Linux” page, installing apparmor. Tried with and without sudo. Any help is greatly appreciated!!

I found a temporary solution until snap is fixed in Manjaro (h/t to mborzecki):

This is something I see on Arch too and AFAIK it’s caused by fonts cache. I can only get it working if I remove ~/snap/snap-store/common/.cache/* and wipe my fonts cache in ~/.cache/fontconfig .

1 Like