SMB: can't connect to server from mac os finder

Hi all!
premise: I’m not so expert in samba :smiley:

I’m running smb server 4.16.0 and I’m connecting to the samba server from virtual machines.
I have 2 shares mapped, here is my config file:

fruit:model = MacPro7,1@ECOLOR=226,226,224
access based share enum = yes
bind interfaces only = yes
interfaces = lo br1
netbios name = Internet

path = /media/2TB
read only = no
browsable = yes
create mask = 0644
directory mask = 0755
force user = nobody
valid users = xxx yyy

path = /media/6TB
read only = no
browsable = yes
create mask = 0644
directory mask = 0755
force user = nobody
valid users = xxx yyy

The issue: I can’t connect to the smb server from finder in mac os; this is happening from samba 4.16 (I think), was working fine in previous version.

I can see the server in the network:

I click on “connect as” to be able to input my user and password:

But connection failed:

Previously after inputting user/password it connected showing my 2 shares in mac os finder.

Maybe it’s an issue with my smb config?

Thanks for reading

I think you are in the wrong place - Manjaro forum does not provide support for macOS.

Your issue is irrelevant to Manjaro.

1 Like

the smb server is in manjaro, so I don’t understand why I should be in the wrong section…

Well - as your topic is entirely describing an issue with macOS - no mention of Manjaro - you understand why I say it is irrelevant to Manjaro.

You are also using a samba config which - despite my many years of experience - uses settings I have never seen before.

1 Like

You are right, I took it for granted that the server was installed in a manjaro host, sorry.
Can you please tell me if the output of testparm is correct?Because I cannot see any “processing section” before “Loaded services file OK”:

[root@tower tower]# testparm
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Weak crypto is allowed

Press enter to see a dump of your service definitions

If testparm says the file is OK - then it is OK for as far as the content of the configuration file.

The -s argument suppress the prompt for enter to show the content.

You can increase the output by using -d with a value of 1 through 10

Thank you, that’s strange and I’m starting to think about an issue with finder or a wrong config, because I’m able to access the shares directly, in the finder with address smb://xxx@
but not able to connect to the main server to see all the shares

That is because SMB1 is upstream disabled.

SMB1 uses the NETBIOS protocol to browse shares - and this protocol has been abused in famous ransomware attacks.

SMB2 and up you need to provide the path to the share to be able to access it.

This is a security feature.

You can lower this but it is bad to do so. See the troubleshooting guide linked above.

1 Like

Thank you again, this explain this behavior, do you know if it was “recently” changed in samba or in manjaro (like a couple of months)?It’s not too long that it behaves like that.

There has been recent reports on the ability to browse for shares - it is not a Manjaro specific change but upstream Samba.

I am quite sure it is done to harden samba shares against ransomware attacks.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.