Slow windows boot after opening manjaro

After booting into manjaro when I restart to open windows it takes around 2 minutes to boot windows and after unlocking the windows the icons are still loading which takes another 30 seconds plus the time is also changed .
Don't know why I'm facing this unusual behaviour after installing manjaro

New issues found
after pressing shutdown or reboot the system gets stuck on manufacturer logo acer here , but reboot , shutdown works fine in windows

Windows boot issues has nothing to do with Manjaro.

If you have followed the recommendations for a succesful coexistance of Windows and Manjaro - you will most likely have disabled Windows Fastboot and possibly Windows Hybrid Sleep. Both of these are designed to load Windows faster than normal - so you may just be the lucky owner of a slow system.

3 Likes

That.

If you can afford to, replace the mechanical HDD if you are using one with an SSD for operating systems. If there is space for both an SSD and an HDD in the system then keep and repurpose the current HDD for user data storage or backups.

HDD was working fine before dual booting , still works fine but the problem only occurs when I boot into manjaro and then boot into windows

For the Windows issue, as @linux-aarhus said, make sure fastboot is disabled in Windows. If it is enabled, it will ironically slow down your boot time in a dual boot system.

Also, when you get time run the defragmentation tool on your C drive, I notice that after shrinking a Windows C drive to install Manjaro, the partition gets fragmented and this can also slow your boot. Avoid letting Windows go into hibernation mode, make sure it is completely shutdown when you’re done using it.

As for Manjaro not shutting down properly, what kernel are you using? It helps to try different kernels for issues like that.

2 Likes

I don't know about kernel, I installed manjaro from officials website the KDE version.

regarding the shutdown freeze

1 Like

You can use the Manjaro Settings Manager, which is a graphical application, to easily manage kernels. Assuming you're on 5.4 LTS, try 4.19 LTS and see if that solves the issue. It would be helpful to see the terminal output of inxi -Fxxxza --no-host as that gives us some relevant system info. :grinning:

the slow booting issue is not solving, I turned the fastboot off :pensive:

what happens when you boot to windows, then you turn it off and then boot to windows again?
Is it faster or same?

Wait. It’s Windows or Manjaro that is not booting fast? Changing kernels was meant to help with your shutdown of Manjaro. You said Manjaro wasn’t shutting down properly. If it’s Windows being slow try defragging it. In Windows, search for an application called “Defragment and Optimize drives.” Run “analyze” then “defragment” on the drive that starts with C:/ or is labeled as your Windows partition.

If that doesn’t work, open a CMD prompt or a Powershell window as the administrator (right click and select “run as admin”) and type:

sfc /scannow

This will check for system corruption and try to repair it. I really can’t troubleshoot Windows too much further here per forum rules, so I have to stop here. Did the kernel change fix your shutdown issue in Manjaro? Also, if you search the web for the clock issue you can find instructions on how to fix it. If I post it here though I’m probably gonna get the thread locked.

That's a feature, not a bug
#WONTFIX
:stuck_out_tongue_winking_eye:

I rechecked it, before this issue I was having issues in grub , so I was booting into windows through boot menu from F12 , Now I discovered windows is loading slow when I boot it from grub

I checked for corruption , I did defragmentation but strangely now both manjaro and windows are loading slow , the shutdown issue on manjaro is fixed

haha, not for me until tableau comes for manjaro

This is odd behavior, and frankly it doesn't make sense to me. I'm starting to think the system is just naturally slow. The only other things I can think of to help out Windows would be to check your startup apps and/or adjust your virtual memory settings. After your next boot of Manjaro, can you post the terminal output of systemd-analyze --blame ? This will show us what is holding up the boot process on Manjaro, if anything at all.

That's good. At least we got one issue resolved. :grinning:

1 Like

That makes no sense whatsoever unless your laptop components are running too hot. That would cause temporary thermal throttling but defragmenting windows partitions would not otherwise slow manjaro down.

  • systemd-analyze blame

        7.683s lvm2-monitor.service
        6.979s dev-sda7.device
        6.266s snapd.service
        5.863s polkit.service
        4.444s NetworkManager.service
        3.623s apparmor.service
        3.076s systemd-fsck@dev-disk-by\x2duuid-3A0A\x2d584B.service
        3.064s pamac-mirrorlist.service
        2.172s snapd.apparmor.service
        2.085s systemd-journal-flush.service
        2.034s NetworkManager-wait-online.service
        1.946s ModemManager.service
        1.872s avahi-daemon.service
        1.796s dev-sda8.swap
        1.743s bluetooth.service
        1.738s systemd-logind.service
        1.721s linux-module-cleanup.service
        1.540s org.cups.cupsd.service
        1.519s systemd-tmpfiles-setup-dev.service
        1.202s systemd-modules-load.service
        1.085s systemd-udevd.service
         961ms systemd-timesyncd.service
         920ms systemd-binfmt.service
         756ms systemd-udev-trigger.service
         751ms tlp.service
         735ms upower.service
         693ms kmod-static-nodes.service
         688ms dev-mqueue.mount
         687ms systemd-journald.service
         552ms udisks2.service
         532ms proc-sys-fs-binfmt_misc.mount
         468ms systemd-sysctl.service
         429ms systemd-tmpfiles-setup.service
         378ms boot-efi.mount
         368ms systemd-tmpfiles-clean.service
         366ms systemd-random-seed.service
         343ms systemd-backlight@backlight:intel_backlight.service
         197ms user@1000.service
         165ms wpa_supplicant.service
         157ms systemd-remount-fs.service
         132ms sys-kernel-debug.mount
         131ms dev-hugepages.mount
         118ms systemd-update-utmp.service
          80ms systemd-user-sessions.service
          80ms sys-kernel-config.mount
          34ms pamac-daemon.service
          32ms user-runtime-dir@1000.service
          30ms rtkit-daemon.service
          26ms systemd-rfkill.service
           8ms sys-fs-fuse-connections.mount
           3ms tmp.mount
           1ms snapd.socket

I don’t see anything out of the ordinary here. I notice you are running snap, that can add to boot time since all the related services are needed to run it. Though I’m assuming snap is installed because you wanted it.

If you don’t use any lvm or raid partitions you can mask that service (lvm2 monitor) , if you think it’s worth saving 7 seconds on boot time. (You can check with sudo parted -l) Just be aware that if you ever want to use lvm in the future you’ll have to unmask and re enable that service.

Forum kindly sponsored by