Slow Performance Intel Graphics

Hello Community…

I have a big issue with the performance of video on my Laptop. The GPU is the one embedded on the Processor, which is labeled only as Intel HD Graphics even in the Intel Website. The problem is that Chrome, Chromium, and Vivaldi perform incredibly slow, until I disable the Hardware Acceleration. Nonetheless, when I play a video on youtube or netflix, i got some flickering in my laptop screen. This issue becomes more notorious when i connect a monitor on the VGA output, where the video (even at 360p) runs at 12 fps with very notorious Flickering.

Right now i have Manjaro Gnome 16.06.1, but the issue is present also in KDE and XFCE, with the xf86 driver installed and without it (on modesetting, with dri on 3).

This is not happening on Fedora 24 or OpenSUSE Tumbleweed. I believe that is an issue with Arch, because this week i ran tests ofr the same thing on Anteros, Apricity and Manjaro (not tried it on True Arch, as I haven’t time to do the installation) with the same exact results.

Here is my inxi output.

    System:    Host: r4-pc Kernel: 4.6.2-1-MANJARO x86_64 (64 bit gcc: 6.1.1) Desktop: KDE Plasma 5.6.5 (Qt 5.6.1)
               Distro: Manjaro Linux                                                                                                     
    Machine:   System: Hewlett-Packard (portable) product: HP G42 Notebook PC v: 049C110000202710000020000                               
               Mobo: Hewlett-Packard model: 1425 v: 54.26 Bios: Hewlett-Packard v: F.16 date: 05/20/2010                                 
    Battery    BAT0: charge: 22.1 Wh 100.0% condition: 22.1/44.0 Wh (50%) model: Hewlett-Packard Primary status: Full                    
    CPU:       Dual core Intel Core i3 M 350 (-HT-MCP-) cache: 3072 KB                                                                   
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9046
               clock speeds: max: 2266 MHz 1: 1599 MHz 2: 1199 MHz 3: 1199 MHz 4: 933 MHz
    Graphics:  Card: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
               Display Server: X.Org 1.17.4 driver: N/A Resolution: 1366x768@60.03hz
               GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 11.2.2 Direct Rendering: Yes
    Audio:     Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
               Sound: Advanced Linux Sound Architecture v: k4.6.2-1-MANJARO
    Network:   Card-1: Realtek RTL8191SEvA Wireless LAN Controller driver: rtl8192se port: 3000 bus-ID: 02:00.0
               IF: wlo1 state: up mac: 70:f1:a1:90:ec:08
               Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
               driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
               IF: enp3s0 state: down mac: c8:0a:a9:c3:d9:72
    Drives:    HDD Total Size: 500.1GB (60.2% used) ID-1: /dev/sda model: TOSHIBA_MK5059GS size: 500.1GB
    Partition: ID-1: / size: 21G used: 17G (82%) fs: ext4 dev: /dev/sda5
               ID-2: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
    Sensors:   System Temperatures: cpu: 61.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 200 Uptime: 36 min Memory: 2074.6/3756.3MB Init: systemd Gcc sys: 6.1.1
               Client: Shell (bash 4.3.421) inxi: 2.3.0
cat /etc/X11/xorg.conf.d/90-mhwd.conf 
## Generated by mhwd - Manjaro Hardware Detection
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod"       "SNA"
    Option      "DRI"               "3"
    Option      "SwapbuffersWait"   "true"
    Option      "TearFree"          "true"
    Option      "VSync"             "true"
    Option      "SWcursor"          "true"
Section "DRI"
    Group   "video"
    Mode    0666
Section "Extensions"
    Option  "Composite" "Enable"
    Option  "RENDER"    "Enable"

$ cat /etc/environment


Try these and reboot. Undo if useless.

1 Like

Thank you for such a fast answer…

These configs have to be made without the driver installed or with it installed???

With it installed.

1 Like

Thank you… I’ll try it when I’m at home, right now I’m at work… :grin:

intel onboard drivers are already installed on your system, i’d wager. But check this out anyway

Dunno if my config will work on your card. For driver specific info

man intel

On xfce and kde, you can get your compositor to vsync. Not so much in gnome (i hate gnome), just hoping those clutter env variables manage to do something on mutter. I found those on a cinnamon thread.


And don’t forget to reboot after the changes. :wink:

Well, the results are parcial. I’v got better perfomance on Chrome, but still has to be with Hardware Acceleration off…

Haven’t tried VGA output, but so far is promising…

Edit 1: VGA still sucks with youtube, not only with chrome or chromium, but also in firefox.

Shouldnt we create a separate file to the manjaro created (and updated) 90-mhwd.conf ?
Such as a 99-intel.conf. This way it takes precedent over the system created file, and wont be subject to non-user changes.


I tried by creatin 20-intel.conf, and no good results. I’m currently using Fedora, I’ll check if the issue is in the driver or in the kernel.

There’s people out there that are haviong the same issue, but only by disabling hardware acceleration is not a solution, specially if you want to watch youtube over the VGA output (curiously, Netflix don’t have that problem, but youtube is unplayable), and every browser based application (nuvola, steam, etc), are being affected by this issue.

Hopefully there’s a solution, because I love Manjaro and Arch, but this issue is really affecting my usage of the distro.

Have you tried using DRI “2” ?


Maybe try changing AccelMethod to “uxa” ?
(this will make tearfree invalid, so keep it with DRI “3”)

1 Like

I have this same problem, but with an i3 m380 CPU. It also affects Atom, and presumably anything else that runs in Electron.

My best guest is that affects anything that works over a Web engine…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by