Slow Network and high latency

Hello Manjaro-World, (Excuse my english in advance :sweat_smile:)

i am new at manjaro but after some houers of use, it is starting to be my favorite one after trying Hackintosh, Linux Mint, Ubuntu and Elementary OS.
I`am prety new in the Linux World too. The decision to change came because I was bored with Windows. Nevertheless I encountered some strange problems across Manjaro.

– Problem description –
After installing Manjaro, everything went great. Even my internet connection. After using it for some hours while installing the needed tools and so on my connection begun to get slower and slower. From Speedtest.net I started to get “Latency Test Error”. The Sites like www.google.de took 5-10sec to load. It feeled like DNS issues. And this problem is still present.

– Informations about my system and so on –

  • I have an Internet connection with Up 500k / Down 200k glass fiber so this coulnd be the problem :grinning:
  • I could reproduce this problem only under Manjaro: that means that even under Hackintosh my internet connection were perfect like under windows and linux mint. So my hardware can`t be the problem.
  • I reinstalled manjaro to be sure it wasn`t a bug while the installation and this time with bluetooth / WiFi disabled (Bios side).
  • This problems happened even while I was connected over my OpenVPN (redirect trough my home connection) and because every other distribution works perfect, it cant be a settings issue caused by my router.
  • As I said, at the beginning it worked great without this issue. Tryed different Firefox versions and cleaned the entire profile from addons and so on. This happen even in the terminal when I want to install new software (long loading times until it starts to download the packages and so on).
  • I tried the mainboard (Intel Ethernet I219-V) slot and the pcie adapter (Realtek RTL8111/8168/8411) but got the same issue.
  • I set manualy the dns server to 8.8.8.8 ; MTU 1500 ; speed: 1000 Mbps ; duplex: full…

Now I’m out of new ideas… What could be the problem? Does anyone have any idea?
grafik
Still loading after 10 sec
After this time if I reload it, its way faster but maybe just cause of the cache.

Ty in advance for the help.

I don’t really understand your problem - your screenshot shows your latency to your DNS as only 6.5 msec, which is very fast. The only suggestions I have would be to:

  1. remove the VPN from the equation - this just complicates the matter
  2. remove any software firewall you might have enabled
  3. reboot your home router

See if that helps…

This may be taking a sledgehammer to the problem, but something to try is running:

sudo modprobe -r e1000e
sudo modprobe e1000e InterruptThrottleRate=8000

When I googled for e1000e and latency I ended up at https://www.kernel.org/doc/Documentation/networking/e1000e.txt and the InterruptThrottleRate is all about adjusting latency and by default it it’s set to dynamic…so maybe it’s modifying itself to a bad place…

If you read the section on InterruptThrottleRate there are some other values you can try…

If you find something that works and want to make it permanent you would create a file like /etc/modprobe.d/e1000e.conf with the contents:

options e1000e InterruptThrottleRate=???????
1 Like

I would not use your Intel adapter. There have been many speed issues with the I-200 series lately.

I would use your Realtek adapter. Uninstall the r8168 driver through Manjaro Settings Manager, restart. This will then load the r8169 kernel module which has been better on more recent kernels.

Test kernel 4.20 as well as others for improvement. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

Also, set your connection speed to auto-negotiation.

Please post:

inxi -Fxxxz
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

Please post all terminal commands as text with code tags, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

Yes. thats why I dont understand this problem too. After the fresh installation I didnt had those problems and after some hour of use i got it.
Maybe u missunderstood me.

  1. I dont use any vpn with my manjaro distribution. I have a VPN to have remote access to my home nas. Manjaro has nothing to do with it.
  2. Even if the ping seams to be good, i get timeouts even from the repository as u can see in the last picture. No firewall installed… except if Manjaro has one enabled by default…

To the others… i ll try and answer later.

Well regardless, start with the simple things:

  1. reboot your home router
  2. reboot your computer
  3. try again.
1 Like

First of all ty for all those answers. First… here my entire log even if I dont understand for what the rest could be important for my problem.

System:    Host: Harold-Manjaro Kernel: 4.20.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.1 
           tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: MAXIMUS VIII FORMULA v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 3801 date: 03/14/2018 
CPU:       Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64152 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nvidia v: 415.27 bus ID: 01:00.0 
           chip ID: 10de:1401 
           Display: x11 server: X.Org 1.20.3 driver: nvidia compositor: kwin_x11 resolution: 1680x1050~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: NVIDIA GM206 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fba 
           Device-3: Logitech G933 Wireless Headset Dongle type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 
           chip ID: 046d:0a5b 
           Sound Server: ALSA v: k4.20.11-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: ath10k_pci v: kernel 
           port: e000 bus ID: 07:00.0 chip ID: 168c:003e 
           IF: wlp7s0 state: up mac: <filter> 
           Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: d000 bus ID: 09:00.0 
           chip ID: 10ec:8168 
           IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.29 TiB used: 16.58 GiB (0.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 950 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 2B0QBXX7 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 1B2QEXP7 scheme: GPT 
           ID-3: /dev/sda vendor: Western Digital model: WD20EARS-60MVWB0 size: 1.82 TiB speed: 3.0 Gb/s serial: <filter> 
           rev: AB51 scheme: MBR 
Partition: ID-1: / size: 47.81 GiB used: 16.55 GiB (34.6%) fs: ext4 dev: /dev/nvme1n1p4 
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 39 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 23% 
Info:      Processes: 228 Uptime: 14m Memory: 31.35 GiB used: 1.52 GiB (4.9%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 running in: yakuake inxi: 3.0.30 


  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8169"
  Device File: enp8s0
  Link detected: yes
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Model: "Intel Ethernet Connection (2) I219-V"
  Driver: "e1000e"
  Device File: enp0s31f6
  Link detected: no
    Driver Status: e1000e is active
    Driver Activation Cmd: "modprobe e1000e"

Ok… before I start to remove, change and so on stuf like drivers and so on… I would like to know what is that much different in the handling of the connection between Manjaro and other distros. I mean, I dont have any problems with other ones. I already tried the connection over my PCIe Adapter @ Realtek but I have the same issue. Do I rly have to remove the driver from my Intel one? Neverthless I still need both connections.
With the Kernel 4.20.11-1 its the same. The only network changes that could happened would be from the installed Docker and VMWare Workstation even if everything was set by default and as I already mentioned, its not my first clean installation of manjaro with the same issue.
I would be rly unhappy to change to Mint just cause of this cause manjaro has some rly nice stuff that works from the scratch.

What I tested atm. is the new latest Kernel, the connection speed to auto-negotiation with MTU 1500 and I added the different resolv.conf according to this site: https://wiki.manjaro.org/index.php?title=Set_DNS_and-or_Nameservers

If you’re not running on bare metal there’s really no telling where the problem lies.

To test the r8169 driver do this:

Run the these commands separately with a few seconds between entering each command in the terminal:

Do not cut and paste all the commands together at once. Enter each command individually.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set enp8s0 down

sudo modprobe -r r8168

sudo modprobe r8169

sudo ip link set enp8s0 up

sudo systemctl start NetworkManager

nmcli networking on

I already removed the r8168 over the Manjaro Settings Manager and restarted. After this I updated my post with the new output of the Driver Status: r8169 is active
Nevertheless I did what u wrote again over the terminal. Still feels the same :frowning:
I will gona turn on my Mobo WLAN. Lets see if it gona be the same…

Test with kernel 4.9 (reported to have better speeds for I-200 series adapters).

Also, check for a bios update.

Bios is already on the latest version.
Still nothing changed… I cant imaginate what the problem could be because after using Linux Mint for some hours, the connection remained the same. @ perfect. Mint uses the same drivers as Manjaro. The single difference is the kernel. Will try the same too to make sure everything is the same.

Edit: Btw. It doesn`t matter if its connected over cable or wlan. Still the same issue. This problem must be somewhere else.

The only difference between the distros are the kernel and the driver from the Realtek one @ Manjaro: driver: r8169 v: kernel Mint: driver: r8169 v: 2.3LK-NAPI

----- From Linux Mint -----

System:    Host: harold-mint Kernel: 4.15.0-45-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.9 
           wm: muffin 4.0.6 dm: LightDM 1.26.0 Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: ASUSTeK model: MAXIMUS VIII FORMULA v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 3801 date: 03/14/2018 
CPU:       Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64128 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nvidia v: 390.77 bus ID: 01:00.0 
           chip ID: 10de:1401 
           Display: x11 server: X.Org 1.19.6 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1680x1050~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 390.77 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK Sunrise Point-H driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fba 
           Device-3: Logitech type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 chip ID: 046d:0a5b 
           Sound Server: ALSA v: k4.15.0-45-generic 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: ath10k_pci v: kernel 
           port: e000 bus ID: 07:00.0 chip ID: 168c:003e 
           IF: wlp7s0 state: down mac: <filter> 
           Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: 2.3LK-NAPI port: d000 
           bus ID: 09:00.0 chip ID: 10ec:8168 
           IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.29 TiB used: 9.98 GiB (0.4%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 950 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 2B0QBXX7 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 1B2QEXP7 scheme: GPT 
           ID-3: /dev/sda vendor: Western Digital model: WD20EARS-60MVWB0 size: 1.82 TiB speed: 3.0 Gb/s serial: <filter> 
           rev: AB51 scheme: MBR 
Partition: ID-1: / size: 47.81 GiB used: 9.95 GiB (20.8%) fs: ext4 dev: /dev/nvme1n1p3 
Sensors:   System Temperatures: cpu: 28.0 C mobo: N/A gpu: nvidia temp: 42 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:      Processes: 237 Uptime: 11m Memory: 31.35 GiB used: 1.52 GiB (4.9%) Init: systemd v: 237 runlevel: 5 Compilers: 
           gcc: 7.3.0 alt: 7 Shell: bash v: 4.4.19 running in: gnome-terminal inxi: 3.0.27

Hey… this problem is rly annoying… but it seams to be a problem of the KDE one…
This time I did the following one.

  • Installing Manjaro : Gnome and everything went perfect. I have no problems with it.

Then I downloaded the Manjaro:KDE again and made it bootable. BUT I noticed, that even on the bootable stick without installing it the Firefox takes long to load and so on…
What exactly is that different from gnome to kde?

Different network manager applet for one.

Perhaps you might want to try installing connman + cmst-git.

You could also try wicd which is another alternative to Network Manager.

Be sure to stop, then mask Network Manager.

Good luck.

Would u maybe like to help me a bit with the commands order and so on?
Because if I fail, it could be hard to gain again the internet connection without being able to search for informations on the internet. :sweat_smile:

Install connman:

sudo pacman -S connman

Install cmst from the AUR for a system tray applet.

yay cmst-git 

Or, if you have enabled AUR support in your graphical package manager then you can use Pamac or Octopi for the installation.

Once you have connman up and running disable Network Manager.

Turn off Network Manager

sudo systemctl stop NetworkManager

Mask (disable completely) Network Manager:

sudo systemctl mask NetworkManager.service

Mask (disable completely) Network Manager dispatcher:

sudo systemctl mask NetworkManager-dispatcher

If you use the NetworkManager-wait-online.service, then mask it as well:

sudo systemctl mask NetworkManager-wait-online.service

Using “unmask” instead of “mask” in the above commands will enable everything again (if you don’t find connman an improvement).

Restart your computer after making those changes.

Good luck.

First of all… Thank you for all the invested time!

I think… I managed to bring it to work. Your suggestion with the connman and cmst ditn worked. After this I wanted to see if its a problem of my hardware, or of the os so I tried it on my Notebook.
I noticed, that I have the same problems so…
After this I came to the idea to try IPv6 because as I said, it looked like a dns problem and so on. Normaly I deactivate always IPv6 on the router and so on so…

  • Activating Native IPv6 on my Router
  • Made sure that Manjaro got an IPv6 Address
  • Thats IT…

I tested it now for about 5 hours and everything seams to work now. I noticed, that as I had the problem, even if I did an web request with firefox, the connection stand still at 0 B/s | 0 B/s .
Now it works as it should and everything is loading nearly instant. Still… this is a strange issue cause I encountered it just on ArchLinux based OSes (Yes, the Manjaro:Gnome one had after 1 day the same symptoms). Ubuntu / Debian / MacOS / Windows hadnt had this problem.
As soon as I’m back home, I’ll try to disable IPv6 in Manjaro again.

1 Like

Well thank you so much for updating us on your solution. Wow, I must say that was a good catch on your part. I guess I’m going to have to start telling people to reverse the IPv6 ban if there is no improvement.

I generally just leave IPv6 disabled on my system. I guess as time moves on more ISP’s will be converting to IPv6 usage. I’ll have to keep my eyes open for this pitfall as IPv6 usage becomes more common in the future.

Glad you got it working. Nicely done.

Its still a pretty strange problem because as I said, none of the other devices and OSes had this problem. I tried a lot of stuf without success… duno…
Anyway it would be a good idea to start a bit with the IPv6 because all the new provider have limited options because the range of the free IPv4 addresses becomes to be rare.
I got normally only an internal(private) IPv4 and an native IPv6 but the problem is… I have a NAS Server at home and wanted to do some other stuf but it becomes to be hard when it comes to open ports and so on. When your phone or at work u have only IPv4 then it is nearly impossible to use ur NAS at home. It exists port mapper to redirect the trafic from ipv4 to ipv6 and vice versa but for this u need another service with IPv4 and IPv6 and so on. I dont want to redirect the trafic over server that aren`t under my control.
Anyway… my new provider were very friendly and gave me an public IPv4 too for free. Normally I had to pay for this.
The popularity of the IPv6 will increase in the next years I think.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.