Slow internet: WiFi Atheros QCA9565 / AR9565 Wireless Adapter

Hello, It’s my second week in linux and so far I didn’t find many problems and usually when I find a problem there are plenty of resources to fix it. But, this wifi problem I can’t seem to fix it. My connection is extremely slow and unstable. I don’t know which information is needed for you to help so please guide me to what information I should provide.

OS: Manjaro XFCE
Wifi Card: Atheros QCA9565 / AR9565 Wireless Adaptor
Kernel: 5.4 LTS

You should at least provide info of:

  • What your definition of “Slow” means in detail.
  • Weather you are connecting using 2.5GHz or 5GHz.
  • The vendor:device ID’s of your WiFi adapter.
  • The driver you use for your WiFi card.
  1. Connection goes down in speed to something like 60kb which is unusable. When I restart the system it goes back to 20mb but after 10 mins it goes down again to 600kb

  2. Using 2.4GHZ

  3. How to provide that?

  4. As I said I’m new to linux but after looking through the arch wiki I found that its: ath9k

Then as usual please see:

System Information ( inxi ) Results:

  Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=68a7b56a-51ff-488b-b590-03703f2a654a rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel, plank wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: TOSHIBA product: Satellite C50-A393 v: PSCG8V-03K00FAR 
  serial: <filter> 
  Mobo: Intel model: PT10F v: Type2 - Board Version serial: <filter> 
  UEFI: Insyde v: 1.40 date: 04/22/2014 
  ID-1: BAT0 charge: 40.7 Wh condition: 40.7/48.4 Wh (84%) volts: 12.3/10.8 
  model: TKBSS NS2P3SZMC4WR type: Li-ion serial: N/A status: Full 
  Info: Dual Core model: Intel Core i3-3110M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19167 
  Speed: 1198 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 1197 2: 1203 
  3: 1197 4: 1196 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Toshiba driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Display: x11 server: X.Org 1.20.10 driver: intel display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.2.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Toshiba 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.4.80-2-MANJARO 
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lite-On driver: ath9k v: kernel port: 2040 bus ID: 02:00.0 
  chip ID: 168c:0036 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 689.33 GiB used: 25.04 GiB (3.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 1102 scheme: GPT 
  ID-2: /dev/sdb vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 3M scheme: MBR 
  ID-1: / raw size: 80.91 GiB size: 79.13 GiB (97.81%) used: 25.01 GiB (31.6%) 
  fs: ext4 dev: /dev/sda5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 217 Uptime: 6m Memory: 7.65 GiB used: 1.33 GiB (17.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1195 lib: 349 
  flatpak: 0 Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.1.08

What were you doing while you got that info and ofcourse where did you gain this info?

It happens randomly during browsing. Currently after restarting the OS its back to normal but over time it goes back down.

Also to mention I just added this line according to the arch wiki inside /etc/modprob.d/ath9k.conf: options ath9k ps_enable=0.

It’s been stable so far I guess it was something to do with Power saving but I’m going to monitor over time again.

And for the source of information its usually using SpeedTest or Fast to measure my internet speed

Speed tests over the internet can vary for various reasons that can not be controlled by your side, so you should never mention those results with this kind of issues.
Only speeds between your computer and your modem can be controlled.


  • Please use a newline when a sentence ends when you write on the forum, i (and others) have a hard time reading walls of text…
  • I adjusted the topic title to reflect what you mentioned.

I’ve edited the reply it should look better now.

Can you please tell me what do you mean by between your computer and modem? Do you mean using the ping command inside the terminal?

P.S: Speed is down again to 100KB/s but since its not a right measure I’m going to wait for the right method

What i mean by that is the hardware’s connection speed.
Ping is something different, it’s like a “reaction time” of your connection not the speed it operates at.
Your connection speed can be light-speed, while your ping can be slower as a turtle if the computer on the other side of your connection is slow to reply to the ping request…
(Some systems don’t reply at all even)

Oh, now the difference is more clear.

But since browser speeds are not a right way to measure, How can I correctly measure the speed to monitor the changes and post it here for you to see?

For that you would need to ask the driver at what speed it operates, i don’t know how to request that for a WiFi driver because i use an Ethernet connection (wired).

I can see mine with this command: networkctl --no-pager status -a
It could work for you also, or it may not…
Maybe others more familiar with WiFi stuff know a different way :wink:

I just got a suspicious message that might be the problem, I ran your command and got this:

WARNING: systemd-networkd is not running, output will be incomplete.

Failed to query link bit rates: Unit dbus-org.freedesktop.network1.service not found.
Failed to query link bit rates: Unit dbus-org.freedesktop.network1.service not found.
Failed to query link DHCP leases: Unit dbus-org.freedesktop.network1.service not found.
● 1: lo                                                                 
                     Link File: /usr/lib/systemd/network/
                  Network File: n/a                                     
                          Type: loopback                                
                         State: n/a (unmanaged)                         
                           MTU: 65536                                   
                         QDisc: noqueue                                 
  IPv6 Address Generation Mode: eui64                                   
          Queue Length (Tx/Rx): 1/1                                     

So first of all what is systemd-networkd? and should I enable it?

It’s a service that is not enabled by default, but should not interfere with normal operations (only a very specific issue could)

You could try to start it before you try that command, and stop it afterwards…
If you like to use that command a lot, or for whatever reason like it, you could enable it so it starts at boot.
I don’t use NetworkManager for my network setup that’s why i have it enabled…

The slow wifi is unbearable I had to install windows yesterday as dual boot. I was wondering if the problem can be fixed or not.

That’s still unclear because we have not pin-pointed it’s cause yet…
It could be driver, it could be your Wifi settings in your router or even your location in respect to your modem…

Is it same under that OS?

It’s probably the driver because I’'m right beside the router and for the router settings they are defaulted by the ISP.

When I switched to windows my wifi was fast again and very stable so its a driver problem

Are you using 5GHz as WiFi?
Because some drivers have problems with band-usage on 5GHz, so in that case you can try to force a lower channel in your router’s WiFi settings wrt 5GHz channel.
(eg. Channel 40)
That info i picked-up from another thread on these forums… (see #wifi)

No, Im using 2.4GHz, my router doesnt support 5GHz

Also to mention, I tried a D-link wifi usb and its way more stable than the built it Atheros wifi so again this confirms that its a driver problem but I’m new to linux and I dont know how drivers are managed manually.

I can’t keep using my D-link usb as I dont have a spare port So I need my built in wifi.

Take a look at these, these users seem to have had the same issue: