Slow internet connection in some applications but not in others

My internet connection seems to work very well in some applications, and terribly awful in others:
I checked the speed on speedtest dot net and the result is 350 mbps download and upload, I’ve downloaded a 4gb opensuse iso in 10 minutes, however the output from the speedtest-cli is about 1 mbps download and upload, and I get that same speed in some steam games, when installing packages from pamac it took me 1 hour to download 700 mb.
I googled the issue and maybe it could be related to ipv6 or to dns but i dont know how to proceed, I have tried to setup dnsmasq as instructed in the archwiki but no success (maybe I messed up?).

System:    Host: osmium Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81FE v: Lenovo ideapad 330-15IKB serial: <superuser/root required> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40679 WIN serial: <superuser/root required> UEFI: LENOVO v: 8TCN51WW 
           date: 12/08/2018 
Battery:   ID-1: BAT0 charge: 26.9 Wh condition: 26.9/30.0 Wh (90%) 
CPU:       Topology: Dual Core model: Intel Core i3-7020U bits: 64 type: MT MCP L2 cache: 3072 KiB 
           Speed: 900 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
           Device-2: Realtek EasyCamera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.8 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.9.1-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: 64:1c:67:a8:c8:06 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci 
           IF: wlp2s0 state: up mac: 00:05:16:65:94:c3 
Drives:    Local Storage: total: 931.51 GiB used: 16.46 GiB (1.8%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10 size: 931.51 GiB 
Partition: ID-1: / size: 423.11 GiB used: 16.44 GiB (3.9%) fs: ext4 dev: /dev/sda5 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 38.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 208 Uptime: 1h 09m Memory: 3.75 GiB used: 2.01 GiB (53.4%) Shell: Zsh inxi: 3.1.05 

Thanks in advance.

I have the same adapter and had a similar speed degredation issue with the 5.9.1 kernel. Whatever caused the issue is fixed for me with the 5.9.3 kernel release. You’ll see it in the next stable snap or you can switch to the testing branch.

Could you please open a terminal and input sudo nano /etc/default/grub , then add the following to the line starting with GRUB_CMD_LINE_LINUX_DEFAULT="

  • ipv6.disable=1

After which you may hit ctrl+s followed by ctrl+x.
You may then execute sudo update-grub .

Then, still in the terminal, enter nm-connection-editor , and a GUI window will appear.

Select the network you are currently connected, then select the gear icon in bottom left corner.
You may then set the MTU to 1495 , then hit save.

You may then reboot!

Pardon me, but I think you may have missed my post :point_up:

Why? What will that accomplish?

Why? automatic is default and should not need to be changed in most cases. Besides, default MTU is usually 1500.

Please don’t recommend blanket “solutions” like that without explaining why you think they will work.

1 Like

Great question, but may I confirm I indeed read your post!

ipv6 often have some performance impact on Qualcomm and Realtek’s older card models, thus may still be a interesting step to try.

The default standardized MTU is 1500, but some network cards and/or routers are extremely sensible to this limit. reducing the MTU size may in some circumstance improve the network stack computation performance and packet decoding, as the card and/or router is not overwhelmed too much, allowing for parallelized processes–if supported device’s firmware.

I hope this may have helped, have a wonderful day! :sweat_smile:

This is definitely not an older card model.

By 5? Good grief.

1 Like

Still worth a try, as regression is still sometimes a thing to consider. But I fully understand your point here.

It does indeed have a exponential performance impact factor, either in the wrong, or in the good, depending on the situation.

Networking, remote data transmission, wireless… All relatively still new technologies still in intensive development! Studying networking is like trying to run after a train in motion :sweat_smile:!

You made your points, indeed. Thank you. In the future, please elaborate like that when you make your recommendations so folks know why you are doing so. :wink:


My most sincere apologies regarding this inconvenience, may I give further informations for future case! :upside_down_face:

1 Like

Updated the kernel to 5.9.3-1-MANJARO and also disabled ipv6 as @The_Quantum_Alpha instructed, no changes, the output of speedtest-cli is 0.99 mbps while speedtest in a browser is 350+ mbps. I’m on wired connection btw, but also tried 5g wi-fi and its the same.

Hm, at least we eliminated a possibility!

:thinking:Could you provide me the output of ifconfig , please?

Thats just your mirrors. In what other areas are you seeing a speed issue?

Sort mirrors and update:

sudo pacman-mirrors -f && sudo pacman -Syyu

The other thing in general is probably DNS.
Just select ‘Automatic (Addresses Only)’ in Network Manager settings … then enter your preferred DNS.
(ex, for cloudflare use,

1 Like

I can’t play my favourite game due to this thing, I think it is something with my providers.

Did that, and tested google’s dns, opendns and cloudflare, still no improvement.

As @Vaullas mentioned, steam games are highly impacted by this issue, causing them to be nearly unplayable with a 1 mbps connection