Slow experience with loading stuff in Manjaro KDE

I’ve never really questioned it much, because I thought it was relatively normal, but using manjaro has never been very fluid for me when things have to load. I know it sounds imprecise, but opening Dolphin takes like 10-15 seconds and then it works great, also okular, firefox or even the manjaro main menu.
This also happens with games. When I have to load a map in csgo or other game, it takes an awfully long time (more than it ever took in windows) loading the map, but then tha gameplay itself is very fluid.

The only thing I have non-standard in my installation is that I have /var in its own partition in a hdd drive because I read somewhere it was better. I use nvidia non-free drivers.
The system is a 7gen core i7, nvidia1050ti laptop version and 8gbs ram.

I recently questioned all of this when I had the chance to use ubuntu in a school pc and it was so fast and responsive that made me think there’s something wrong with my laptop.

Does anyone have any suggestion? Thanks a lot.

EDIT: As someone pointed out, maybe the /var in a separate partition is not the best idea. If there’s nothing weird with the inxi output now, could reinstall manjaro without the /var separate partition maybe do something? How would I do it without losing information and configuration of things installed?
I update with the output of the inxi command:

Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=48313523-3d79-4512-a060-6cee9bff637c rw quiet apparmor=1
  security=apparmor resume=UUID=3dd24e0e-9056-4731-a854-9d15aa817ad5
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: GL62M 7REX v: REV:1.0
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: <filter>
  UEFI-[Legacy]: American Megatrends v: E16J9IMS.318 date: 05/22/2017
  ID-1: BAT1 charge: 36.3 Wh (100.0%) condition: 36.3/42.4 Wh (85.7%)
  volts: 12.2 min: 10.8 model: MSI BIF0_9 type: Li-ion serial: N/A
  status: Full
  RAM: total: 7.69 GiB used: 6.96 GiB (90.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA
  cache: L2: 6 MiB bogomips: 44817
  Speed: 1294 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1294 2: 1223
  3: 1875 4: 1341 5: 1369 6: 1701 7: 1697 8: 1331
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
  xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Micro-Star MSI
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
  chip-ID: 10de:1c8c class-ID: 0302
  Display: x11 server: X. Org 1.20.13 compositor: kwin_x11 driver:
  loaded: modesetting,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
  Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
  v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
  v: kernel bus-ID: 02:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI
  driver: alx v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 1969:10a1
  class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 1-10:4 chip-ID: 8087:0aa7 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.14 TiB used: 574.39 GiB (49.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: THNSNJ256G8NY
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 0101 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LM048-2E7172
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 236.47 GiB size: 231.76 GiB (98.01%)
  used: 32.67 GiB (14.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 48313543-3d79-4552-a060-6cee9bff637c
  ID-2: /home raw-size: 919.79 GiB size: 904.35 GiB (98.32%)
  used: 532.57 GiB (58.9%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A
  uuid: 040c4572-90c9-4eb8-8aa3-982855fe262e
  ID-3: /var raw-size: 11.72 GiB size: 11.47 GiB (97.90%)
  used: 7.15 GiB (62.3%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A
  uuid: 153e2370-8d5d-4f47-8291-d6fc101f6426
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2 GiB used: 2 GiB (100.0%) priority: -2
  dev: /dev/sda1 maj-min: 8:1 label: N/A
  uuid: 3ddf4e0e-9056-4731-a854-9d25aa817ad5
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Razer USA DeathAdder Chroma type: Mouse,HID,Keyboard
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 1532:0043 class-ID: 0301
  Device-2: 1-7:6 info: MSI steel series rgb keyboard type: HID
  driver: gt683r_led,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 2mA
  chip-ID: 1770:ff00 class-ID: 0300 serial: <filter>
  Device-3: 1-10:4 info: Intel Wireless-AC 3168 Bluetooth type: Bluetooth
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 8087:0aa7 class-ID: e001
  Device-4: 1-12:5 info: Realtek RTS5129 Card Reader Controller
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
  class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 63.0 C mobo: 27.8 C gpu: nvidia temp: 54 C
  Fan Speeds (RPM): N/A
  Processes: 300 Uptime: 13h 32m wakeups: 2 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 alt: 8 clang: 12.0.1 Packages: apt: 0
  pacman: 1995 lib: 504 flatpak: 0 Shell: Bash v: 5.1.8 running-in: kitty
  inxi: 3.3.07

If the system has an ssd that wasn’t the best decision performancewise.

“Better” in what sense?

Yeah, months later I realised that’s true

It was along the lines of less stress to the SSD, I didn’t really know a lot back then.

I updated my post with better info.

Boot from live usb and reintegrate /var into / (copy all content while preserving ownership and permission info) and comment out /var mount in /etc/fstab.

Could you provide a little more info into how that’s done, please? It’s great to know I don’t need to reinstall the whole system but I’m not that well versed to know how to do it with a little bit more guidance, sorry.

Thanks a lot for the answer.

  • boot up your system from usb
  • mount your root partition (/) and prepare:
$ mkdir -p /mnt/root
$ mount /dev/sda2 /mnt/root
$ mkdir -p /mnt/root/var
  • mount your /var partition
$ mkdir -p /mnt/var
$ mount /dev/sdb2 /mnt/var
  • copy the contents:
$ rsync -aAXH /mnt/var/ /mnt/root/var/
  • edit /etc/fstab (located at /mnt/root/etc/fstab at this time) and disable the /var mount by placing a literal # in front of it
  • reboot

I’ve used /dev/sda2 and /dev/sdb2 as given by your inxi output.
Be aware that these can possibly change on each boot and also be different when booting from usb.
Take your time and extra care to identify your / and /var partition properly before copying content.
The partition/filesystem sizes are quite different - should be enough to discern them properly. You can of course also take a look at the mounted filesystems after each mount step to verify.
You could also use the non-changing UUIDs as they are used in your /etc/fstab to be sure.

Wow, thank you very much, it worked perfectly and now I have /var set up in the SSD.

I’ve noticed the system si way faster at booting up, but it still lags a little (it’s gotten better) while opening some menus or PDFs, and I’ve tried the map loading in genshin impact and it’s very slow still.

Any ideas of why could this be?

Perhaps those actions access your $HOME which still resides on your HDD.
You could re-integrate that into / as well and only split off and symlink back large video/music collection for example.

Maybe I’ll try that, for now, seeing that it’s already faster, I’ll mark it as solved.
Thank you very much for everything.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.