Slow download speed but upload is fine


I recently installed the Manjaro KDE on a 2022 Legion 5 Pro. Everything is working fine except the ethernet download is slow. The strange thing is, the upload is fine. I have Google Fiber, and in Windows, I can get a solid 1Gb up/down on Ethernet. When I boot to Manjaro, I’m getting 150/600ish on ethernet but on Wifi I can pull 400/400 but then it sometimes disconnects (seems to have issues with Asus AIMesh and sticking to a node). I did install tlp and ran powertop --auto-tune, so I’m not sure if that had anything to do with it, but given that I can push it on upload, I don’t think that’s the problem. I’ve tried both the 8168 and 8169 driver and multiple kernels. I can see the connection at the switch is 1000/full duplex, and I’ve configured the network to both automatic and manual, and tried various mtu. The gui in kde, when on automatic, actually shows 100Mbs/Full, but inxi is showing 1000. I was earlier on the gnome version and I thought I tried/saw 1000, but I’m not sure (I have a spare partition, so I’ll try to reinstall and see it it’s working. ) I’ve tried various speedtest sites, and they all give the same results. I’ve gone through nearly every post I can find, and nothing is helping.

Here’s the output of inxi

Kernel: 6.1.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
Desktop: KDE Plasma v: 5.26.5 Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 82RG v: Legion 5 Pro 16ARH7H
Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN
serial: UEFI: LENOVO v: JUCN57WW date: 12/06/2022

Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
bus-ID: 03:00.0
IF: wlo1 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8168 v: 8.050.03-NAPI port: 4000 bus-ID: 04:00.0
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac:

This is more likely to create problems than solutions.
Generally speaking - applying everything from powertop is a bad idea, a better idea is reading its suggestions and applying ones you are comfortable with.

TLP is less likely to be as far reaching, but as power management software … its unlikely to ‘fix’ networking by being installed.

But let me make sure … are you saying you always had these issues, or that they are new after your tlp and powertop forays?

A few other things…

There have been posts about this hardware since 3 forum iterations ago.
That its working this well (at all) is nice I guess.

My search shows this BIOS out of date.

Have you applied any configurations to this module ?
(ex: /etc/modprobe.d/iwlwifi.conf etc)

1 Like


Thanks for the reply. I did a few things this morning just to make sure. Did a fresh install on a separate partition, issue exists. Updated the bios, issue still exists. I never touched iwlwifi.conf.

Like I said, the slowness is only in download, not in the upload and only on Ethernet. I’m seeing 700Mbps upload but download is 150Mps when connected to Ethernet. Over wifi, it’s ~300/300.