Slow browser video on a thinkpad x220

hi there, I know this sounds so standard, I searched the forum but couldnt find anything related:

i have very bad video performance in my browsers, for youtube videos and the likes, be it on firefox or vivaldi, on my old thinkpad x220.

other than that videos run well in smplayer , overall performance of manjaro is great.

videos often run well for a few minutes and then start to freeze or load or stutter…

any recommendations of what i could check? thank you!!!

First checks might be:

thank you cscs!! I read through the page and tried some of the mods and tried to enable hardware acceleration and all but it does not seem to change. the weird thing is, that videos start to play well, sometimes play well for a few minutes and then i get the stuttering and loading etc. not sure if this points to some other problem? also that it affects both browsers i use in the same manner but none of the video players is kind of strange.

If you run some resource tracker … like htop … do you see anything like RAM being maxed out?

Might as well share general system info:

inxi -Fazy

the ram usage stays pretty low on 3,5% usage,

 inxi -Fazy

  Kernel: 6.5.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=52fd1a07-74d7-4215-b689-5c0818e0c9e6 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 4291U7E v: ThinkPad X220
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 4291U7E serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: 8DET56WW (1.26 ) date: 12/01/2011
  ID-1: BAT0 charge: 43.6 Wh (100.0%) condition: 43.6/62.6 Wh (69.6%)
    volts: 12.4 min: 10.8 model: SANYO 45N1172 type: Li-ion serial: <filter>
    status: full
  Info: model: Intel Core i7-2640M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 797 min/max: 800/3500 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 797 2: 797 3: 797 4: 797 bogomips: 22332
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Lenovo driver: i915 v: kernel arch: Gen-6 code: Sandybridge
    process: Intel 32nm built: 2011 ports: active: LVDS-1 empty: DP-1, DP-2,
    DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0126 class-ID: 0300
  Device-2: Chicony Lenovo Integrated Camera (0.3MP) driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.6:8
    chip-ID: 04f2:b217 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: AU Optronics 0x106c built: 2010 res: 1366x768
    hz: 60 dpi: 125 gamma: 1.2 size: 277x156mm (10.91x6.14") diag: 318mm (12.5")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Lenovo 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  API: ALSA v: k6.5.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
    driver: e1000e v: kernel port: 5080 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0085 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: Broadcom BCM2045B (BDC-2.1) driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.4:7 chip-ID: 0a5c:217f
    class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 2.08 TiB used: 1.24 TiB (59.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: SanDisk model: SD32G
    size: 28.86 GiB block-size: physical: 512 B logical: 512 B tech: SSD
    serial: <filter> scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LX001-1RG174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM1 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Transcend model: TS256GMSA230S
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: S86A scheme: MBR
  ID-1: / raw-size: 238.47 GiB size: 233.67 GiB (97.99%)
    used: 192.64 GiB (82.4%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  Alert: No swap data was found.
  System Temperatures: cpu: 97.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 4493
  Processes: 218 Uptime: 1d 51m wakeups: 1 Memory: total: 16 GiB
  available: 15.51 GiB used: 2.47 GiB (15.9%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1420 libs: 402 tools: octopi,pamac,trizen,yay
  pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.29

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

First things first … have you tried a not ‘release candidate’ kernel ?
(6.5 is pretty new)

5.15, 6.1 are both LTS worth checking.


And Im pretty sure you have BIOS updates…

1 Like

Yes, I tried all the other kernels , also the LTS kernel,

Bios update is a thing I will look into now, thank you!!

edit: only thing I am always afraid of is updating the bios, as you saw in this ancient version, haha… but I will give it a try this time!

I cannot judge if this is an issue for your system - or it has been fixed - after all a few months has passed

One speculates if using linux510 would work

sudo mhwd-kernel -i linux510
1 Like

Probably not linked to your issue but it is recommendable to have a swap partition or swap file.

1 Like

Maybe that :point_up_2: has something to do with it? You’re just about boiling your CPU. :astonished:

1 Like

ha, could be! no idea why it gets so crazy hot… this would explain why it starts normal and then the stuttering starts…

Obviously the cooling in your system is inadequate. Probably dust in the ventilation ports and/or fans, and most likely the thermal paste between the processor and the heat sink no longer doing its work.

Your machine is a laptop — those are already running hotter than the average desktop computer — and according to your inxi information, it’s already 12 years old. You had better have that machine taken apart, cleaned, have new thermal paste applied, and the heat sink reseated.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.