Slow booting time of Manjaro KDE

Hello,

I’ve installed Manjaro KDE in my Acer Nitro 5 with i5 10th gen and GTX 1650ti. I have a dual boot setup and installed manjaro on SSD. When I boot in windows it takes hardly 10-13s to boot into the home screen But, when I boot in Manjaro It takes more than 1 minute.
I have tried searching for this problem for a solution but nothing works.

I have provided some terminals outputs below :

systemd-analyze

Startup finished in 4.916s (firmware) + 13.092s (loader) + 3.386s (kernel) + 20.596s (userspace) = 41.992s 
graphical.target reached after 20.301s in userspace 

systemd-analyze blame

11.018s systemd-journal-flush.service                         
6.294s lvm2-monitor.service                                  
5.847s snapd.service                                         
3.681s systemd-modules-load.service                          
3.278s dev-sda6.device                                       
3.276s polkit.service                                        
2.767s cups.service                                          
2.465s NetworkManager.service                                
1.883s bluetooth.service                                     
1.882s avahi-daemon.service                                  
1.733s systemd-logind.service                                
1.531s apparmor.service                                      
1.328s systemd-random-seed.service                           
1.220s systemd-udevd.service                                 
1.162s ModemManager.service                                  
892ms var-lib-snapd-snap-core18-1944.mount                  
869ms snapd.apparmor.service                                
857ms var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-145.mount 
817ms var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1514.mount 
662ms var-lib-snapd-snap-joplin\x2djames\x2dcarroll-41.mount
638ms var-lib-snapd-snap-joplin\x2djames\x2dcarroll-42.mount
553ms var-lib-snapd-snap-snapd-10492.mount                  
499ms systemd-tmpfiles-setup-dev.service                    
497ms systemd-rfkill.service                                
401ms upower.service                                        
394ms modprobe@fuse.service                                 
380ms systemd-tmpfiles-clean.service                        
357ms wpa_supplicant.service                                
347ms user@1000.service                                     
312ms udisks2.service                                       
307ms systemd-user-sessions.service                         
293ms tlp.service                                           
266ms modprobe@drm.service                                  
254ms systemd-udev-trigger.service                          
252ms systemd-journald.service                              
245ms modprobe@configfs.service                             
234ms systemd-tmpfiles-setup.service                        
233ms dev-loop4.device                                      
204ms boot-efi.mount                                        
194ms kmod-static-nodes.service                             
154ms rtkit-daemon.service                                  
151ms systemd-timesyncd.service                             
145ms linux-module-cleanup.service                          
132ms systemd-backlight@backlight:intel_backlight.service   
118ms systemd-sysctl.service                                
 86ms systemd-binfmt.service                                
 80ms systemd-fsck@dev-disk-by\x2duuid-0A64\x2dA0A0.service 
 60ms dev-hugepages.mount                                   
 59ms dev-mqueue.mount    

systemd-analyze critical-chain

The time when unit became active or started is printed after the “@” character.
The time the unit took to start is printed after the “+” character.

graphical.target @ 20.301s
└─multi-user.target @ 20.301s
└─snapd.service @ 14.453s +5.847s
└─basic.target @ 14.305s
└─sockets.target @ 14.305s
└─snapd.socket @ 14.305s +420us
└─sysinit.target @ 14.265s
└─systemd-timesyncd.service @ 14.113s +151ms
└─systemd-tmpfiles-setup.service @ 13.801s +234ms
└─systemd-journal-flush.service @ 2.782s +11.018s
└─systemd-journald.service @ 2.529s +252ms
└─systemd-journald.socket @ 2.472s
└─system.slice @ 2.290s
└─-.slice @ 2.290s

Thanks in Advance

Hello,

That happens when the journal file is very large. You can check that with this command from terminal:
journalctl --disk-usage

I recommend doing this: systemd/Journal - ArchWiki to solve the problem. You can set the file larger than in that example, but you will not need more than 50M …

Thanks, @bogdancovaciu for the reply.

I did what you recommended but it didn’t work even it increased boot time. I have pasted the output below :

systemd-anaylyze

Startup finished in 4.891s (firmware) + 19.472s (loader) + 3.579s (kernel) + 22.003s (userspace) = 49.946s 
graphical.target reached after 21.341s in userspace

systemd-analyze blame

11.509s systemd-journal-flush.service                         
 6.152s lvm2-monitor.service                                  
 5.905s snapd.service                                         
 3.791s systemd-modules-load.service                          
 3.533s dev-sda6.device                                       
 3.475s polkit.service                                        
 2.783s cups.service                                          
 2.753s avahi-daemon.service                                  
 2.751s bluetooth.service                                     
 2.750s NetworkManager.service                                
 2.706s systemd-logind.service                                
 1.649s ModemManager.service                                  
 1.137s apparmor.service                                      
 1.052s systemd-tmpfiles-setup-dev.service                    
 1.050s systemd-random-seed.service                           
  867ms var-lib-snapd-snap-core18-1944.mount                  
  855ms var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-145.mount 
  833ms var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1514.mount 
  776ms systemd-udevd.service                                 
  774ms var-lib-snapd-snap-joplin\x2djames\x2dcarroll-41.mount
  728ms snapd.apparmor.service                                
  710ms var-lib-snapd-snap-joplin\x2djames\x2dcarroll-42.mount
  651ms var-lib-snapd-snap-snapd-10492.mount                  
  570ms systemd-timesyncd.service                             
  560ms systemd-tmpfiles-clean.service                        
  458ms systemd-sysctl.service                                
  407ms tlp.service                                           
  404ms systemd-binfmt.service                                
  369ms systemd-udev-trigger.service                          
  368ms upower.service                                        
  357ms modprobe@drm.service                                  
  357ms modprobe@fuse.service                                 
  352ms wpa_supplicant.service                                
  351ms systemd-tmpfiles-setup.service                        
  309ms systemd-journald.service                              
  308ms udisks2.service                                       
  308ms linux-module-cleanup.service                          
  285ms boot-efi.mount                                        
  269ms proc-sys-fs-binfmt_misc.mount                         
  242ms user@1000.service                                     
  185ms systemd-fsck@dev-disk-by\x2duuid-0A64\x2dA0A0.service 
  126ms systemd-update-utmp.service                           
  119ms dev-hugepages.mount                                   
  118ms dev-mqueue.mount                                      
  118ms systemd-rfkill.service                                
  117ms sys-kernel-debug.mount                                
  115ms sys-kernel-tracing.mount                              
  105ms systemd-backlight@backlight:intel_backlight.service

Did you read the part where you clean journal files manually ? Do that, then reboot. I hope you did things the correct way and no typos. :slight_smile:

I tried. It helped me to reduce the boot time. While searching on the internet I found that others linux are take 6-10s to boot up.

Startup finished in 5.934s (firmware) + 2.874s (loader) + 3.591s (kernel) + 14.297s (userspace) = 26.698s 
graphical.target reached after 13.983s in userspace

5.220s lvm2-monitor.service                                  
4.557s snapd.service                                         
3.301s systemd-modules-load.service                          
3.151s dev-sda6.device                                       
2.275s NetworkManager.service                                
2.233s polkit.service                                        
2.162s cups.service                                          
1.730s avahi-daemon.service                                  
1.729s bluetooth.service                                     
1.542s apparmor.service                                      
1.353s ModemManager.service                                  
 878ms systemd-logind.service                                
 848ms linux-module-cleanup.service                          
 776ms var-lib-snapd-snap-joplin\x2djames\x2dcarroll-42.mount
 765ms systemd-rfkill.service                                
 721ms systemd-remount-fs.service                            
 695ms systemd-random-seed.service                           
 670ms systemd-tmpfiles-setup-dev.service                    
 617ms systemd-udevd.service                                 
 483ms var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-145.mount 
 467ms var-lib-snapd-snap-core18-1944.mount                  
 453ms var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1514.mount 
 414ms modprobe@fuse.service                                 
 408ms systemd-journal-flush.service                         
 407ms var-lib-snapd-snap-joplin\x2djames\x2dcarroll-41.mount
 397ms snapd.apparmor.service                                
 395ms upower.service                                        
 388ms var-lib-snapd-snap-snapd-10492.mount                  
 381ms dev-loop0.device                                      
 370ms modprobe@drm.service                                  
 340ms systemd-tmpfiles-setup.service                        
 313ms tlp.service                                           
 305ms udisks2.service                                       
 301ms systemd-journald.service                              
 281ms systemd-udev-trigger.service                          
 223ms wpa_supplicant.service                                
 195ms dev-loop1.device                                      
 179ms dev-loop5.device                                      
 159ms dev-loop4.device                                      
 151ms user@1000.service                                     
 147ms modprobe@configfs.service                             
 140ms systemd-timesyncd.service                             
 126ms dev-loop3.device                                      
 118ms systemd-binfmt.service                                
 113ms systemd-sysctl.service                                
 104ms kmod-static-nodes.service                             
 100ms dev-hugepages.mount                                   
  98ms dev-mqueue.mount                                      
  97ms sys-kernel-debug.mount   

What else I do to decrease this boot time ?